•   
  • 1
  • 83
  • 84
  • 85(current)
  • 86
  • 87
  • 192
  •   
  Thread Closed
[RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
Just double click you "Computer Icon" on the desktop and then in the address bar type

%AppData%\XBMC

That is the fastest way in Win 7
Thanks for the help, edited my post out after you posted. Thanks.
Holy channel over load,

Anybody see this?

http://www.bbc.co.uk/blogs/bbcinternet/2...es_fr.html

Please tell me the makers of this fine addon will update the plugin to accommodate the new channels

Oh Please say it can be so
Hi

I'm very new to this, and need some advice/assistance please ?

I have an Linux media centre with 4GB RAM running the XBMC 10.0 Live, and have installed the v2.3.2 BBC iPlayer plugin.

For catch-up streams, everything is perfect. Programmes play stunningly well.

For Live TV, I have a problem. My Internet link is about 4Mbit/s throughput with about 150ms latency to most of the speedtest servers.

When I select live TV (for example, BBC News), the stream buffers and starts, but the first 3-4 seconds is played back at super-quick time. The news ticker along the bottom races through.

After that, things settle down, but every 30-40 seconds, the stream stalls and I see "buffering." This repeats.

So it appears that the initial buffer fill is being emptied out too quickly, and I never hold enough in reserve to overcome natural network delays.

On a PC running standard iPlayer through a browser, live streams are fine.

Where do I start to debug ? Is this a plugin problem or on XBMC issue ?

Thanks

David
At a guess, the xbmc is selecting a higher rate than your network can handle whilst the browser is streaming at a slower rate. You can set the max rate srtreams will stream at in

iplayer->Settings->Video Stream to use and select the 1500kb/s one.
Oddsodz Wrote:Holy channel over load,

Anybody see this?

http://www.bbc.co.uk/blogs/bbcinternet/2...es_fr.html

Please tell me the makers of this fine addon will update the plugin to accommodate the new channels

Oh Please say it can be so
they are not new channels. bbc iplayer does not even embed them, it just provides links to them. it would need new video resolving code for each external site, which is a lot of hard nail-biting work for a coder, so i don't think they will be added
anarchintosh Wrote:they are not new channels. bbc iplayer does not even embed them, it just provides links to them. it would need new video resolving code for each external site, which is a lot of hard nail-biting work for a coder, so i don't think they will be added

yeh. basically what i was going to say. It's no easier than making a plugin for those other sites, and the problems that go with that - for example 4od http://forum.xbmc.org/showthread.php?tid=74089 (unable towork out how the keys are generated) or http://forum.xbmc.org/showthread.php?tid=74089 (uses a currently unsupported verification handshake).
Finally got around to doing some updates.

v2.4.2 on the site for download. Probably needs some more testing. might be bugs.

changes:

* new settings layout
* proxy support
* option start on directly on tv/radio page
* defaults to 1500kbit, level3 streams added - hd playback should be automatic on streams that support it (and if screen res is high enough)
* various code cleanups/reorganisations (such as settings area)

[edit] correction. 2.4.2 is available. 2.4.1 had a bug with auto video selection quality
Question 
exobuzz Wrote:Finally got around to doing some updates.

v2.4.2 on the site for download. Probably needs some more testing. might be bugs.

changes:

* new settings layout
* proxy support
* option start on directly on tv/radio page
* defaults to 1500kbit, level3 streams added - hd playback should be automatic on streams that support it (and if screen res is high enough)
* various code cleanups/reorganisations (such as settings area)

[edit] correction. 2.4.2 is available. 2.4.1 had a bug with auto video selection quality

Hi exobuzz,

Once you have set the default to be 'start on TV' or 'Start on Radio' how do you access the 'settings' page or return to the 'defaults'?

Thanks for a great addon by the way.

All the best

Andrew
totallymaxed Wrote:Hi exobuzz,

Once you have set the default to be 'start on TV' or 'Start on Radio' how do you access the 'settings' page or return to the 'defaults'?

Thanks for a great addon by the way.

through system/addons or via context menu inside the plugin, or in videos when hovering over iplayer.
exobuzz Wrote:Finally got around to doing some updates.

v2.4.2 on the site for download. Probably needs some more testing. might be bugs.

changes:

* new settings layout
* proxy support
* option start on directly on tv/radio page
* defaults to 1500kbit, level3 streams added - hd playback should be automatic on streams that support it (and if screen res is high enough)
* various code cleanups/reorganisations (such as settings area)

[edit] correction. 2.4.2 is available. 2.4.1 had a bug with auto video selection quality
nice one exobuzz, thanks a lot for maintaining this addon
exobuzz Wrote:through system/addons or via context menu inside the plugin, or in videos when hovering over iplayer.

Got it. Thanks

Andrew
exobuzz Wrote:Finally got around to doing some updates.

v2.4.2 on the site for download. Probably needs some more testing. might be bugs.

changes:

* new settings layout
* proxy support
* option start on directly on tv/radio page
* defaults to 1500kbit, level3 streams added - hd playback should be automatic on streams that support it (and if screen res is high enough)
* various code cleanups/reorganisations (such as settings area)

[edit] correction. 2.4.2 is available. 2.4.1 had a bug with auto video selection quality
Nice one, I'll get it updated on my repo. Big Grin
Hitcher Wrote:Nice one, I'll get it updated on my repo. Big Grin

Thanks. I mentioned your repo on the iplayerv2 google site. hope that's ok Smile
Thanks for the updates. HD is working great and looks lovely on the TV.

Has any one had any luck with the new proxy setting? I had to modify it to also pass my username and password since my proxy requires authentication but it still throws network errors when browsing some folders and won't play any videos.

I pasted in my own proxy code that I've been using since 2.3.2 and it works for videos but breaks radio. It did this in 2.3.2 too. I'll have to see if I can get it sorted.

I changed the code for httpget(url) back to urllib and changed it to urllib2 since urllib doesn't support proxy authentication.
  •   
  • 1
  • 83
  • 84
  • 85(current)
  • 86
  • 87
  • 192
  •   
  Thread Closed
 
Thread Rating:
  • 13 Vote(s) - 4.38 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)4.3813
This forum uses Lukasz Tkacz MyBB addons.