Thread Rating:
  • 1 Vote(s) - 5 Average
projectM black screen
#16
Sorry, I think I was looking in the wrong place for projectM.conf.

Please look in ~/.xbmc/userdata/visualisations directory. Paste contents from there please.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#17
ok, I have turned on debug in settings so here is my new log.
http://en.pastebin.ca/1432246

I run my xbmc with the xbmc command and are starting with fullscreen - only have a 1024x768 Plasma screen and my xbmc is set to that.
in option it says : 1024X768 @ 50.00HZ (FULL SCREEN)

Already tried removing the ProjectM.conf file before and that didn't help.
Reply
#18
Please show me the correct projectM.conf from the location I mentioned in my last post.

Umm..

What does this mean?

#
21:12:21 T:3049805632 M:789598208 DEBUG: Loading: /usr/local/share/xbmc/visualisations/projectM.vis
#
21:12:21 T:3049805632 M:789598208 ERROR: Unable to load /usr/local/share/xbmc/visualisations/projectM.vis, reason: /usr/local/share/xbmc/visualisations/projectM.vis: kan inte öppna delad objektfil: Filen eller katalogen finns inte

Do you even have a /usr/local/share/xbmc/visualisations/projectM.vis ?
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#19
I had someone tell me that is swedish. That means that file does not exist.

Go check.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#20
my ProjectM.conf file I posted earlier is from that location u mention.

And thats correct that is swedish and that is telling me that the file is missing, this reminds me to something I changed an hour ago in my GUI conf file - forgot to undo that.. but changing that back don't help .. still black.. here's a new fresh logfile with the filename correct.

http://en.pastebin.ca/1432274
Reply
#21
Sorry.. No idea Sad

I can't reproduce.

Without details on how to reproduce, we may be at a standstill.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#22
Not easy to debug without beeing able to reproduce the fault - it's very annoying that I have this problem since I have had ProjectM working in the past. I think it was when I switched to Ubuntu Intrepid It went dark.

Im almost considering wiping the whole thing and do a complete reinstall of Ubuntu and the recompile xbmc and hoping that that will make it work.


There is nothing with the graphics drivers I have to adjust to get it to work - I have a Nvidia card it the box?
Reply
#23
tslayer, are you running xbmc in standalone mode (from a folder) or installed as a package/made install?
if you run it standalone it could be what makes it work for you but not for us... btw what is your XBMC_HOME setting set to? for me it's /usr/share/xbmc

what i want to try now is to copy projectm.conf to /usr/share/xbmc/userdata/visualizations and see...
Reply
#24
I compile using regular : ./configure; make; sudo make install

So, it is installed in /usr/local/share/xbmc

And I just use xbmc to run it (which invokes /usr/local/bin/xbmc script).

This is the normal way to do it.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#25
i compile with --enable-avahi --enable-mid --enable-vdpau --disable-pulse --prefix=/usr so that xbmc is installed in /usr/share/xbmc
again, i guess it can depend on one of three things:
1: the distro (what distro are you on?)
2: the hardware/drivers (all of my pcs are nvidia-based, what's yours?)
3: some missing dependency (i have all the ones detailed in README.linux, but who knows)

i can't think of anything else...
Reply
#26
Some more details from me:
- I always compile with --disable-pulse --
- my files are played form SMB
- the XBMC_HOME variable had no influence
- using NVIDIA 9400GT usually with VDPAU enabled, XBMC is set to 1080p
- my XBMC installation is located in /user/share/xbmc.
Reply
#27
I have nvidia 9500GT. vdpau enabled. pulse enabled/disabled does not matter as I have tested both.

I use ubuntu 8.04(32-bit). Latest beta drivers from nvidia. 185.18.#.

For arguments sake, test without specifying a new --prefix. Keep it default and see. That is the only other difference really.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#28
so you're on ubuntu 8.04... this seems to me to be a BIG difference
i made uninstall and re-made without any prefix, so now it's installed in /usr/local/share/xbmc
i used the prefix because, as far as i can remember, ppa builds used /usr instead of the default /usr/local
no difference at all... my next move will be to try live, as it should e jaunty based, so if it does work it myst be something with my environment

will let you know

edit: just noticed that, even if i exported XBMC_HOME i have a line in the terminal log saying "[PresetLoader] ENOENT error. The path "/usr/share/xbmc/visualisations/projectM" probably does not exist. "man open" for more info."
will reboot and see if anything changes
Reply
#29
mmmmmmmh... somehow XBMC_HOME gets hardcoded in projectm at configure time, as even rebooting gave me the same error
anyway, made reallyclean and re-configured, and noticed that i have a warning regarding ftgl not being installed (i guess this is to show track names and so on)
anyway, just installed libftgl-dev (shouldn't it be listed in README.linux?), re-configured, re-made, re-made install (in /usr/local) and say what? nothing changed Sad

p.s. just noticed that the preset path is not hardcoded during configure, but is in .xbmc/userdata/visualizations/projectM.conf
edited that too Smile
Reply
#30
XBMC_HOME should not be needed.

Show me your console output.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply



projectM black screen51