Thread Rating:
  • 0 Vote(s) - 0 Average
[LINUX] VDPAU and embedded SSA/ASS subtitles?
#1
Question 
Hi,

I was wondering if VDPAU and embedded subtitles are being worked on? I've tried a search on the forum and quite a few people are acknowledging this but is it actually in the "todo" list to get it fixed?

Would love it if it's acknowledge. Can anyone give me an update on this?
Reply
#2
A ticket has been opened on trac (http://trac.xbmc.org/ticket/6168). Feel free to post on the ticket if you have something to add to the discussion. It's been open for 2 months and the milestone has been changed to 9.10 (Next stable?).
Reply
#3
This is being worked on now
Reply
#4
nolem Wrote:This is being worked on now

woo hoo!

Can't wait to test this out.
Reply
#5
nolem Wrote:This is being worked on now

This is great news!

I just spent this weekend configuring my Asrock ION 330 and disaster struck when I discovered there was an issue with VDPAU and subtitles. This is a major issue for me as 80% of the stuff I watch is Anime with subtitles!
Reply
#6
nolem Wrote:This is being worked on now

That is some good news! I watch a lot of anime too and i have to switch back to Advanced Shaders instead of VDPAU (i have 8400gs).

when there are patches that need testing, let me know Wink
Reply
#7
Shameless bump as I just submitted a patch adding this support. See the ticket for details.
Reply
#8
Awesome!! Too bad the codebase is so unstable right now.
Reply
#9
Yeah!

Thank you for the patch and same for me: looking forward for the linux branch to stabilize and the svn ppa to be updated Smile

Again, thank you!
Reply
#10
Looks like i'll be getting an nvidia card pretty soon.
Reply
#11
Darn, they denied the patch. Hopefully that other implementation he's talking about gets added soon.
Reply
#12
If the other implementation simply needs some cleanup I can see it getting committed soon. I like the sound of the other solution more than my own given it takes care of the problem for all renderes. If you're impatient you can always use my patch in the meantime, it's what I'll be doing.
Reply
#13
Now my XBMC (installed 5 days ago) will crash (shutdown) when I browse for .sub/.idx-subtitles. I use VPAUD.

Is this fixed in the patch, Kirov? How can I apply that patch?
Will this problem be fixed in a upcoming xbmc release?
Reply
#14
duttzi Wrote:Now my XBMC (installed 5 days ago) will crash (shutdown) when I browse for .sub/.idx-subtitles. I use VPAUD.

Is this fixed in the patch, Kirov? How can I apply that patch?
Will this problem be fixed in a upcoming xbmc release?

You should probably start a new thread and post a debug log. Make sure you read the "post about a problem in a useful manner" thread before you do so.

It's pretty hard to help you if you don't post any specifics. "Installed 5 days ago" tells us nothing. You could have installed a two year-old build, or a two hour old build.

If you installed a really recent build, it's probably because the code in the svn is sort of unstable right now.
Reply
#15
A BIG thanks to whom worked on this.
Tested a couple of minutes ago with a fresh svn compile: now styled subs on all the fansubs I've tried.
Reply



[LINUX] VDPAU and embedded SSA/ASS subtitles?00