how to remove music from library?
#31
Thanks ... all working ... and with Album art this time! So Network Shared Folder has worked ... well almost! Of the 200 or so Albums at that location, only 132 show in xmbc! Any ideas? I've cleaned the Library and rescanned, but still missing some. And curiously, in the same locations on the Win7 machine.

So,

--- shared path/music
--- Artist 1
--- Album 1
--- Album 2
--- Artist 2

etc. etc.

Album 1 made it into the Database. Album 2 didn't.
Reply
#32
briddles Wrote:Thanks ... all working ... and with Album art this time! So Network Shared Folder has worked ... well almost! Of the 200 or so Albums at that location, only 132 show in XBMC! Any ideas? I've cleaned the Library and rescanned, but still missing some. And curiously, in the same locations on the Win7 machine.

So,

--- shared path/music
--- Artist 1
--- Album 1
--- Album 2
--- Artist 2

etc. etc.

Album 1 made it into the Database. Album 2 didn't.


Checked the Log file and it says this ....

19:06:09 T:2720029552 M:3012882432 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://Brad:<password>@PLAYROOM%2dCOMPAQ/Users/Public/Music/iTunes/iTunes%20Media/Music/Aerosmith/Rocks'
unix_err:'6e' error : 'Connection timed out'

Does that help?
Reply
#33
briddles Wrote:Checked the Log file and it says this ....

19:06:09 T:2720029552 M:3012882432 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://Brad:<password>@PLAYROOM%2dCOMPAQ/Users/Public/Music/iTunes/iTunes%20Media/Music/Aerosmith/Rocks'
unix_err:'6e' error : 'Connection timed out'

Does that help?


... and yet if I exit Library View and navigate to the missing albums over the network, I can see them and stream them.

Very strange ... any ideas?
Reply
#34
Try rescanning and see if you get the timeout for the same directories each time.

JR
Reply
#35
Yes. It does seem so.

As far as the missing albums in Library, seems that was a tagging issue. Fixing that now with 'Picard' ... but the network seems painfully slow and keeps timing out / interrupting playback. Sad
Reply
#36
RealTek network card? There ahve been a few comments in the forums that certain (I don't remember which) driver versions can cause this.

JR
Reply
#37
jhsrennie Wrote:RealTek network card? There ahve been a few comments in the forums that certain (I don't remember which) driver versions can cause this.

JR

Not that I'm aware of. It's a new Acer Aspire R3700 with onboard Wireless LAN.
Reply
#38
Try copying a file from the server to your Revo and time how long it takes. That will give you an idea of the link speed.

JR
Reply
#39
To raise an old thread is tedious I know, but I'm having an issue which (as far as I can conclude) would warrant this feature.

Scenario:

I recently deleted and refreshed my library after re-tagging the lot. This took me over a week to do due to the size of my library.
I'm now in the position where I have a couple of albums which were incomplete, or were still incorrectly tagged. I've updated the tags, but nothing I do will rectify how it's displayed in the library, ie it still displays the old info.

I've cleaned the library, updated the library, gone into file mode and added the folder back to library....nothing works.

If I was able to remove that particular album from the library via the context menu, then I'd easily be able to re-scan it back in via the file mode.

so, in essence this is a plus 1 for this feature.

BTW, i'm still on eden, so if this is a feature in Frodo then feel free to rag me all you want Smile

** edit: I've discovered that the old info was from a compilation album stored elsewhere on my NAS. I changed the album tags on the compilation album to reflect the compilation. Just doing an update now, so fingers crossed this works.

That said, the feature would still be useful methinks. Say I want to change the info on one or two albums by updating the tags. Great, no problem there, but to rescan the entire library by means of a library update is a little over the top.
Reply
#40
(2010-01-12, 06:58)jmarshall Wrote: You can delete the files from the library if you enable file rename/delete I think?
 That can't be done for music library items unfortunately.
Reply
#41
@VikkiXavier

I am not sure if you are asking a question or providing a statement of fact in this 5 year old thread, but if you are looking for a way to remove music from the library, see the following link.

https://kodi.wiki/view/Update_Music_Libr...move_Music
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
how to remove music from library?0
This forum uses Lukasz Tkacz MyBB addons.