•  Previous
  • 1
  • 56
  • 57
  • 58(current)
  • 59
  • 60
  • 73
  • Next 
Thread Rating:
  • 9 Vote(s) - 3.67 Average
[RELEASE] Justin.tv (Video) Plugin
(2012-08-08, 02:59)Pednick Wrote: anyone else getting script error?

Seems to be working now, actually started working this afternoon.
(2012-08-08, 21:30)Pednick Wrote:
(2012-08-08, 02:59)Pednick Wrote: anyone else getting script error?

Seems to be working now, actually started working this afternoon.

Strange, maybe pastebin a log if it happens again.
(2012-08-08, 09:53)pch43 Wrote: not working on xbmc ubuntu 11.10
when i select any channel nothing happens. using latest version of plugin

This add-on sometimes requires a newer build of librtmp. If you find 'unknow option jtv' in your xbmc.log you'll need to update to a newer build.

Otherwise, http://pastebin.com your xbmc.log and paste the link here.
(2012-08-03, 00:57)anarckie Wrote: Also, would it be possible to view following/subscribed broadcasts that are currently live? Instead of just the full list?

Sadly, the justin api doesn't provide this information.
Add-on update - 0.3.1
added page-nation to archived videos
added setting "Set default stream quality", most channels only have "Live, iPhone High, and iPhone Low", setting "720p - 240p" will result in "Live" if not listed, if you need a lower bitrate stream use an iPhone setting

Download zip -> http://divingmules-repo.googlecode.com/f...-0.3.1.zip
Repository updated.

A lot of code changes, let me know of any issues.
Trying to watch the teamliquidnet channel, I get a "Script failed! plugin.jtv.video.archives" error. I can watch the archived videos from that channel no problem.


Using 0.3.1.

Any help would be appreciated! Thanks!
Thanks for reporting, will be fixed in the next update. You should* be able to get a stream if you select 480p as default setting.

I'm assuming you have updated your librtmp sense posting the pastebin, if not you'll need to. http://wiki.xbmc.org/index.php?title=librtmp
Is the android version of xbmc supported yet for this plugin ?

because the plugin does not stream for me on android 4.1 jelly bean

XBMC Fever..
Hi, I'm not sure what limitations are for android, but I suspect it's a librtmp issue. Check your log for "unknown option jtv".
Hi All,

I have an AppleTV 1st Gen and *really* wanted to get this plugin to work with in in XBMC. After a bunch of running around, I managed to make it work and thought I'd try and share what I did? Your mileage may vary. It took a bunch of playing around to do this and finally I had some success, so trying to remember it all has been kinda hard....

What I needed was git and Xcode on my iMac that was running Mountain Lion so I could compile this from source.

I think I went to http://rtmpdump.mplayerhq.hu/ and downloaded the latest code. I think I used git and did:

git clone git://git.ffmpeg.org/rtmpdump

I then changed directories into the rtmpdump/librtmp directory. Don't try and compile rtmpdump. I tried and failed miserably, but then realized I don't need that, I only needed the library file. That's why I went straight to the librtmp directory.

In the librtmp directory edited the Makefile to have:


... and added just below that...


I then did from my command prompt:


I then compiled stuff with this command:

make CXXFLAGS="-arch i386 -arch x86_64" CFLAGS="-arch i386 -arch x86_64" LDFLAGS="-arch i386 -arch x86_64"

.... *all* on one line.

I then took the compiled/resulting librtmp.0.dylib and put it on my ATV under
/Applications/XBMC.app/Contents/Resources/XBMC/system/players/dvdplayer with
the same perms as anything else in there.

I then tried to use divingmule's JTV plugin and XBMC would keep crashing.
After reading the xbmc.log it turns out that it was looking for some other
libraries under /usr/lib. I did some sym links to fix that:

sudo ln -s /mnt/Scratch/Users/frontrow/Applications/XBMC.app/Contents/Frameworks/libssl.0.9.8.dylib /usr/lib/libssl.0.9.8.dylib

sudo ln -s /mnt/Scratch/Users/frontrow/Applications/XBMC.app/Contents/Frameworks/libcrypto.0.9.8.dylib /usr/lib/libcrypto.0.9.8.dylib

... (there's *two* sudo lines there, and each line is all one long command) .... because in my log file XBMC I could see it was complaining about these being missing. It probably has to do with the way I compiled it on my iMac. The XBMC Eden app already had these libraries on my ATV, I just needed to put them where the newly compiled librtmp.0.dylib could see them is all and a symlink did that.

I then fired up the JTV app in XBMC and tried it... POOF, we're up.

I thought about trying to upload a copy of the librtmp.0.dylib I compiled so others could just jump to the part about putting it the dvdplayers directory on their ATV1 and then doing the symbolic links, but I'm not used to this forum and don't see a way to upload it anywhere?

Hopefully the info above helps someone else? I *know* the ATV1 is old and slow and stuff, but XBMC runs great on it!

Big props to divingmule for making this addon! Thank you for all your hard work! I've been enjoying JTV thanks to you! :-)

I've been working on getting this plugin working for a few days (on XBMCbuntu 11) and, after another failure, I'm seeking some assistance. I updated my librtmp file via the link in the wiki to no avail. I then followed the instructions posted in post #846 by divingmule without success.

Upon clicking on a channel selection, I'm getting the following error (after the "working" wheel spins for about 10-15 seconds):

Quote:Playback failed: One or more of the items failed to play. Check the log file for details.

Check out the log: http://pastebin.com/9R2k7Q8D

EDIT: After a reboot, I can now play some channels but not others. For example, if I'm trying to watch national US news broadcasts, CNN is working but Fox News is not (same error as above). Suggestions?

Thanks! Smile

Hmm... Yeah, Fox News doesn't work for me either *BUT* if I use a computer and go to the actual site I get the message "This stream may contain content that is inappropriate for some users. To view this stream, please verify you are 18 or older" and the user actually has to click on "I am 18 or older".

I'm thinking that this isn't a problem with librtmp or the jtv addon but rather the site requires this before they'll let the viewer see the stream?
@johnadams: I've never seen that notice myself but I bet that could cause loading problems if the plugin does not acknowledge the message. That's interesting.

On another note: After a little more tinkering, I've gotten the other channels to load but ...with a bit if a caveat. The problem that remains is that the default stream quality has to be set at "iPhone High." This obviously results in a very poor picture quality but, if set any higher, the channel kicks out the error I included in my previous post. So, with this detail added, any suggestions on improving the picture quality?

Hm... on my ATV1 using the iphone stream qualities was horrible. I get the best results using "Live" or "240". The picture is quite good, at least for me anyway. Try those.
@johnadams: the problematic channels will not play if I set the default stream higher than "iPhone High"; I simply get an error message. I'm thinking this is related to the bitrate of each channel. To use the national US news channels as an example: CNN's bitrate is 747 and Fox News is 170. I may be completely off-base here but I'm thinking the issue I am having with playing channels with a higher default stream quality setting is related to this bitrate.

So, being inquisitive, I backed out of the National News list and re-entered twice checking the bitrate of Fox News and I got 216 and 324 respectively for the same channel. Even at 324 I was unable to to raise the default stream quality to 240p. Maybe this is just a limitation of the stream and is nothing that this plugin can remedy. I'm still optimistic that I'm just missing a setting somewhere though. Smile

Despite everything, this is a great addition to my XBMC box and I'm extremely grateful for it! Thanks divingmule.
I can't really get any stream to start playing. I rebuilt rtmpdump to get a newer version of librtmp but it still wont work. Youtube, Revision3 and some other "play" scripts that i have installed all work fine but the Twitchtv/Justintv plugins just wont work. Down below is output of me clicking a stream and getting "Playback failed: One or more items failed to play. Check the log file for details." back. Any tips?

XBMC: 11
OS: Ubuntu Linux 10.04
rtmpdump: version 2.3

ldd output
Quote:[email protected]:~/tar# ldd /usr/lib/i486-linux-gnu/librtmp.so.0
linux-gate.so.1 => (0xb77cd000)
libssl.so.0.9.8 => /lib/i686/cmov/libssl.so.0.9.8 (0xb7759000)
libcrypto.so.0.9.8 => /lib/i686/cmov/libcrypto.so.0.9.8 (0xb7607000)
libz.so.1 => /lib/libz.so.1 (0xb75f1000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7498000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7494000)
/lib/ld-linux.so.2 (0xb77ce000)

Log file
Quote:11:27:24 T:2813315952 NOTICE: -->Python Interpreter Initialized<--
11:27:24 T:2813315952 NOTICE: Mode: 2
11:27:24 T:2813315952 NOTICE: URL:
11:27:24 T:2813315952 NOTICE: Name: esltv_lol
11:27:24 T:2813315952 NOTICE: catId: None
11:27:25 T:2813315952 NOTICE: ---- Stream Type: 720p ----
11:27:25 T:2813315952 NOTICE: --- Stream: rtmp://live-cdn.jtvnw.net/live/[email protected] jtv=e1fa7f239060b811735b0649829702cf7f8245d9:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\22twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22imapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\[email protected]\22,\20\22expiration\22:\201345372045.2590871,\20\22server\22:\20\22akamai\22} ---
11:27:25 T:2813315952 ERROR: EndOfDirectory - called with an invalid handle.
11:27:25 T:3014924096 NOTICE: DVDPlayer: Opening: rtmp://live-cdn.jtvnw.net/live/[email protected] jtv=e1fa7f239060b811735b0649829702cf7f8245d9:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\22twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22imapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\[email protected]\22,\20\22expiration\22:\201345372045.2590871,\20\22server\22:\20\22akamai\22} swfUrl=http://www-cdn.jtvnw.net/widgets/live_embed_player.r2437be639e06a956a1b4bef7c2df9cb5f46d9d08.swf?channel=esltv_lol&referer=http://www.justin.tv/esltv_lol&userAgent=Mozilla/5.0%20(Windows%20NT%206.1;%20WOW64;%20rv:6.0)%20Gecko/20100101%20Firefox/6.0&channel=esltv_lol swfVfy=1 live=1 Pageurl=http://www.justin.tv/esltv_lol
11:27:25 T:3014924096 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
11:27:25 T:2894678896 NOTICE: Creating InputStream
11:27:25 T:2894678896 ERROR: Unknown option jtv
11:27:25 T:2894678896 ERROR: Valid RTMP options are:
11:27:25 T:2894678896 ERROR: socks string Use the specified SOCKS proxy
11:27:25 T:2894678896 ERROR: app string Name of target app on server
11:27:25 T:2894678896 ERROR: tcUrl string URL to played stream
11:27:25 T:2894678896 ERROR: pageUrl string URL of played media's web page
11:27:25 T:2894678896 ERROR: swfUrl string URL to player SWF file
11:27:25 T:2894678896 ERROR: flashver string Flash version string (default LNX 10,0,32,18)
11:27:25 T:2894678896 ERROR: conn AMF Append arbitrary AMF data to Connect message
11:27:25 T:2894678896 ERROR: playpath string Path to target media on server
11:27:25 T:2894678896 ERROR: playlist boolean Set playlist before play command
11:27:25 T:2894678896 ERROR: live boolean Stream is live, no seeking possible
11:27:25 T:2894678896 ERROR: subscribe string Stream to subscribe to
11:27:25 T:2894678896 ERROR: token string Key for SecureToken response
11:27:25 T:2894678896 ERROR: swfVfy boolean Perform SWF Verification
11:27:25 T:2894678896 ERROR: swfAge integer Number of days to use cached SWF hash
11:27:25 T:2894678896 ERROR: start integer Stream start position in milliseconds
11:27:25 T:2894678896 ERROR: stop integer Stream stop position in milliseconds
11:27:25 T:2894678896 ERROR: buffer integer Buffer time in milliseconds
11:27:25 T:2894678896 ERROR: timeout integer Session timeout in seconds
11:27:25 T:2894678896 ERROR: CDVDPlayer::OpenInputStream - error opening [rtmp://live-cdn.jtvnw.net/live/[email protected] jtv=e1fa7f239060b811735b0649829702cf7f8245d9:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\22twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22imapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\[email protected]\22,\20\22expiration\22:\201345372045.2590871,\20\22server\22:\20\22akamai\22} swfUrl=http://www-cdn.jtvnw.net/widgets/live_embed_player.r2437be639e06a956a1b4bef7c2df9cb5f46d9d08.swf?channel=esltv_lol&referer=http://www.justin.tv/esltv_lol&userAgent=Mozilla/5.0%20(Windows%20NT%206.1;%20WOW64;%20rv:6.0)%20Gecko/20100101%20Firefox/6.0&channel=esltv_lol swfVfy=1 live=1 Pageurl=http://www.justin.tv/esltv_lol]
11:27:25 T:2894678896 NOTICE: CDVDPlayer::OnExit()
11:27:25 T:2894678896 NOTICE: CDVDPlayer::OnExit() deleting input stream
11:27:25 T:3014924096 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.jtv.archives/?url=&mode=2&name=esltv_lol&iconimage=http%3A%2F%2Fstatic-cdn.jtvnw.net%2Fjtv_user_pictures%2Fesltv_lol-profile_image-e88a502d8edd5da3-600x600.jpeg]
11:27:25 T:3014924096 WARNING: CreateFile, successfuly opened </home/mythtv/.xbmc/addons/skin.quartz/1080i/DialogOk.xml> instead of </home/mythtv/.xbmc/addons/skin.quartz/1080i/DialogOK.xml>
11:27:25 T:3014924096 NOTICE: CDVDPlayer::CloseFile()
11:27:25 T:3014924096 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
11:27:25 T:3014924096 NOTICE: DVDPlayer: waiting for threads to exit
11:27:25 T:3014924096 NOTICE: DVDPlayer: finished waiting

So I took another look on google for "unknown option jtv" as that seemed to be the big problem and everything was pointing at rtmpdump needing an upgrade. I had the latest stable version so i decided to build the git-version instead and that did the trick. A word of caution though, in the README file it says to use "make SYS=darwin" while compiling in Linux but that doesn't work so instead use the old one "make SYS=posix", and then just copy the librtmp.so.0 file to wherever the old librtmp.so.0 is located now. Hope this helps.
  •  Previous
  • 1
  • 56
  • 57
  • 58(current)
  • 59
  • 60
  • 73
  • Next 

[RELEASE] Justin.tv (Video) Plugin3.679