[linux] XBMCbuntu + HDMI audio // how-to ?
#1
XBMCbuntu out-of-the-box hit 1080p, but only analog audio

how can i use XBMC's digital / analog audio hardware toggles ?
i know hdmi works, i've managed using this solution
( i have the same mobo with intigrated HD 3200 ATI )

can we control the volume of the UI effects ?
my TV is @ 95% Vol & XBMC @ 40-60% Vol
but the UI effects are always @ 100% Vol ... too load
do i only have 2 options -- 100% / OFF ?
rPi 2&3 | android phones | fireHD8 | linux | win10 + NFS NAS w/ mySQL + props to...
libreElecyatse, titan, AELflexGet, context.manageTags (a zosky original)
Reply
#2
What version of Ubuntu? HDMI audio is supported in Jaunty (or any version of ALSA that is 1.0.18+) "cat /proc/asound/version"

If you are running Intrepid or lower you'll need to manually install a more recent version of ALSA (note: this will break apt support for that package)

If you're running Jaunty you probably just need to make a few config changes for HDMI audio.

Personally I find it best to slave HDMI audio off the analog using /etc/asound.conf, I have posts detailing how to do this in the HOWTO: XBMC set-top box thread for Hardy & Intrepid.

Once you've done that (my previous posts explain why this is good) you just need to unmute the HDMI Audio in the mixer (IEC958 1)

Cheers.
Reply
#3
ErrI guess i should have read the entire thing first....
Dunno, with my solution, I've found the UI volume follows whatever volume I have set in xbmc... <shrug>
Reply
#4
I have the same board in the provided link and I can't control volume in XBMC - I have to use the television volume control. I can't change the volume in ubuntu either.
Reply
#5
bobb0 Wrote:ErrI guess i should have read the entire thing first....
Dunno, with my solution, I've found the UI volume follows whatever volume I have set in xbmc... <shrug>

in winBlows i have sound... so i knew it was a setting
$ alsamixer shows IEC958 0 on card 0
$ alsa -c 1 to unmute IEC958 1
... it took me 2 weeks to figure that out Nod

i couldnt find much on the wiki for HDMI audio ?
hopefully we can save the next dude 4 hours Nerd

another on-topic Q > why HDMI audio begin 2~3sec AFTER the video when FF/RW'ing / pausing ?
is this a result of the solution i'm using (binding ALSA.defult to hw 1:3) ?
... does this delay go away when HDMI is slaved to analog ?
... can this be controlled by alsa ?

the other thread you're talkin about is 100 pages strong
would you hit me with a $cat /etc/asound.conf please Laugh
rPi 2&3 | android phones | fireHD8 | linux | win10 + NFS NAS w/ mySQL + props to...
libreElecyatse, titan, AELflexGet, context.manageTags (a zosky original)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[linux] XBMCbuntu + HDMI audio // how-to ?00