• 1
  • 40
  • 41
  • 42
  • 43
  • 44(current)
[RELEASE] Luemmel's DVD-Ripper (Script) for Linux, Mac, and Windows
spiff Wrote:uhm, yes. read again. hint; it's an add-on like all scripts these days.

Ok but when i try to install it in install from zip file, it isn't there.
I have windows 7.
Dark_Fox Wrote:Ok but when i try to install it in install from zip file, it isn't there.
I have windows 7.

Feel free to port this script to a addon for windows ....
I ran the setup.sh and configured everything (ssh-user is definitely correct) but it says (sorry it's the German message): "Konfigurierter SSH-Benutzer ist nicht aktueller Benutzer".

Did I get something wrong?
I don't run xbmc-live, I run it as normal user (broco) and executed setup.sh with "sudo ./setup.sh broco"; it created the key pair etc but it's not working.

I use Ubuntu 11.04.

Edit: Nevermind, after the installation it reset the configuration.

But when I started transcoding, after 1 minute XBMC quit... Undecided
Thanks for the excellent tool!

I tried using XBMC live CD, used a USB key to put the .zip file. I was able to update and get the swiss army knife add on loaded. Running the addon it told me to run setup.sh. After some effort I located the xecutor add on and managed to run xterm. Within xterm I could run the setup script and it seemed to run fine.

Next I tried again to run the addon and I got an error saying the license for mkv has expired but after a pause the menu came up.

Since I only have one cd / dvd drive in my system, I need to eject xbmc cd now and put the Dvd in the drive. I clicked on RIP DVD, or Transcode dvd and the message always appears "Inserted disc is not a DVD disc".

So I am wondering if the problem is the expired license, or does it have to do with using the live cd to boot? If I eject the xbmc live cd, do I need to unmount any filesystem? I tried to unmont /dev/sr0 but it complained the file was in use. I tried "fuser -k " but that just resulted in stopping the xbmc and restarting it, again putting the file in use.

Look forward to any advice on this great tool!
It seems I should try again to boot xbmc from a usb key instead of booting from the live cd. That way the cd / dvd drive won't be mounted with the live cd, assuming that's the problem.
Hello fellows ;-)

On the project url are new binarys for makemkv 1.6.14 ready to download.
(Both 64 and 32 bit).


Yes , It would be better to run the xbmc from a stick .-)

Could you activate the debug-log inside the configuration of the addon and place a full log anywhere in a pastebin ?

Regards Hans
Hi linuxluemmel

I'm running your addon using openELEC generic build and when I try to run it it tells me that I need run ssh and change the settings.

I can access it via ssh but I'm not sure what settings I need to change. I've been searching the thread but its not clear to me what I should be searching for.

Sorry for my delay

I had a accident I was not able to be online a few weeks.
You should be able to connect with your current user into the ssh-daemon without any password given.
Inside the settings you have to edit the ssh username used for the ssh connection if it is not xbmc.

I hope this helps.
Hi all,

I see a lot of progress on the board here but unfortunately I'm still at square 2.

evertything installed fine according to first-run install; ssh works as expected, occasional crash/restart when exiting Programs/addons/Swiss-Army-Knife and Programs/addons/Swiss-Army-Knife/Expert mode

transcode dvd > no activity > working.../crash xbmc OR INFO: Inserted disc is not a dvd disc /crash on exit
expert mode/rip dvd to iso > working.../dvd iso copy could not be started /crash on exit
expert mode/rescue-copy dvd to iso > working.../dvd iso copy could not be started /crash on exit
expert mode/copy vob-files from dvd to hd > working.../dvd vobcopy could not be started [dvd folder created with video_ts subfolder but is empty]
expert mode/transcode & burning/dvd->mkv > working.../no error, no result/crash xbmc OR insterted disc is not a dvd disc /crash on exit
expert mode/transcode & burning/dvd->h264 low-profile > working.../select track to export/add audio; add subtitle/INFO: dvd transcoding started successfully/progress hangs at 97%/mp4 is saved in transcode dir and is playable

here is debug log from xbmc:

saw some comments about the log from SAK but not sure where that is. I found log in: home/mediabox/swiss.army.knife/ssh

any help or insight would be much appreciated.


P.S. Is there an irc channel for any of this?

what about run the script on fedora?
all setup.sh is only for ubuntu/debian... Huh
Hi - just a quick note to say that I just installed SAK from the repo - running latest xbmcbuntu

Install ran smoothly, no errors at all, customised a few directories and start to rip

At the moment is says "buffering please wait" - fingers crossed it is doing what it is supposed to be doing ;D

cheers for an awesome plugin - I've been looking for something like this for a while

Edit: I had my dvd drive accidently set to /dev/sg0 instead of /dev/scd0 - so after a reboot everything seems to be working.. now to wait for my video to pop out ;D!
I keep getting "Local SSH server is not configured properly" - any idea what's wrong?

I use the official XBMCbuntu.

is there someone still working on this?
because the last someone heard from hans luemmel that was on 2011-11-03 more than a year ago

please let me know
  • 1
  • 40
  • 41
  • 42
  • 43
  • 44(current)

Logout Mark Read Team Forum Stats Members Help
[RELEASE] Luemmel's DVD-Ripper (Script) for Linux, Mac, and Windows2
This forum uses Lukasz Tkacz MyBB addons.