Mixed XML & URLl video NFO bug?
#16
After some more troubleshooting, here's what I've found -

When the url is removed from the nfo - no duplicate data, but any fields not specifically set in the nfo are not pulled in

Tried changing the scraper for movies - have IMDB set in the nfo and used TMDB, also tried having IMDB set in the nfo and using IMDB as the scraper....made no difference

If you need the debug log of this, let me know. Thanks.
Reply
#17
Aenima99x Wrote:When the url is removed from the nfo - no duplicate data, but any fields not specifically set in the nfo are not pulled in

yeah .. with url .. dupes cause of addative mechanism of scraper in certain fields
without url .. no dupes but missing info if not specified in nfo
Reply
#18
i understand there is a diff on trac to work around the genre additive .. i'd love to help test and debug it .. but alas i'm not a programer so woulnd't know how/where to start

however .. i had another question .. is it necesary for the current version of the scraper to work properly, that studio be additive like genre & director and not like title, plot, etc? i ask because if not .. could we make it not additive .. that way people can manually set studios so flags work better in the several skins that use them now

many times, imdb doesn't provide a good studio for a movie but rather a small off the wall one and this would prevent this
Reply
#19
yes, studios need to be additive of course - you can have more than one!
Reply
#20
after being overrun by all the tests results i obtained, i finally had a few spare moments to test it. commited at r21453. sho, please do your thing.

nicezia; you would want to add this to your library as well probably
Reply
#21
spiff Wrote:after being overrun by all the tests results i obtained, i finally had a few spare moments to test it. commited at r21453. sho, please do your thing.

nicezia; you would want to add this to your library as well probably
Cool thanks Spiff!
Even though I just finished compiling 21452 about 2 hours ago Laugh
Reply
#22
thanks for the update .. i'll give it a test in a bit .. need to grab the latest svn

jmarshall Wrote:Perhaps a <genre append="true"> might be a solution?

to enable it .. do i need to add lines like that to my advancedsettings.xml as outlined by jmarshall in a previous post ?

<genre append="false">
<director append="false">
<studios append="false">
Reply
#23
spiff Wrote:hmm, i think the solution would be a <genre clear="true">. the specified xml information is applied after we have scraped. pletopia, you haven't quite grasped the problem yet if you think an advancedsetting will help Smile
i'm NOT explaining it again.
Reply
#24
i guess i have to wait for sho to update the wiki with instructions on how to get this feature to work .. thx for the new feature though
Reply
#25
Pletopia - you need to edit your actual movie.nfo files and add the tags there.
Like this
<genre clear="true">Horror / Mystery</genre>
<director clear="true">someone / someone2</director>


Spiff - I have about 500 movies and use nfo's with mixed xml/url for all of them, is there a way to universally set these options so I don't have to manually edit all of my nfo's? Shocked
Reply
#26
aenima99x; no.
it's simple to do with some scripting though, something along

for i in find . -name *nfo; do cat $i | sed -e 's/<genre/<genre clear="true"/g' > foo && mv foo $i; done
Reply
#27
Thanks Spiff.
Reply
#28
Sorry to bother Spiff, but what are all the fields that can use the "clear" tag?
Is it just genre, directors and studio? Thanks.
Reply
#29
genre, director, studio, actor, credits, artist (for mvids)
Reply
#30
Docs updated:
http://wiki.xbmc.org/?title=Import_-_Exp...ML_and_URL
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Mixed XML & URLl video NFO bug?00