[LIVE] Issue with installXBMC.py
#1
Lightbulb 
I've a problem while using the script to install 9.04.1 iso live image into a bootable usb.

Running the command
Code:
sudo ./installXBMCFromISO.sh

fails with the following message:
Code:
...
  File "./installXBMC.py", line 43, in diskSizeKB
    nBytes = int(diskusage)
ValueError: invalid literal for int() with base 10: ''

I've seen that the scripts only works with english version of fdisk, so i've to change line 42 of installXBMC.py from

Code:
diskusage, retCode = runSilent('fdisk -l ' + aVolume + ' | grep "Disk ' + aVolume + '" | cut -f 5 -d " "')
to
Code:
diskusage, retCode = runSilent('fdisk -l ' + aVolume + ' | grep "Disco ' + aVolume + '" | cut -f 5 -d " "')

in order to detect the available partitions.

After this all worked fine.

Hope this helps somebody with the same issue
Reply
#2
DISCO!

Image

... sorry, just had to do this Wink
OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sony 55" X85C Android TV (also with Kodi!)
Asus Chromebox EZ Script
Kodi on Sony Bravia Android TVs
Reply
#3
hi,
try editing the file "instalXBMC.py".

Make the row 42 like this:
Code:
diskusage, retCode = runSilent('fdisk -l ' + aVolume + ' | grep "' + aVolume + '" | cut -f 5 -d " "')

I'm on a kubuntu 9.10.

Bye
Reply
#4
Star 
grajea Wrote:I've a problem while using the script to install 9.04.1 iso live image into a bootable usb.

Running the command
Code:
sudo ./installXBMCFromISO.sh

fails with the following message:
Code:
...
  File "./installXBMC.py", line 43, in diskSizeKB
    nBytes = int(diskusage)
ValueError: invalid literal for int() with base 10: ''

I've seen that the scripts only works with english version of fdisk, so i've to change line 42 of installXBMC.py from

Code:
diskusage, retCode = runSilent('fdisk -l ' + aVolume + ' | grep "Disk ' + aVolume + '" | cut -f 5 -d " "')
to
Code:
diskusage, retCode = runSilent('fdisk -l ' + aVolume + ' | grep "Disco ' + aVolume + '" | cut -f 5 -d " "')

in order to detect the available partitions.

After this all worked fine.

Hope this helps somebody with the same issue

As you can read in this blog another option is to execute a
Code:
export LANG=C
before calling the
Code:
sudo ./installXBMCFromISO.sh

This way you get the same result without modifying the script Nod
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LIVE] Issue with installXBMC.py00
This forum uses Lukasz Tkacz MyBB addons.