[live] cant get wifi to work
#1
hi, i got a zotac ion board and i plugged in a Intel Pro/wireless 3945ABG Mini-pci Express Network Adapter. but i cant get it to recognize my wifi card:
Code:
(T: XBMCLive)[email protected]:~$ lspci
00:00.0 Host bridge: nVidia Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: nVidia Corporation MCP79 LPC Bridge (rev b2)
00:03.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: nVidia Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: nVidia Corporation MCP79 Co-processor (rev b1)
00:04.0 USB Controller: nVidia Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB Controller: nVidia Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:06.0 USB Controller: nVidia Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:06.1 USB Controller: nVidia Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: nVidia Corporation MCP79 PCI Bridge (rev b1)
00:0a.0 Ethernet controller: nVidia Corporation MCP79 Ethernet (rev b1)
00:0b.0 IDE interface: nVidia Corporation MCP79 SATA Controller (rev b1)
00:0c.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:10.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:17.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:18.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
03:00.0 VGA compatible controller: nVidia Corporation Device 087d (rev b1)
(T: XBMCLive)[email protected]:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:01:2e:26:0e:15  
          inet addr:192.168.5.3  Bcast:192.168.5.255  Mask:255.255.255.0
          inet6 addr: fe80::201:2eff:fe26:e15/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:537 errors:0 dropped:0 overruns:0 frame:0
          TX packets:449 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:358782 (358.7 KB)  TX bytes:56468 (56.4 KB)
          Interrupt:21 Base address:0x6000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

(T: XBMCLive)[email protected]:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

(T: XBMCLive)[email protected]:~$
how can i make it recognize and connect to my router ?
Reply
#2
xbmc live doesn't include the wireless extensions, this has been covered before.

https://help.ubuntu.com/community/WifiDocs/WiFiHowTo
OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sony 55" X85C Android TV (also with Kodi!)
Asus Chromebox EZ Script
Kodi on Sony Bravia Android TVs
Reply
#3
^ hi, the above code snippet implies that i already installed wireless-tools thru apt-get.

what i am having problems with is the initial lspci command. for some reason my Intel Pro/wireless 3945ABG Mini-pci Express Network Adapter isnt being listed in either lspci or lshw; how do i get it so that lspci can see my wireless card ?
Reply
#4
ah, okay. google returns problems with this exact card and (mostly notebook) mini PCIe slots that are *NOT* really fully compatible mini PCIe, e.g. only work with the manufacturer provided (mostly broadcom) cards. I'd still recommend booting from a full ubuntu live CD and checking if the card gets recognized.
OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sony 55" X85C Android TV (also with Kodi!)
Asus Chromebox EZ Script
Kodi on Sony Bravia Android TVs
Reply
#5
^ i tried with dsl and fedora 11 (neither list them in their lspci)
Reply
#6
well, then it's not an XBMC-related problem
OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sony 55" X85C Android TV (also with Kodi!)
Asus Chromebox EZ Script
Kodi on Sony Bravia Android TVs
Reply
#7
^ no its not, it seems that zotac ion lock down their board so you have to use their specific wifi module...

thanks for the help.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[live] cant get wifi to work00
This forum uses Lukasz Tkacz MyBB addons.