back to having r21xxxM on my *nix builds
#1
No idea why but all of a sudden yesterday the *nix builds are showing the dreaded M again. I've changed nothing on my end, and yes I do the build reallyclean every build.

Any reason why the "modified" would be showing up again?

OS X
Image

And Linux

Image

Doesn't seem to happen on Win32 or XBOX

Craig
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#2
40 "reads" and not "1" reply Sad
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#3
hehe, that's because we don't know why this has returned Smile
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#4
Smile
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#5
Just run "svn revert -R *" between each platform's build. I'd imagine something silly like the vcproj file is getting modified.
Reply
#6
It's the *nix builds, not the win32 one.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
#7
jmarshall Wrote:It's the *nix builds, not the win32 one.

Aye this is JUST the *nix build doing this.

Here is my Linux build command

svn up && echo "Y" >temp_input_file && make reallyclean < temp_input_file && svn revert -R * && cp ../mybuild.sh ./ && autoconf && ./configure && make && ./mybuild.sh NOUPDATE NOCOMPILE NOCLEAN NOCONFIG && cp BUILD/xbmc.bin ./ && checkinstall -D --install=yes -y --pkgname=xbmc --pkgversion=21650 --pakdir=/devel/XBMC [email protected] --nodoc --strip=yes --stripso=yes --provides=xbmc && rar a -r -m5 /devel/XBMC_Linux_21650.rar xbmc*.deb

And here is my OS X build command

svn up && echo "Y" > temp_input_file && make reallyclean < temp_input_file && svn revert -R * && autoconf && ./configure && export XBMC_HOME=`pwd` && make xcode_depends && xcodebuild -sdk macosx10.4 -project XBMC.xcodeproj -target XBMC.app -configuration Debug build && cd tools/PackageMaker && ./dmgmaker.pl ../../build/Debug/XBMC.app && cd /users/craig/XBMC/tools/PackageMaker/dist && tar -czf ./XBMC_OSX_21650.tgz XBMC.dmg && md5 -q XBMC_OSX_21650.tgz > /users/craig/xbmc/md5.txt && mv *.tgz /users/craig/xbmc

so you see I already AM doing svn revert -R

By all rights these should be as clean as possible with no way of a modified build Sad
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#8
Next time it happens, do an "svn st -q" and pastebin the output.
Reply
#9
it just happened tonight again.
no need for pastebin lol its one line

[email protected]:/devel/XBMC# svn st -q
M configure


something is modifying the "configure" file?
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#10
You have autoconf in the buildline, could probably trigger a Modified.
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

[Image: badge.gif]

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#11
Tomorrow's er I mean tonight's build I'll try without, but it never did it before. Something changed in the last 4 or 5 days that triggered it. Sigh. I'm not so worried about it, but I was told by a dev that it might cause issues with GPL 2, except that it states only that the source code must be made available and I'm willing to do that if asked by anyone FOR the source code, but I highly doubt that will ever be the case Smile
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#12
Right, missed that. You have no need to run autoconf.
Reply
#13
roger will remove the autoconf and see what happens.

Thanks
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
#14
Run svn st -q again and figure out WTH is getting modified...
Reply
#15
sh-3.2# svn st -q
M xbmc/cores/paplayer/MPCCodec/include/config.h.in
sh-3.2#
Main Rig [Scorpius] - Core i7 2600k @ 5Ghz. 16 Gig DDR3 1600. 1x HD 6990 1x HD 4870 Hackintosh [Chiana] - Core i5 @ 3.8Ghz. 12 Gig DDR3 Linux [Moya] - Core2 Duo E8200 - 2 Gigs DDR2 800 WHS [Zhaan] - DualCore [email protected] - 4 Gigs DDR2 800 VMC [Jothee] Core2 Quad @ 2.8Ghz 4 Gigs DDR2 800 VMC [Aeryn] Core2 E8400 @ 3.0Ghz 2 Gigs DDR2 800 2TB Server [Talyn] Core2 Quad Q6600 @ 3.0Ghz - 8 Gigs DDR2 1066 FileServer [Crichton] P4 650 3.4GHz - 2 Gigs DDR
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
back to having r21xxxM on my *nix builds00