MP3 Playback too fast
#1
Hello,

I'm running a recent build of XBMC on ubuntu 8.04. Recently I noticed that mp3 playback is playing at about 1.25x faster then it should be, every song regardless of bitrate. Movies and TV is fine but mp3 is definitely an issue.

Any thoughts on how I might go about attempting to debug this?
Reply
#2
Yep. Start with a debug logfile onto pastebin.com please.
A quick shot in the dark would be using the alsa plug interface as default output device - but without more details about your setup that's prone to fail Smile
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#3
debug logfile was too big for pastebin and I got an SQL error when I tried to paste, what part of the log file do you need. There aren't any errors in there so assuming you just want the header with version number etc?
Reply
#4
Turn on Debug logging, Exit XBMC, start XBMC, play a song long enough to confirm that the MP3 is playing at the wrong sample rate, and then exit XBMC.

The log should be small enough to at that point to pastebin it.
Reply
#5
thanks, I had to disable all the auto scans and stuff as well to make this readable, but think this should be everything you need!

http://pastebin.com/m27d1a900
Reply
#6
This is a known issue and there should be no reason to use a pastebin. Then again, I'm pasting from a previous post that you could have found by searching:

put this:

<advancedsettings>
<audio>
<resample>48000</resample>
</audio>
</advancedsettings>

in .xbmc/userdata/advancedsettings.xml

Fixes it every time

Pete
Reply
#7
thank you very much, worked great.
Reply
#8
It worked for me too.> I had submitted a sob story about not finding the .xbmc folder but found out that was because of hidden files. Duh. However, this fix works for MP3 only. For some movies I have the same problem. Any ideas how to fix that?
Reply
#9
Mayalla Wrote:However, this fix works for MP3 only. For some movies I have the same problem. Any ideas how to fix that?

I have been searching Google and the forums for a fix to this for about a week now, and thanks to this thread finally found it! Thanks. Adding that to advancedsettings.xml worked perfectly.

However, I also have the same issue that Mayalla has. It seems like the only videos affected are those using mpeg audio layer 3 (ac3 and DTS audio video files seem to be unaffected). Does anyone have any ideas about that?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
MP3 Playback too fast00