alsactl store 0 => Home directory /home/xbmc not ours.
#1
Hello,
I am setting up my new ION 330 and when I did:

EDIT: Bad copy/paste I did run sudo
Quote:sudo alsactl store 0

I got
Quote: E: core-util.c: Home directory /home/xbmc not ours.

Have anyone seen that before? I it happen to me once before and it can be solved by
Quote:sudo apt-get remove pulseaudio

That may be fine but I would like to know why it happens.

Other than that it works fine so far. The killasample is playing fine on the 17'' and I am going to connect it to the teli now.

I am using a full ubuntu desktop installation and the xbmc session.

//J
Reply
#2
Run the command "whoami" and ensure that you're who you think you are.
Reply
#3
You want to run alsactl as root.
Reply
#4
I did run sudo, sorry bad copy/paste

I put the pulseaudio back again and:

Quote:[email protected]:~$ sudo alsactl store 0
E: core-util.c: Home directory /home/xbmc not ours.

and

Quote:[email protected]:~$ whoami
xbmc

I assume that means that I am xbmc.

//J
Reply
#5
When using sudo it runs the application as root. Does it give you the same result when running it as xbmc (without sudo)?
Reply
#6
No, that he does not like:

Quote:[email protected]:~$ alsactl store 0
alsactl: save_state:1541: Cannot open /var/lib/alsa/asound.state for writing: Permission denied

This is not a huge problem for me... do not spend too much time on it.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
alsactl store 0 => Home directory /home/xbmc not ours.00