• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 11
  • Next 
 
Thread Rating:
  • 6 Vote(s) - 4.17 Average
Linux - HOW-TO setup XBMC and Linux with correct resolution (xorg.conf)
#1
Thumbs Up 
If you ever had problems getting the correct resoulution on your htpc this
is an easy guide.

IMPORTANT!
This guide asumes you are running a xbmc-live 9.04 wich
also means Ubuntu Jaunty 9.04 with Nvidia restricted drivers 185.18.14

I bellive it however should be pretty "generic" but use this guide on your own risk. if you end up without a picture on your screen dont blame me.

Im no linux guru so if there are any who read this and find anything wrong please say so !

First of all make sure you backup you original xorg.conf.
your xorg conf is found here:
Code:
/etc/X11/xorg.conf

Then generate a new clean xorg.conf by doing this in a terminal:
Code:
sudo nvidia-xconfig

Now you have a new clean xorg.conf.
Do the following
Code:
sudo nano /etc/X11/xorg.conf

then add the following lines in the correct section of that file:
Section "monitor"
Code:
Option "ExactModeTimingsDVI" "TRUE"

Section "Device"
Code:
Option "ModeValidation" "NoEdidModes"


Now close and save the file by hitting "Ctrl + X" on your keyboard. Then press "Y" and "enter"

Now we need to figure out what kind of resolution your TV supports by its EDID info:

Kill xbmc if it's running by
Code:
sudo /etc/init.d/xbmc-live stop

then we need to setup a logfile wich logs your tv's edid modes:
Code:
cd ~
Code:
X -verbose 6 > ~/xlog.txt 2>&1

kill X by pressing "Ctrl" + "C"

In the root of your home directory you will find a xlog.txt (/home/xbmc/xlog.txt)
Open the file and browse until you see something like this section:
[HTML]
(II) NVIDIA(0): Frequency information for SAMSUNG (DFP-1):
(II) NVIDIA(0): HorizSync : 15.000-50.000 kHz
(II) NVIDIA(0): VertRefresh : 48.000-62.000 Hz
(II) NVIDIA(0): (HorizSync from EDID)
(II) NVIDIA(0): (VertRefresh from EDID)
[/HTML]
Write Down the HorizSync and VertRefresh values.

Browse further and find all the validated modes. Like the example underneath:
[HTML]
(II) NVIDIA(0): Validating Mode "1920x1080":
(II) NVIDIA(0): 1920 x 1080 @ 60 Hz
(II) NVIDIA(0): For use as DFP backend.
(II) NVIDIA(0): Mode Source: EDID
(II) NVIDIA(0): Pixel Clock : 74.25 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0): HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0): VRes, VSyncStart : 1080, 1084
(II) NVIDIA(0): VSyncEnd, VTotal : 1094, 1124
(II) NVIDIA(0): H/V Polarity : +/+
(II) NVIDIA(0): Extra : Interlace
(II)NVIDIA(0): Mode is valid.
[/HTML]
Make sure that the "(II)NVIDIA(0): Mode is valid." line exists on the one you pick. To create a modeline from this is easy. From my example above the first line would be "1920x1080" and then 74.25 and then 1920 2008 and 2052 2200 and so on. you just read the values from top to bottom.
So in this example the modeline that section gives me would be:
Code:
ModeLine "1920x1080" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync Interlace

Now that we got bot vsync,hsync and a working modeline lets put it in our xorg.conf.

issue from terminal:
Code:
sudo nano /etc/X11/xorg.conf

Then add from what you wrote down earlier.
Section "Monitor"
Code:
HorizSync 15 - 50
VertRefresh 48 - 62
ModeLine "1920x1080" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync Interlace
(edit the ones there allready)

SubSection "Display"
Code:
Modes "1920x1080"
IMPORTANT! This line must match the modeline you created ! In my case it was "1920x1080"

Now close and save the file by hitting "Ctrl + X" on your keyboard. Then press "Y" and "enter"

Start xbmc by running it:
Code:
sudo /etc/init.d/xbmc-live start

You should get a nice correct screen, make sure to go into settings - screen and calibrate/adjust your new resoultion.

If not try another modeline using same methods and see if that works.

This guide was made from the following sources:
http://ubuntuforums.org/showthread.php?t...nes&page=2

http://www.nvnews.net/vbulletin/showthread.php?t=118701
Reply
#2
Moved to HowTos, thanks for the post!
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#3
Thanks for the guide The-Boxhead! I spent 3 hours messing with my xorg file and nvidia x-server trying to solve this exact issue. Will give it a try over the weekend.
Reply
#4
Thanks but the following lines:

Option "ExactModeTimingsDVI" "TRUE"
Option "ModeValidation" "NoEdidModes"

causes me to have 1080i instead of 1080p, so I need to have something else. I'll keep you updated.
Reply
#5
You are sure your TV handles Native 1080p and not only interlaced ?
PointOfView Nvidia ION Atom 330 - TRANSCEND 2GB DDR2 DIMM 800MHz - G.SKILL 64GB SSD 2.5
Open Elec Beta4 1.95.4
XBMC Online Manual - HOW-TO post about a problem in a useful manner - Create/View Bug Report
Setup/Fix correct resolution on XBMC/Ubuntu - Usefull linux terminal commands
Reply
#6
Does this fix the problem if the Ubuntu desktop goes off the screen? What I mean is that that top and bottom bars aren't visible because the system thinks my viewing area is larger than what it is. I basically have to take my mouse and move it up and guess where the menu is (for gnome). Just wondering it this will fix that?
Reply
#7
Hey there, thanks for the guide.

I ran into trouble when it came time for logging - running the X -verbose command did nothing, just went to the next command line.

I tried to run just 'X' and this was the result:

Code:
Fatal server error:
Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.


Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.

ddxSigGiveUp: Closing log
Reply
#8
nice thanks for the howto ... but a little to late for me ... it took me 2 days to figure that out, but i was to lazy to write up a howto Wink
Reply
#9
kbrookes Wrote:Hey there, thanks for the guide.

I ran into trouble when it came time for logging - running the X -verbose command did nothing, just went to the next command line.

I tried to run just 'X' and this was the result:

Code:
Fatal server error:
Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.


Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.

ddxSigGiveUp: Closing log

Hello, i had this message too. I have xbmc installed on top of ubuntu so am not using the live version.

I've got lots of issues i need to put right before i'm happy with my ion n330 and xbmc, this being one of them.

Problem is i know nothing about linux but it's all part of the learning curve.

Anyway i found the way round this whilst researching another problem, so you can have the required info in the log file. Here's what i did from what i found.....

Logout
Press Alt+Ctrl+F1
Login to the commandline
type in
Code:
sudo /etc/init.d/gdm stop

This stops the logon prompt from returning.

Type in:
Code:
cd ~

Type in:
Code:
X -verbose 6 > ~/xlog.txt 2>&1

My screen went black at this point, i left it for about 20 seconds and then pressed Alt+Ctrl+F1 and then Ctrl+C to kill X (i think)

Then type in:
Code:
sudo /etc/init.d/gdm start

The log file should now contain all the info you need to make the ModeLine.

My resolution in XBMC is now fine. The desktop resolution is still not right, the top and bottom just slighty too big.

It's nice to find these things but i'm still pretty much none the wiser ha!

Good Luck
Reply
#10
Great indications, now I have all my modes set up in my X configuration.


Thanks a lot.

BTW, I've spent a few hours trying to change between different modes 24p, 25p, etc without restarting X and I couldn't.

I've tried Ctrl+Alt+KeypadMinus or Ctrl+Alt+KeypadPlus and it didn't work. Neither scripts running "xvidtune -next" and "xvidtune -prev".

Any clues?? It would be really much appreciated.

What I intend is changing between 24p, 25p, 60p... with remote control depending on the media I'm going to play and without restarting XBMC and/or X. Adapting output frequency to source fps makes pulldown work much easier.

Thanks again.
Reply
#11
How foes this work for correcting overscan? Would I, instead of setting 1920X1080 set 1824X1026 instead? This setting gives me zero overscan under the Nvidia Windows drivers.

Kryspy
Reply
#12
Chambers Wrote:Does this fix the problem if the Ubuntu desktop goes off the screen? What I mean is that that top and bottom bars aren't visible because the system thinks my viewing area is larger than what it is. I basically have to take my mouse and move it up and guess where the menu is (for gnome). Just wondering it this will fix that?

This is called overscan - it'll normally be an option on your TV (look for thing called Zoom or Overscan and disable them)


motd
Reply
#13
First I would like to thank you for posting this how to since the other guides out there is alot more complicated. Now to my problems:

I have a 1080p screen but I can't find any 1920 x 1080 mode that is valid. What do I do? Modelines is my only hope to get 24p working.

The EDID gives me weird shit like: @25Hz and @30Hz, but no @24Hz. The weirdest thing is that my manual says it only supports these modes:
Image

Anyone who knows what the difference between video formats and computer formats is? Obviously it doesn't seem to be any, because right now I run in either @50Hz or @60Hz.


Heres my xlog:
http://paste.ubuntu.com/273674/

My tv is a Sharp LC-42SB55S LCD TV.

Code:
(II) Sep 18 19:11:58 NVIDIA(0): Frequency information for SHARP HDMI (DFP-0):
(II) Sep 18 19:11:58 NVIDIA(0):   HorizSync   : 15.000-75.000 kHz
(II) Sep 18 19:11:58 NVIDIA(0):   VertRefresh : 55.000-76.000 Hz
(II) Sep 18 19:11:58 NVIDIA(0):     (HorizSync from EDID)
(II) Sep 18 19:11:58 NVIDIA(0):     (VertRefresh from EDID)
Hardware: ASUS P5N7A-VM with 2GB RAM and Intel Celeron 430 1,8GHz @ 3,06GHz
Reply
#14
[STRIKE]Mmm, I tried this, and maybe I'm doing something wrong, but it would work out.

I can't kill X with CTRL-C. Maybe since I'm running XBMC in a separate session next to full Ubuntu Desktop so I tried what W4rr10r suggested.

But every time I try to start X again I get:

"X: user not authorized to run the X server, aborting."

In my log.

Any ideas?[/STRIKE]

Nevermind W4rr10r post does work but you have to use local shell instead of putty remote.

I have a valid log now but there aren't any valif 1920x1080 modes available!! I used the values from somewhere right under my TV listing. Something that looked like:
Code:
(--) NVIDIA(0): CEA-861B Timings:
(--) NVIDIA(0):   1920 x 1080 @ 50 Hz
(--) NVIDIA(0):     Pixel Clock      : 148.50 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1920, 2448
(--) NVIDIA(0):     HSyncEnd, HTotal : 2492, 2640
(--) NVIDIA(0):     VRes, VSyncStart : 1080, 1084
(--) NVIDIA(0):     VSyncEnd, VTotal : 1089, 1125
(--) NVIDIA(0):     H/V Polarity     : +/+
(--) NVIDIA(0):     CEA Format       : 31

I used these settings and calibrated the screen. I do got working 24p but everything is in 24Hz now including the menu!
When I try to start a PAL DVD ISO but it's played in 50Hz with horrific motion judder. Sad
Reply
#15
Thanks a lot for the guide!

I had to add the following under Section "Screen" in xorg.conf.

Code:
Option "DynamicTwinView" "False"
    Option "FlatPanelProperties" "Scaling = Native"

I also had to remove my guisettings.xml (in userdata folder) to get correct identification of the different modes.
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 11
  • Next 



HOW-TO setup XBMC and Linux with correct resolution (xorg.conf)4.176