Alsamixer - Audiophile 2496 SPDIF output in XBMC for Linux?
#1
After not getting my onboard spdif device to work on my asus m3n78-vm with the live cd and not being able to upgrade the alsamixer I got another card to try.

It’s a audiophile 24/96 it’s a simple card with 2 RCA line in 2 RCA line out SPDIF in, SPDIF out and midi.

The card works and is seen by the Alsamixer but still no joy in xbmc.
I can’t get this clear, what is suppose to be here? Audio output device is it iec958 of is it spdif? Or IEC958 or SPDIF or something elseHuh??
There are too much variables here to just try them all.

In the alsamixer :
Card M Audio Audiophile 24/96
Chip ICE1712 – multitrack

I am in playback

On the left I have 2 IEC958 devices

I can select the following :

PCM out
H/W in 0
H/W in 1
H/W in 2
H/W in 3
H/W in 4
H/W in 5
H/W in 6
H/W in 7
IEC958 In L
IEC948 in R
Digital Mixer

What do I select? And what do I have to put in XMBC?
Reply
#2
nobody?

Can you give me the name of a sound card that WILL work with the live cd? Is digital output working at all with the live version?
Reply
#3
the audiophile works really well with linux in general - in fact i use the same for recording at home. please post the output of aplay -l (lowercase L) and aplay -L (uppercase L) so we can see the device names.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#4
still think you need to update alsa..
Reply
#5
No don't think so. I'm using the card since 2.6.26 and even Ubuntu Studio 8.04 worked with it out of the box.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#6
**** List of PLAYBACK Hardware Devices ****
card 0: M2496 [M Audio Audiophile 24/96], device 0: ICE1712 multi [ICE1712 multi ]
Subdevices: 1/1
Subdevice #0: subdevice #0


default:CARD=M2496
M Audio Audiophile 24/96, ICE1712 multi
Default Audio Device
front:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi
Front speakers
surround40:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi
4.0 Surround output to Front and Rear speakers
surround41:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
iec958:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi
IEC958 (S/PDIF) Digital Audio Output
null
Discard all samples (playback) or generate zero samples (capture)


Thanks for your help!

@blittan

I’am simply not good enough to make a clean do it yourself setop topbox Linux install. I tried but there are faults in the tutorial something with the key server not working etc. I don’t think someone here will have enough patience to help me every step of the way ;-) So I have find a way to get this thing working by changing hardware.

Regards Sebastian
Reply
#7
voyager2 Wrote:iec958:CARD=M2496,DEV=0
M Audio Audiophile 24/96, ICE1712 multi

Try with "plug:iec958" as default output device in xbmc and "iec958" as passthrough device. As you apparently only have one souncard loaded/active that should do. You could try at the console first with "speaker-test -c2 -Dplug:iec958" and see if you get white noise out of your speakers
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#8
I will update the tutorial with correct keys later today.. please try it, since you will be able to compile bleeding edge xbmc on it and not stuck with older live Smile
Reply
#9
"speaker-test -c2 -Dplug:iec958"

speaker-test 1.0.18
Playback device is plug:iec958
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2 to 6553
Period size range from 2 to 3276
Using max buffer size 6552
Periods = 4
was set period_size = 1638
was set buffer_size = 6552
0 - Front Left
1 - Front Right

And yes I have pink noise on both speakers!

I now have navigation sounds true the digital out on 1 speaker L
Still no music playback or DD DTS can't initialize audio device.

So what you are saying is, try to make your own bleeding edge xbmc and if you get stuck 20 times I will help you :-)
Reply
#10
Please post a full debug logfile onto pastebin.com while trying to play something with this new soundcard.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#11
updated the guide now, so it should be a straight forward thing to follow it.
Reply
#12
Thank you for updating, I will give it a try on another hdd.

http://pastebin.com/m1af1b02f

Here is the log file.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Alsamixer - Audiophile 2496 SPDIF output in XBMC for Linux?00
This forum uses Lukasz Tkacz MyBB addons.