SPDIF/optical on Creative X-Fi 5.1 USB+XBMC
#1
Thumbs Up 
Hi im trying to get my SPDIF/optical on Creative X-Fi to give sound.

atm in xbmc:
"Audio Output Device" "default"
"Passthrough Output Device" "iec958"

I know hdmi and jackplug works on Acer REVO
cant get anything on Creative X-Fi to work.

What do i put in "Audio Output Device" & "Passthrough Output Device"?

spec/hw:
Ubuntu-9.04-desktop-i386 last update 28. July.
XBMC Linux
Acer REVO R3600
Creative X-Fi 5.1 USB (SB1090)

aplay -L :
Code:
front:CARD=NVidia,DEV=0
    HDA NVidia, ALC662 Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, ALC662 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, ALC662 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, ALC662 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, ALC662 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, ALC662 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, NVIDIA HDMI
    HDMI Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)
front:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    Front speakers
surround40:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=S51,DEV=0
    SB X-Fi Surround 5.1, USB Audio
    IEC958 (S/PDIF) Digital Audio Output

aplay -l :
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 Analog [ALC662 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: S51 [SB X-Fi Surround 5.1], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: S51 [SB X-Fi Surround 5.1], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

(yea, my english is bad)

- Perril Smile
Reply
#2
I have an audigy 2 platinum and set both options to "SPDIF" to get my optical out working properly.

I don't have any dashboard sounds but movies (stereo, ac3, dts) and music all playback without issue.
Reply
#3
hmm didnt work for me Sad
Reply
#4
iec958

check in alsamixer that it isn't muted (MM)

alsamixer is run in console.

also look if the optical is lit
Reply
#5
In alsamixer i only see master, it has a green "OO"

optical cabel i see red light
Reply
#6
if you go to the far right using the arrows, you should see a "iec958" it's listed in you aplay listing.

in "Audio Output Device" & "Passthrough Output Device" try iec958
Reply
#7
that didnt work to.. Sad
I have sound in gnome/gui

but not in xbmc :/
Reply
#8
Try with plug:iec958 for audiodevice and iec958 for passthrough
Reply
#9
Note that just using iec958 is ambiguous here - you have to specify the full device like this:
Code:
xbmc default device: plug:iec958:CARD=S51,DEV=0
xbmc passthrough device: iec958:CARD=S51,DEV=0

You can try it with "speaker-test -D plug:iec958:CARD=S51,DEV=0" first.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#10
SPDIF/Optical works! Big Grin
Reply
#11
...
Reply
#12
Hi, sorry my english isn't very good, but i try to describe my problem. I have the same soundcard (X-Fi USB 5.1) and i try the settings from this thread, but it doesn't work on XBMC live. No Sound.

/$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: S51 [SB X-Fi Surround 5.1], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: S51 [SB X-Fi Surround 5.1], device 1: USB Audio [USB Audio #1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: S51 [SB X-Fi Surround 5.1], device 2: USB Audio [USB Audio #2]
Subdevices: 1/1
Subdevice #0: subdevice #0
/$ aplay -L
default:CARD=S51
SB X-Fi Surround 5.1, USB Audio
Default Audio Device
front:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
Front speakers
surround40:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
4.0 Surround output to Front and Rear speakers
surround41:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=S51,DEV=0
SB X-Fi Surround 5.1, USB Audio
IEC958 (S/PDIF) Digital Audio Output
null
Discard all samples (playback) or generate zero samples (capture)
/$ alsamixer
alsamixer: function snd_ctl_open failed for default: No such file or directory

Can anyone help me please?
Reply
#13
I know this is an old thread, but hopefully a bump will help resurect it. Has anyone had any success getting the USB X-Fi working on a Revo with XBMC Live? Alternatively, if it can be made to work with Ubuntu would there be a problem with running XBMC on top of Ubuntu in terms of the playback of 1080p MKV files?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
SPDIF/optical on Creative X-Fi 5.1 USB+XBMC00