•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 13
  •   
[MAC] HOW-TO setup Logitech Harmony Remote for use with XBMC for Mac OS X
#61
Tbtf Wrote:On a side not is anyone else having these problems? I am wondering if it is just me.

look at what i said in my PS. i'm not sure if i'm seeing precisely the same thing, but not far off. in my case I chalked it up to how XBMC handles ff/rw/skip forward/skip back (not as smoothly as I would expect), rather than to the map itself.

Note this is the actually used keymap:

Code:
<!-- hold left  --> <button id="9">BigStepBack</button>
      <!-- hold right --> <button id="10">BigStepForward</button>
      <!-- Previous --> <button id="73">SkipPrevious</button>
      <!-- Next --> <button id="74">SkipNext</button>
      <!-- Rewind --> <button id="75">Rewind</button>
      <!-- Forward --> <button id="76">FastForward</button>

maybe it should be different? also try the hold left and hold right?
Reply
#62
I just set up the remote with XBMC Camelot Beta I and everything works great for the most part. I downloaded the keymap on page 1, and set the options as described in the tutorials. However, for the life of me I can't figure out why I can't tart XBMC with my Harmony... I click Menu, I click Power Toggle, but XBMC does not open. When I open it normally the remote works great! I even went into settings and made sure that the ability to start XBMC with my remote was set to on (and it was). Any help on this issue will be greatly appreciated Smile

-Russ

P.S. Also, FF and REW don't really work like they should. When I select one or the other, it skips or rewinds 10 min at a time. Is there a way to fix this (and yes I do have it set to the Harmony setting already)?

EDIT: Solved the opening issue... I had to re-pair my remote for some reason... now it works like a charm. Still curious about the FF/REW though...
I love my Mac Mini :;):
Reply
#63
Any idea why the sleep command isn't working?
Been using plex but moved to xbmc due to plex being so limited and the only issue is the sleep command isn't working!
Using latest svn as far as I'm aware!
Reply
#64
Kingsley Wrote:Any idea why the sleep command isn't working?
Been using plex but moved to xbmc due to plex being so limited and the only issue is the sleep command isn't working!
Using latest svn as far as I'm aware!

Hi,

This can be solved by changing the value in the joystick.Harmony.xml file at button id 46 in the global node from XBMC.SleepSystem() in to XBMC.Suspend()
This will then sleep the system.

Can one of the developers explain this, why this is not working with the XBMC.SleepSystem() on OSX system? Or do other systems have the same issue with the sleep function?

Gr.
Reply
#65
VideoMaster Wrote:Hi,

This can be solved by changing the value in the joystick.Harmony.xml file at button id 46 in the global node from XBMC.SleepSystem() in to XBMC.Suspend()
This will then sleep the system.

Can one of the developers explain this, why this is not working with the XBMC.SleepSystem() on OSX system? Or do other systems have the same issue with the sleep function?

Gr.

Odd, both of those should do the same thing. Sleep and suspend are the same thing under OSX. OSX will detect if running on battery and suspend to disk automatically if commanded to sleep.

EDIT, figured it out. XBMC.SleepSystem() is not a valid built-in command while XBMC.Suspend() is. Not sure why XBMC.SleepSystem() is listed but this will be changed in svn trunk very soon.
Reply
#66
I really want to know about the Rew/FF thing I asked above... does ff and rew work for anyone. I assume pushing ff on my harmony should do the same thing as pushing "f" on my keyboard, but it doesn't. Pushing ff skips 30 seconds ahead instead of normal ff... if anyone could help me with this I would greatly appreciate it Smile
I love my Mac Mini :;):
Reply
#67
UnisonRuss Wrote:I really want to know about the Rew/FF thing I asked above... does ff and rew work for anyone. I assume pushing ff on my harmony should do the same thing as pushing "f" on my keyboard, but it doesn't. Pushing ff skips 30 seconds ahead instead of normal ff... if anyone could help me with this I would greatly appreciate it Smile

Just checked Harmony and keyboard mapping and, indeed, 'f' maps to FastForward, while FF on harmony is mapped to BigStepForward (which might default to 30 seconds).
So what you see is at least consistent with what is mapped.

To customize it, just copy the harmony keymap.xml into your keymaps folder (~/Library/Application Support/XBMC/userdata/keymaps/) and modify it as you like.

Ofc, changing the defaults is also an option.

@ctawn, what do you think?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#68
Thanks for the reply! I don't really know anything about keymaps, but now looking at the two side by side I can see how to fix it. Thanks! Smile

EDIT: Got it working Big Grin It def. makes more sense to have it this way IMO, more like a dvd remote Smile
I love my Mac Mini :;):
Reply
#69
MaestroDD Wrote:Just checked ... and, indeed, 'f' maps to FastForward, while FF on harmony is mapped to BigStepForward (which might default to 30 seconds).
So what you see is at least consistent with what is mapped.

@ctawn, what do you think?

I definitely think the default should be changed, in the next revision, to whatever makes the most sense. please make sure to change RW also. thanks.
Reply
#70
Ok, not sure if you guys can help me on this one.
I got Plex running on a Mac Mini (early '09) with Leopard and a Harmony 520.
I have the standard buttons working all fine and dandy, I even have the the F1-F5 buttons working b/c they were pre-mapped. With Plex they give you a standard xml file for various types of remotes (xbox, ps3, wii, apple, harmony, etc.).

I've gone to Plex forums and the Plex wiki, and the XBMC wiki. I can't get this to work though.

I placed it /applicationsupport/plex/keymaps/harmony.xml
I even copy and pasted a (videolibrary,movietitles) code from F1 to F12, and it wouldn't work. I restarted too.

I need a shortcut for my playlists, and a shortcut for a specific playlists, and various video plugins (but I'm not sure what their code would be, thenytimes nyt ny_times?)

Here's my code, hopefully someone can help, thanks.

Code:
<keymap>
  <global>
    <harmonyremote>
      <play>Play</play>
      <pause>Pause</pause>
      <stop>Stop</stop>
  ...
      <power>XBMC.ShutDown()</power>
      <sleep>XBMC.SleepSystem()</sleep>
      <aspect>ConetextMenu</aspect>
      <queue>Queue</queue>
      <largeup>PageUp</largeup>
      <largedown>PageDown</largedown>

      <F1>XBMC.ActivateWindow(Music)</F1>
      <F2>XBMC.ActivateWindow(videolibrary,tvshowtitles,return)</F2>
      <F3>XBMC.ActivateWindow(videolibrary,movietitles,return)</F3>
      <F4>XBMC.ActivateWindow(Weather)</F4>

      <F6>XBMC.ActivateWindow(Music)</F6>
      <F7>Plex.ActivateWindow(MyVideoFiles,vimeo)</F7>
      <F8>Plex.ActivateWindow(MyVideoFiles,youtube)</F8>
      <F9>Plex.ActivateWindow(MyVideoFiles,cnettv)</F9>
      <F10>Plex.ActivateWindow(MyVideoFiles,cnn)</F10>
      <F11>Plex.ActivateWindow(MyVideoFiles,comedycentral)</F11>
      <F12>Plex.ActivateWindow(MyVideoFiles,food_network,return)</F12>
      <F13>Plex.ActivateWindow(MyVideoFiles,mtv,return)</F13>
      <F14>Plex.ActivateWindow(MyVideoFiles,nbc,return)</F14>

      <red> xbmc.activatewindow(videolibrary,movietitles)</red>
      <green>xbmc.activatewindow(musiclibrary,playlists)</green>
      <yellow>Plex.ActivateWindow(ActivateWindow(10001,/Applications/Hulu Desktop.app/))/yellow>
      <blue>Plex.ActivateWindow(ActivateWindow(10001,/Applications/DVD Player.app/))</blue>

      <F5>Plex.RunAppleScript(do shell script "drutil tray eject = 1")</F5>
      <two>JumpSMS2</two>
      <three>JumpSMS3</three>
      <four>JumpSMS4</four>
      <five>JumpSMS5</five>
      <six>JumpSMS6</six>
      <seven>JumpSMS7</seven>
      <eight>JumpSMS8</eight>
      <nine>JumpSMS9</nine>

    </harmonyremote>
  </global>
...
</keymap>
Reply
#71
ctawn Wrote:I definitely think the default should be changed, in the next revision, to whatever makes the most sense. please make sure to change RW also. thanks.

set to FastForward and Rewind in r25678 and backported to camelot, so it should be in next release

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#72
Hi bmorris,

not sure I get you right, but Plex' forum might be a better place to ask Plex related questions...

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#73
MaestroDD Wrote:not sure I get you right, but Plex' forum might be a better place to ask Plex related questions...


Yeah, I'm looking for help there too.
But a lot of Plex's wiki on keymap.xml is hyper-linked to XBMC's wiki.
So a lot Plex users are in both forums sometimes or XBMC have some familiarity with both.

Wishful thinking/searching basically.

I've tried a lot of things, and gotten nothing, it's been almost 2 weeks of trial/error.
I think a fresh removal/re-install of Plex might help.
I was hoping I wouldn't have to try it. Oh, well.
Reply
#74
FYI, I have tried the default keymap with 9.11RC1 and the FW/RW buttons now work as expected. Much better, thanks to the squeaky wheels and maestrodd! ;-)
Reply
#75
For some reason the directional buttons (up, down, left, right) are respond amazingly slow. I press them and then count a beat then it moves on the screen. Is there any way to fix this? Interestingly enough it seems that the other buttons respond as expected but the directional buttons don't respond when I press them but respond a moment after... Sad
OS: Leopard 10.5.6
Processor: 2x Quad Core Intel 2.8Ghz Xeon
Internal Storage: 2.4TB [4x 600GB Western Digital]
External Storage: Drobo 4.5TB
Memory: 14GB PC-6400 800mhz FB-ECC Ram
Apple Wireless Bluetooth Keyboard
Apple Remote
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 13
  •   



Logout Mark Read Team Forum Stats Members Help
[MAC] HOW-TO setup Logitech Harmony Remote for use with XBMC for Mac OS X1
This forum uses Lukasz Tkacz MyBB addons.