Covers building up slow using fast scroll mode
#1
Hey guys,

I'm using latest svn build XBMC and latest Aeon Hitched Mod.
When using the fast scroll covers are building up slow.
Didn't have this issue a few weeks ago, everything was fine then.
I'm running XBMC with Aeon Hitched mod on my laptop C2D 2,2ghz, 2GB RAM, GeForce 8600GT 512Mb and on my Desktop, basically same setup with 4GB RAM.

You cann see the issue here:
http://www.youtube.com/watch?v=DU5gb6teokk

Any ideas how to fix this?
Not that it's a big issue but I would really like the smooth scrolling thingy back Wink
Thanks in advance!
Reply
#2
That's because of the background = "true" setting... if you remove the background setting, it will be fixed but the scrolling will be way slower than before... wall view is not usable without it. For faster loading with background = "true" use smaller thumbs, mine are 480x320 and it's imo fast enough. An SSD should also speed up things.
Reply
#3
what did you mean with background true?
i have the same probleme, and a few releases earlier i never had this problem ...! and i didnt changed my thumbs ... Sad
Reply
#4
Code:
<texture background="true" diffuse="multiplex/multiplex_mask.png">$INFO[ListItem.Icon]</texture>

It's now like this... if you remove the
Code:
background="true"
all posters are loaded if you enter the movie/music section. But that makes the scrolling very slow but if you don't mind, edit all views and remove the setting.
Reply
#5
I took some time to look into this today, since i see a lot of people complaining about how slow images load.

There are a few things in play here:
1) A bug in the Large Texture Manager kills the thread immediately and cleans up the loader as soon as the last item in the queue is loaded. This adds a small amount of overhead to image load as the scrolling starts.

2) The fanart is the first thing XBMC tries to load because it is the first image control. That means all those thumbs have to wait until the fanart loads before they can load, and 1080p fanart takes about 1/4 second to load on a decent pc. The quick solution to this would be to rearrange the skin file to put the fanart after the list (it can still be in the same spot on the screen it just has to come later in the skin file). This isn't ideal though, because now you have to be careful to not mess up the layering.

What should probably be done is to add (yet another) property to images to indicate its load priority to the background loader.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#6
You can't put the fanart after the list because then it won't be in the background...
Reply
#7
`Black Wrote:You can't put the fanart after the list because then it won't be in the background...
Quote:This isn't ideal though, because now you have to be careful to not mess up the layering.
WTF did I just say? In the OP's case, it can be safely moved because it is on top.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#8
So does no one else have that problem?

I can't be the only one using large covers (1000 x xxxx) and multiplex view.
I don't know if I really want to mess with the .xml files...
Reply
#9
I have the same behaviour. Well a bit faster, but thats because I don't have the huge thumbs. But I can't say that I see it as a "problem". It's more of a feature, as `black described earlier with the background=true stuff and all. And it all boils down to the speed of your disk.(well mostly) Without it you would probably not have a smooth animation when going from one item to the other.

This I not a fix, more of a improvement(?) of a working solution. But maybe it would be possible to cache the whole lists thumbs in ram instead when entering a node and then have the loading done from ram, maybe thats faster?
  • Livingroom - C2D E8400, P5N7A-VM on a Samsung 46" LE46M86 FullHD via HDMI
  • Kitchen - ASRock 330 HT Displayed on a Samsung Lapfit 22" dual touch screen LD220Z
  • Bedroom - LG Laptop on a 32" tv
Reply
#10
same problem here, my cover are 1000px up too...
Reply
#11
It's got nothing to do with the size of your covers instead it's the size you have XBMC set to cache them. Either default (512) or by setting it in your advancedsettings.xml.

ie
Code:
<advancedsettings>
    <thumbsize>384</thumbsize>
</advancedsettings>
Reply
#12
I have the same issue of all my posters loading with a delay. I am user larger posters as well. 1000px and up.
Reply
#13
Image
Reply
#14
Hitcher Wrote:It's got nothing to do with the size of your covers instead it's the size you have XBMC set to cache them. Either default (512) or by setting it in your advancedsettings.xml.

ie
Code:
<advancedsettings>
    <thumbsize>384</thumbsize>
</advancedsettings>
Does Aeon/Your Mod/Andy's Mod actually ever use thumbnails >384? I thought the skin loaded the folder.jpg directly when viewing the info screen. Is there any reason to have the default 512 setting?
Reply
#15
Skins can only load folder.jpg/poster.jpg outside of the actual list. All the thumbs you scroll through are the cached ones.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Covers building up slow using fast scroll mode00