Just got SVN build working but Audio is very very low
#16
Ok, so I reinstalled Ubuntu, XBMC, Alsa 1.0.19, nvidia-glx-190 and everything works great inside of Gnome, when I run XBMC as a session though no sound at all? When I go back to the GDM login screen I get sound again. Does this make any sense? I'm using all the same stuff I used before, SVN version 21936 with Aeon. I can get you a log file but it doesn't normally have that exit part because there is no selection in Aeon to exit XBMC.
Reply
#17
Just to be clear I wanted to add that when inside of Gnome and not using XBMC as a session there is sound and everything with XBMC. It's just when it's run as a session does it give me issues.
Reply
#18
Sounds like an issue outside of XBMC. Is it the same user when inside gnome and when as a session?

Does aplay work when not using gnome?
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#19
Ok nevermind this comment it's not working right still.
Reply
#20
What is aplayer exactly? And do I use it in CLI?
Reply
#21
Also, how do you disable passthrough? The only thing I see in the menu is Passthrough output device which is set to IEC958.
Reply
#22
don't enable digital output / don't tick 'ac3 capable reciver' or 'dts capable receiver'
Reply
#23
Well then SPDIF over HDMI won't work anymore will it? Where I stand right now Dolby Digital tracks work fine DTS tracks do not. Although the sound still seems a bit low compared to what it used to be.
Reply
#24
that's three actions to take;

1) enable digital output - pcm passthrough
2) tick ac3 capable receiver - ac3 passthrough
3) tick dts capable receiver - dts passthrough

first is harmless - you can adjust volume et al. the two latter is not, we cannot amplify a bitstream, only pcm.

in conclusion; do 2&3 if you want to loose your multichan at the expense of volume control (unless alsa changed and allows multichan pcm passthrough over hdmi, in that case you don't loose much at all)
Reply
#25
When I untick AC3 and DTS it pops up and says can't initialize audio device. Either way DTS tracks do not work. And audio volume is better hten it was but stills seems about half of what it used to be.
Reply
#26
Alright, well I installed alsa-tools, then unticked DTS and AC3 and wolla. It works now, volume is back to normal and both AC3 and DTS tracks are working.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Just got SVN build working but Audio is very very low00