Windows 7 movie in homescreen CPU 50-60%
#16
I make some additional tests, and get an unexpected result.

In the main menu, idle the video button is active, increase the CPU load to 50% if the screensaver dim go to active.
If I stay in other GUI parts e.g. Settings-Appearance and the screensaver "dim" go to active, the CPU load is the same without active screensaver

For my point of view is that an error, the active screensaver "dim" should increase the CPU load max of a very small value.

If a debug log necessary, it's not a problem to create it.
Reply
#17
WiSo Wrote:What do you expect?
Just playing the video: XBMC renders the film with 25-29fps.
Playing in home screen: XBMC has to decode the video and to render the gui with 60-100fps (depending on vsync)

Also noteworthy if you have any of the sync options on XBMC needs to to do extra calculations to have the 2 in sync. transfer film @ 25-29 into 60-100

EDIT: missed that there were 2 pages to this post so ignore me Big Grin
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply



Logout Mark Read Team Forum Stats Members Help
Windows 7 movie in homescreen CPU 50-60%0
This forum uses Lukasz Tkacz MyBB addons.