[LIVE] MCE Remote not working
#1
I am setting up a new Asrock ION 330 system and I decided to install Live since I don't know squat about Linux. I've had a lot of trouble in the beginning getting the video to play right so I've been through a couple Live installations. Initially, the remote worked fine. I plugged it in, installed Live and it just worked. Even after a second Live installation it still worked. Then, all I did was move the system to the bedroom TV where I plan to use it and all of the sudden the remote stopped working. There is a red light constantly on on the IR receiver. Normally this only lights up when it senses a command from the remote.

I've since gone through yet another Live installation and it's still acting the same. I can't figure out why it used to work and then stopped. Anyone have any ideas? Here's my debug log:

http://pastebin.com/m3938b88d
Reply
#2
Can someone at least tell me how to begin troubleshooting the problem? Like I said, it was working fine so I would guess that the remote is compatible.
Reply
#3
OK. I've searched and searched and I can't find any info on this. What does the little red light on the receiver staying on mean? Nobody else has ever experienced this?
Reply
#4
Have an Asrock ION 330 as well, and my IR receiver started behaving in a similar manner to what you describe. It also worked initially....

The IR receiver would flash constantly for long durations with small pauses in between, and no buttons are pressed on any remote. If you are lucky to press a button in the small pauses, the operation will take, if not, nothing happens.

Also, I used to be able to just suspend the machine using the remote by using that setting in XBMC, and then when powering on my system, the ION would come out of suspend mode and work. Now when the machine goes into suspend, it almost immediately restarts, but to the Gnome desktop since XBMC is no longer running. could not see any crashlog.

This behaviour disappeared when I updated to SVN "Built on Sep 6 2009 (SVN:Unknown)".
Reply
#5
Thanks for your reply. I am running the same build as you are. My problem sounds a little bit different than yours. The red light on my receiver stays on constantly. It doesn't blink or anything even when a remote button is pressed. When it was working correctly, the light on the receiver stayed off except to indicate a button press on the remote. It would even send to system to sleep and then wake it. So it seems really weird that all of the sudden it just stopped. Here is my cat /proc/bus/input/devices:

http://pastebin.com/m7b213089

I don't really know anything about this, but in researching my problem I saw people mention to look there to see if it's showing. It doesn't appear to me as though it's seeing the remote.

I would really appreciate anybody who could help guide me towards troubleshooting this. Again, I don't know anything about Linux and I need a working remote for this system.

EDIT: Yes, I have unplugged it and tried other USB ports and still no luck.
Reply
#6
What receiver are you using?
Does the Asrock have something built into the case or is it a proper MCE Usb receiver?

run 'lsusb' and post back your results..
Reply
#7
The red light should indicate infared activity picked up by the receiver, right? If so, is it possible you have something in this new room that emits in the infra red? Have you tried in the original room?
Reply
#8
Swifty Wrote:What receiver are you using?
Does the Asrock have something built into the case or is it a proper MCE Usb receiver?

run 'lsusb' and post back your results..

The Asrock doesn't have anything built into the case. This is a Vista MCE USb remote/receiver. I don't see a brand name anywhere, but if I remember correctly, when I tried it on my Win system it was reported as EHome or something like that.

I'll try that command when I get home. Do I just type "lsusb" in the terminal or do I need more? Sorry, I'm Linux challenged.
Reply
#9
papaf Wrote:The red light should indicate infared activity picked up by the receiver, right? If so, is it possible you have something in this new room that emits in the infra red?

That's possible I guess though I can't imagine from what. Also, I originally bought this remote for a Winodws XBMC build I did a while back. Not thinking it mattered, I bought this Vista MCE remote to use on Xp only to find it wasn't compatible. It also showed the red LED on constantly.

Quote:Have you tried in the original room?

That seems pretty obvious. I can't believe I haven't tried that. I will when I get home. Though I'd be surprised if it works.
Reply
#10
here is the output of lsusb:

Code:
(T: XBMCLive)[email protected]:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 045e:00e3 Microsoft Corp.
Bus 002 Device 002: ID 1784:0008 TopSeed Technology Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Reply
#11
Ok try running this;

sudo dpkg-reconfigure lirc

Then select the Windows Media Center reciever, you should see two versions in the list.
One should say something like Old/V1/Microsoft, the other New/V2/Philips.
You want to choose the Microsoft one, then hit ok/next.
Choose a blaster if you use one...

Once you complete this you should see several things at the command line;
Lirc Stopping, Lirc Starting Etc..
Check that all of these comlpete with 'OK'
Then restart XBMC and see if it works.
Reply
#12
OK this is weird! I tried your suggestion Swifty, but it still did the same. I even tried selecting the New MCE remote option in the LIRC setup and it still did the same. Realizing I never did try papf's suggestion to try the other room agin, I moved the system back to the other room and voila... it works! What the heck could be causing problems in the other room? I removed all the remotes that were in there to rule them out and it didn't change anything.

The problem room is a standard fare bedroom. The system sits on a dresser underneath an new LCD TV and is flanked by a Logitech 5.1 surround sound system. Nothing else unusual in the room except my wife an I both have an iPhone charging cradle on our night stands. I can't imagine what could be causing this.

Anybody with ideas or suggestions??
Reply
#13
mm, you don't want to unplug ALL other equipment including TV and if it makes a differnce you turn them on one by one?
Reply
#14
I finally nailed it down to my LCD TV. Anywhere within 7-8 feet and the receiver was picking up a constant signal. Turn off the TV and the signal disappeared. Some web searching lead me to a post where someone said they had a similar problem and figured out that it was the TV's "brightness sensor"/"energy saver" feature. I went in and turned that off and now the remote works. Go figure!

Thanks to all that replied and helped in this thread. Especially you papaf for the suggestion that lead to figure this all out.
Reply
#15
LOL,

I've been trying to figure out what I've been doing wrong with my new MCE receiver for nearly 18 hours now, I was on the edge of being devoiced. I then found this little post, BAM issue solve EekEekEek

THANKS
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LIVE] MCE Remote not working00