Thread Rating:
  • 0 Vote(s) - 0 Average
atv: xbmc & win7+homegroup

I'm used to have my atv ( mounting the SMB shares from my local server (

Recently I upgraded the server to Win7. Here a cool network functionality is homegroup. This facilitate the audio-video-pictures-document across the home network. Unfortunately when it is active, the ATV can't connect anymore:

20:34:14 T:2684407808 M: 51183616 NOTICE: starting zeroconf publishing
20:34:16 T:2684407808 M: 48345088 WARNING: CUtil::GetMatchingSource... no matching source found for [Plugin video]
20:34:18 T:2684407808 M: 24895488 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://xbox:[email protected]'
unix_err:'2' error : 'No such file or directory'
20:34:18 T:2684407808 M: 24895488 ERROR: GetDirectory - Error getting smb://xbox:[email protected]/
20:34:18 T:2684407808 M: 24895488 ERROR: CGUIMediaWindow::GetDirectory(smb://xbox:[email protected]/) failed
20:35:20 T:51526656 M: 23560192 NOTICE: ES: Client from timed out

For the time-beeing I disabled homegroup and share connection are restored.
Any idea how to troubleshoot what's wrong ? Both ATV and Win7 seems to not provide useful debug informations.

Btw, my source.xml is the following.
And yes, xbox:xbox is the user sharing the resources.

-bash-2.05b$ more sources.xml
<path>smb://xbox:[email protected]</path>

ATV: 2.4
XBMC: 9.04.1.r20621 (Compiled: May 24 2009)
Launcher: 3.1

Any idea/suggestion ?
Any one with similar experience ?


I made some more investigation and apparently the things that changed with win7 is that now you smb is not always able to retrieve the general share list.

So if instead of:
smb://xbox:[email protected]
I define:
smb://xbox:[email protected]/vcd
smb://xbox:[email protected]/pictures

then the atv correctly show up the contents.

Its a pity to not have the full listing.
Hope that someday the xbmc will interact directly with homegroup functionality which, as I said earlier, is a cool ones.

after several google-search I found my answers...

Original URL:

Apparently in Vista/Win7 you can no longer remotely connect to admin shares in a workgroup environment, even if you have admin credentials for the remote machine.

-workaround #1-
create a password for the user named "Administrator", then use the username Administrator and the password you set for it as the login when you access the machine remotely.

-workaround #2-
You can also allow access to the administrative shares by any local administrator by creating a registry entry.

Create or modify the following registry value:


This is a DWORD value. Set it to 1.

Workaround #2 IS my solution !!
So, since this was working before, I guess that some patches has enhanced security removing the registry key.

Thanks for this post!! I am also running windows 7 and am having a difficult time getting XBMC on apple tv to find my shares. I am also running XBMC on a windows laptop and don't have any problem connecting to the same shares. When I try to connect via apple tv, it just keeps asking for my password. I believe everything is in the proper format, or it wouldn't have worked on the window's laptop. I have also created the mentioned registry entry and have disabled homegroup. Does anyone have any suggestions of what else I could try?
I had this exact issue just now, was driving me insane! This is how I did the fix:

My Computer > Network > Desktop >
Right Click "dvd" (aka your share folder)
Click Properties
Click the Security Tab

I'm not sure which one of these fixed it, but I have the following Groups/Users in mine:
Administrators (Desktop/Administrators)
Users (Desktop\Users)

The problem lied in some of these users/groups not added to this list and/or them not having enough privaledges.

I'm a total noob so im sure you can figure it out from here, but this is where the problem lies! For Win7 users that is...
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
atv: xbmc & win7+homegroup00