Several bugs spotted
#1
Some (mostly cosmic) bugs I found in v 2.0:

VideoOSDBookmarks.xml

- Dialog size

I think it was reported before, the bookmark window in fullscreen needs a cleanup. Buttons too low, thumbs too large etc..

- Font color of selected item

I looked through VideoOSDBookmarks.xml to fix the size problem by myself and noticed that you intend to change the font color of select items. Apperently <selectedcolor>blue</selectedcolor> doesn't work, changed to <textcolor> fixes the issue. Haven't noticed any side effects yet.

MusicOSD.xml

- No 'record in progress' icon

The icon with the darker red circle (player-recordrecording-focus.png I think), indicating recording in progress, won't show up.

- Placement of record-button vs. next track

I think with the current layout we might get into trouble when a source has both, record capatibilities and 'next track' (audio-cds?!).

MyMusicPlaylist.xml

- No coverart/song info in fanart view

Don't know if it's by design, but there is no coverart/song info in fanart view.

That all for now..
Reply
#2
topkat Wrote:VideoOSDBookmarks.xml
- Font color of selected item

I looked through VideoOSDBookmarks.xml to fix the size problem by myself and noticed that you intend to change the font color of select items. Apperently <selectedcolor>blue</selectedcolor> doesn't work, changed to <textcolor> fixes the issue. Haven't noticed any side effects yet.

hmm...it's indeed not working. guess xbmc doesn't support it in this window.
note, 'selectedcolor' is something different than 'focusedcolor' what i think is what you've changed.

topkat Wrote:MusicOSD.xml

- No 'record in progress' icon

The icon with the darker red circle (player-recordrecording-focus.png I think), indicating recording in progress, won't show up.

- Placement of record-button vs. next track

I think with the current layout we might get into trouble when a source has both, record capatibilities and 'next track' (audio-cds?!).

i indeed removed the record button due to a lack of space and because i had no idea what it's used for. but i guess it's used for ripping cd's ?

if i move the buttons a little closer together there should be enough room to bring it back.

topkat Wrote:MyMusicPlaylist.xml

- No coverart/song info in fanart view

Don't know if it's by design, but there is no coverart/song info in fanart view.

ha! i beat you to it! i just added it about an hour ago. ;-)

cheers for taking such a close look at the skin.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
Ich kann mich nur zurück bedanken für diesen tollen Skin! Mach weiter so!

Der 'record' button wird z.B. bei Shoutcast Streams zum Aufnehmen verwendet (hier gibts allerdings keine 'next track' Anzeige.. Hab grad keine Audio-CD zur Hand, aber ich nehme mal an dass der Knopf in diesem Fall den Rip-Vergang startet.
Reply
#4
topkat Wrote:Ich kann mich nur zurück bedanken für diesen tollen Skin! Mach weiter so!

Der 'record' button wird z.B. bei Shoutcast Streams zum Aufnehmen verwendet (hier gibts allerdings keine 'next track' Anzeige.. Hab grad keine Audio-CD zur Hand, aber ich nehme mal an dass der Knopf in diesem Fall den Rip-Vergang startet.

What's with the german?
Reply
#5
magnetism Wrote:What's with the german?

Um sorry, since I though ronnie is German, it was easier for me to explain it in my native language, but ok, switch back to English mode.

In a nutshell:

The record button is used to record shoutcast streams, and I think (but not for sure) for ripping audio-cds too. Shoutcast streams don't have a 'next track'-indicator, hence no collison with the record button. ATM I have no cd to test, but if I remeber right xbmc will show both, 'next'-label and record button when playing back cd-tracks, hence they will overlap each other in the current layout.

Edit:

I just noticed an other problem in VideoOSD.xml:

When a tv episode has no scraped screenshot, the OSD will show up the default image (hd-cam), even when xbmc has automatically extracted thumbs from the source file ('generate thumbs for vidoes with no cover' option turned on). Same with the 'now playing'-display on home screen. In library mode it works though. The files are stored on a smb-share, maybe that's the problem.
Reply
#6
topkat Wrote:I just noticed an other problem in VideoOSD.xml:

When a tv episode has no scraped screenshot, the OSD will show up the default image (hd-cam), even when xbmc has automatically extracted thumbs from the source file ('generate thumbs for vidoes with no cover' option turned on). Same with the 'now playing'-display on home screen. In library mode it works though. The files are stored on a smb-share, maybe that's the problem.

i can't do anything about it, i'm afraid.
it's all handled by xbmc. no clue why it doesn't use the auto-generated thumbs in some places.

i'm not german btw. ;-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#7
Sorry, my fault, though I saw your write in German in another thread, probably mixed it up somehow...
Reply
#8
Sorry for hijacking the thread but another small bug?

The mouse scroll wheel does not work in the skin settings...

(to scroll down to see more options)

It seems to work everywhere else in T!

Edit: okay, I'll take that back. It does actually work, but only when moving the cursor over the scroll bar first...

(which kind of makes sense, so yeah, nevermind)

Daaamn, it's *so* hard to find bugs in Transparency! Wink
Reply
#9
Quote:Daaamn, it's *so* hard to find bugs in Transparency!

If you look hard enough you'll find them Laugh

When in the info-dialog for movies or tv-shows, with the fanart-button selected, the skin doesn't show up the current fanart-image. Can't take a screenshot, seems to be broken in the latest svn-build.
Reply
#10
topkat Wrote:If you look hard enough you'll find them Laugh

hopefully most have been caught by now. i've hardly seen any new bugreports over the past few days.

topkat Wrote:When in the info-dialog for movies or tv-shows, with the fanart-button selected, the skin doesn't show up the current fanart-image. Can't take a screenshot, seems to be broken in the latest svn-build.

ahhhh...too bad, this one doesn't count. it's been reported before. ;-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#11
Well then, how about a feature reqest? Support for last.fm love&hate buttons in music-osd?

Have done it myself, it's really simple. All you need is a button and the 'XBMC.LastFM.Love' function, eg

Code:
<control type="button" id="9000">
    <posx>-80</posx>
    <posy>0</posy>
    <description>lastfm love</description>
    <width>40</width>
    <height>40</height>
    <texturenofocus>osd-love-nofocus.png</texturenofocus>
    <texturefocus>osd-love-focus.png</texturefocus>
    <onleft>907</onleft>
    <onright>9001</onright>
    <onup>901</onup>
    <ondown>901</ondown>
    <onclick>XBMC.LastFM.Love</onclick>    
    <visible>LastFM.CanLove</visible>
</control>

But 'official' support would be better though..
Reply
#12
previous versions of T! had support for the last.fm love/hate feature, but it was removed at some point. i thought it was cluttering up the side menu (that's where it was located) too much and had the impression it was some obscure feature nobody would miss.

i'll consider re-adding it to the osd.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#13
Yeah I have to say I actually use the last.fm love/hate thingy too so if it could be reinstated that would be smashing. Also, for the xbox media flagging to work you need to scan movies in stages or else it just freezes (scanning movies by year works for me) so would it be possible to somehow allow the movies home button to go the menu where it asks if you want to search by title, genre, year etc.? At the moment it takes you straight to the "search by title" option and there seems to be no way of getting back to the "search by..." screen, maybe this could be an option in skin settings - I am no coder so have no idea what I'm talking about so please feel free to tell me to shut up! Btw I have edited my includes_home.xml file so that "Movies" takes me to the screen I need so it's not a big problem but would be nice if xbox users didn't have to change code when there's any future updates. Sorry if none of that makes sense - I've just got back from the pub!!!
Reply
#14
whufclee Wrote:Yeah I have to say I actually use the last.fm love/hate thingy too so if it could be reinstated that would be smashing. Also, for the xbox media flagging to work you need to scan movies in stages or else it just freezes (scanning movies by year works for me) so would it be possible to somehow allow the movies home button to go the menu where it asks if you want to search by title, genre, year etc.? At the moment it takes you straight to the "search by title" option and there seems to be no way of getting back to the "search by..." screen, maybe this could be an option in skin settings - I am no coder so have no idea what I'm talking about so please feel free to tell me to shut up! Btw I have edited my includes_home.xml file so that "Movies" takes me to the screen I need so it's not a big problem but would be nice if xbox users didn't have to change code when there's any future updates. Sorry if none of that makes sense - I've just got back from the pub!!!

if you're in the movie list, use the 'up' icon to navigate to the parent folder.
in case there's no 'up' icon, you've disabled it in Settings > Appearance > View Options > Hide parent folder items
Also make sure you uncheck 'Flatten' on the side menu.

Another option would be to use the Videos button on the Home Menu.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#15
Well done Ronie, I am officially an idiot. I thought it was strange the parent folder had disappeared - I was sure I had it a while ago, must have disabled it in settings - doh! Sorry for wasting your time.
Reply



Logout Mark Read Team Forum Stats Members Help
Several bugs spotted0
This forum uses Lukasz Tkacz MyBB addons.