couple of bugsthat I think are Transparancy related
#1
Hi Ronie. I have a couple of probs using Transparancy 2.0 on the xbox. Just done a fresh install with r22867 to see if the bugs would disappear but the pesky bleeders are still there.

The first is when I have media flags enabled browsing my movies causes the xbox to freeze. Using PM3HD and there is no freeze.

Second is that some TV shows do not show the 'episodes watched and unwatched' info when in fanart view. However this doesn't happen if in media info view. The offending shows are Far Flung Floyd, Floyd on Britain, The Rock 'n' Roll Years and Land Girls. In the log all these are mentioned with 'ERROR: InputStream: Error opening'

The xbmc.log is here
Reply
#2
looks like your issues are caused by 'Out of memory' problems.
i'm afraid there's little i can do about that.
you can try if disabling weather.com and/or media flags solves it.
or maybe try the xbox friendly version of the skin, since this version comes with reduced backgrounds it should be a bit less memory consuming.

the only skin related errors in your log are the 'missing includes' which i'll fix. ;-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
I tried again with debug mode on and there was just over 20MB free when it froze.

Also slightly OT when I have Media flags enabled all my films are shown with the DVD logo?? Xvids for example are shown as xvid and DVD, whilst DVDs are shown as just DVD. I'm guessing this is a problem with XBMC but just wanted to check if other Xbox Transparancy users experience the same issue.
Reply
#4
yadster Wrote:I tried again with debug mode on and there was just over 20MB free when it froze.

Also slightly OT when I have Media flags enabled all my films are shown with the DVD logo?? Xvids for example are shown as xvid and DVD, whilst DVDs are shown as just DVD. I'm guessing this is a problem with XBMC but just wanted to check if other Xbox Transparancy users experience the same issue.

xvid = videocodec
dvd = source

so, those are two different things.
if you're using native media flagging, it doesn't support dvd's yet, so it can't detect the videocodec
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#5
yadster Wrote:Second is that some TV shows do not show the 'episodes watched and unwatched' info when in fanart view. However this doesn't happen if in media info view. The offending shows are Far Flung Floyd, Floyd on Britain, The Rock 'n' Roll Years and Land Girls. In the log all these are mentioned with 'ERROR: InputStream: Error opening'

The xbmc.log is here

I've just updated to the latest version of transparancy and am still getting the same problem. I also notice it does the same for the tv show 'House'. Not sure if that helps. Cheers Smile
Reply
#6
I just wondered if it's just me having problems with 'watched and unwatched episodes' info not showing in TV fanart view. I've just added Micro Men and that also fails to show 'watched unwatched' info.
Reply
#7
yadster Wrote:I just wondered if it's just me having problems with 'watched and unwatched episodes' info not showing in TV fanart view. I've just added Micro Men and that also fails to show 'watched unwatched' info.

i had another look at the code and it turns out the 'watched/unwatched' info is not shown if there's no tv show thumb available for that show.

could this be the case?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#8
ronie Wrote:i had another look at the code and it turns out the 'watched/unwatched' info is not shown if there's no tv show thumb available for that show.

could this be the case?

Micro Men definitely has a thumb as I uploaded it to tvdb myself. Just to recheck I removed it from the library then rescanned it in but still the same issue. Not sure what else I can add but thanks for looking.
Reply
#9
just to make sure, open View-Fanart.xml and look up this code:
PHP Code:
<control type="label">
    <
posx>40</posx>
    <
posy>565</posy>
    <
width>785</width>
    <
height>30</height>
    <
font>font-20</font>
    <
textcolor>white</textcolor>
    <
shadowcolor>black</shadowcolor>
    <
scroll>true</scroll>
    <
align>center</align>
    <
aligny>center</aligny>
    <
label>$INFO[ListItem.Episode,$LOCALIZE[20360] : ] [color=lightblue$INFO[ListItem.Property(WatchedEpisodes),(, $LOCALIZE[16102] - ]$INFO[ListItem.Property(UnWatchedEpisodes), , $LOCALIZE[16101])][/color]</label>
    <
scrollspeed>0</scrollspeed>
    <
visible>!Window.IsVisible(Videofiles) + !IsEmpty(Listitem.thumb)</visible>
</
control

remove this line:
<visible>!Window.IsVisible(Videofiles) + !IsEmpty(Listitem.thumb)</visible>

restart xbmc and test again.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#10
Thumbs Up 
You sir are a gentleman and a scholar. Thanks for putting up with me and fixing the problem. Have a 'virtual' beer on me. Cheers.Big Grin
Reply
#11
no problem, glad it's working now.

it was just a quick fix, i'll see if i can come up with a better way of doing this in the next T! release.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply



Logout Mark Read Team Forum Stats Members Help
couple of bugsthat I think are Transparancy related0
This forum uses Lukasz Tkacz MyBB addons.