Thread Rating:
  • 0 Vote(s) - 0 Average
XBMC fails assert in pulseéstream.c on startup
#1
Occassionally, when I start XBMC, the window comes up briefly, but it immediately exits out. Once the problem starts, I can`t make it stop, and the only way around it that I`ve found so far is rebooting. Running it from the command-line i`ve learned that it looks to have something to do with sound:

$ xbmc
The XBMC_HOME environment variable is not set.
StdString: Assertion Failed on line 916
StdString: Assertion Failed on line 917
StdString: Assertion Failed on line 916
StdString: Assertion Failed on line 917
ALSA lib pcm_pulse.c:626Sadpulse_prepare) PulseAudio: Unable to create stream: Invalid argument

E: stream.c: Assertion 's' failed at pulse/stream.c:1224, function pa_stream_drain(). Aborting.
Aborted



Linux walter 2.6.29-02062906-generic #02062906 SMP Fri Jul 3 10:56:30 UTC 2009 i686 GNU/Linux
xbmc 9.0.4.1-jaunty1 PPA
Log is here: http://pastebin.ca/1578737

and here`s my sound hardware:
$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

Anybody know what this is about or how to fix it

Thanks.

-Nathan.
Reply
#2
Try a newer build, if it still happens, check the sticky about posting problems in a useful manner for instructions on creating a stack trace.
Reply
#3
I`m running babylon (9.04.1) and I don`t think anything later than that has been released. Would you like me to try from svn?

Edit: Nevermind, found there are svn build ppas. I`ve upgraded 9.04.3, we`ll see how that goes.
Reply
#4
Just a note. This is always preceded by an unclean shutdown of xbmc. So it's leaving something around and not expecting this at xbmc startup.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC fails assert in pulseéstream.c on startup00