"Just Scan" on Samsung TV
#1
I've got an Asrock 330 hooked up to a Samsung 46" LCD TV.
They are connected via HDMI.

I have set the TV to "Just Scan" and the picture looks perfect.

However, if I reboot the Asrock, the TV switches back to 16:9 mode and I have to switch it back to "Just scan".

Has anyone with a Samsung TV had similar behaviour?
Reply
#2
Mine stays on Just Scan... I have a 40 though. Lnt4061f.

Maybe goto the setup of the TV and change it there (instead of cycling through them). See if that makes a difference.
42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#3
Had the same issue with my display reverting back after my receiver is turned off or the HTPC starts.

The fix is to hold the menu button down for 10secs untill Dynamic is displayed - It should now remember to stay on "Just Scan"
Reply
#4
i have the same trouble on my samsung, works from the windows box fine as second display, maybe it gets confused due to the bootscreen? ill give AzzX suggestion a try, also i dont really get it, dynamic is usual a viewmode... we will see
Reply
#5
Hi!

I have the same problem with my Samsung LE40A866 TV.
Shop-mode is not the issue for me, I have set my TV to "home-mode".

Whenever I reboot (my Asrock Ion 330 with Ubuntu 9.04 and XBMC) it changes back to 16:9 everytime. All other settings are saved accept the "just scan" setting.

Did you find a solution for the problem?
Reply
#6
I have the same issue...
Running XBMC on Ubuntu, ION 330
Reply
#7
Big Grin 
I had the same problem on my Samsung TV and after spending hours searching all kinds of forums I finally found a solution (can't remember where I found the answer though):

1. Connect HTPC to HDMI2 on TV
2. Rename HDMI2 in the TV setup menu to "PC"

After I've done this, only "4:3" and "16:9" aspects are available for HDMI2, but "16:9" behaves like "just scan" and it survives a reboot of the HTPC.
Reply
#8
Alphix Wrote:1. Connect HTPC to HDMI2 on TV
2. Rename HDMI2 in the TV setup menu to "PC"

Lucky you! this didnt work for me.. think Ive got a series 6. Ill keep searching for an answer and in the meantime use a macro on my mx-810 to control it.
Reply
#9
Didn't work for me either...

Would be nice if you could disable the different sizes - as I ONLY use "Just scan".
Also the different sources that you dont use, annoying that you have to jump over those you dont use.
Reply
#10
It's because you use your xorg.conf is set to negotiate the resolution with the tv through the edid.

Turn of ed-id and set the resolution manually, that wil fix it. The tv will always stay on just scan.

This is the xorg.conf i use:

Code:
Section "Device"
  Identifier  "Device0"
  Driver      "nvidia"
  VendorName  "NVIDIA Corporation"
EndSection

Section "Screen"
  Identifier  "Screen0"
  Device      "Device0"
  Monitor     "Monitor0"

  # Fixes issue with modesetting on xbmc
  Option      "ExactModeTimingsDVI" "True" # we have proper modelines
  Option      "UseEDIDFreqs"        "True" # trust no edid
  Option      "ModeValidation"      "NoEdidModes, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes" trust no edid
  Option      "FlatPanelProperties" "Scaling = Native" # make sure the gpu does not scale and loose performance

  # Fixes tearing/smoothvideo issues
  Option      "DynamicTwinView"           "False" # disable or you'll get tearing
  Option      "TripleBuffer"              "0" # disable or xbmc will segfault with smoothvideo

  # Misc
  Option      "NoLogo"                    "True" # we're not myspace

  DefaultDepth  24
  SubSection "Display"
    Depth       24
    Modes      "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]"
  EndSubSection
EndSection

Section "Monitor"
  Identifier  "Monitor0"

  HorizSync   20.0 - 150.0
  VertRefresh 22.0 - 90.0

  # 1920x1080p @ 50Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 60Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 24Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 74.250 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 59.94Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 148.350 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 25Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 74.250 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 29.97Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 74.175 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
  # 1920x1080p @ 30Hz (EIA/CEA-861B)
  ModeLine "[email protected]" 74.250 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
EndSection

Section "Extensions"
  # fixes tearing with vdpau/vsync
  Option      "Composite"           "Disable"
EndSection
Reply
#11
but ubuntu Januty is reporting mode is not supported. Is this something to do with the resolutions I've selected. Please find xorg.conf below. Any help would be great thanks.

Section "Monitor"
Identifier "LE37M87BD"
HorizSync 31.5-67
VertRefresh 56-65
Modeline "1920x1080_50.00" 141.50 1920 2032 2232 2544 1080 1083 1088 1114 -hsync +vsync
Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
Modeline "1920x1080_24.00" 63.00 1920 1976 2160 2400 1080 1083 1088 1098 -hsync +vsync
Modeline "1920x1080_23.98" 63.00 1920 1976 2160 2400 1080 1083 1088 1098 -hsync +vsync
Modeline "1920x1080_59.94" 172.75 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
Modeline "1920x1080_25.00" 65.75 1920 1976 2160 2400 1080 1083 1088 1099 -hsync +vsync
Modeline "1920x1080_29.97" 79.50 1920 1976 2168 2416 1080 1083 1088 1102 -hsync +vsync
Modeline "1920x1080_30.00" 79.75 1920 1976 2168 2416 1080 1083 1088 1102 -hsync +vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "LE37M87BD"
Device "Configured Video Device"
Option "ExactModeTimingsDVI" "True" # we have proper modelines
Option "UseEDIDFreqs" "True" # trust no edid
Option "ModeValidation" "NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes" #trust no edid

#"NoEdidModes"

# Fixes tearing/smoothvideo issues
Option "DynamicTwinView" "False" # disable or you'll get tearing
Option "TripleBuffer" "0" # disable or xbmc will segfault with smoothvideo

Option "FlatPanelProperties" "Scaling = Native" # make sure the gpu does not scale and loose performance
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
Reply
#12
I get this problem with a 2007 Samsung 40" 720p LCD HDTV LN-T4053H connected to a Raspberry Pi with Kodi 17.6.

Kodi 16 was able to set the resolution correctly without my having to go into the TV's settings and setting "Just Scan".

Also, do these Samsung TVs have an internal battery that needs replacing? My TV doesn't remember any settings (except it does remember TV channels), and sometimes it loses the "Just Scan" setting even while the TV is on!
Reply



Logout Mark Read Team Forum Stats Members Help
"Just Scan" on Samsung TV0
This forum uses Lukasz Tkacz MyBB addons.