uPNP problems sometime after rev21142
#23
Ok, the problem has changed. I now get a black screen instead of a lockup

First time I started the sytem, I booted in debug mode. I clicked file manager and this is what came up. The left side was the first click on uPnP, the right was the 2nd click. Eventually the left side came up too after the server was detected and I refreshed the left side.
Image
After a few minutes, nothing else would show up. So I clicked the back button to test other media types.

When I clicked the back button, the screen went black. I could see the hard drive button lighting up whenever I clicked a button. The processor reacted as well. There was no critical halt, but it stayed on a black screen for about 3 minutes with 0% processor activity unless I hit a button.

I was in debug mode, so here's the log

http://pastebin.com/f64a31b77

It didn't freeze when establishing a initial uPnP link in debug mode the first time, however the 2nd time, out of debug mode it did. With the exception of it not freezing in debug mode, I don't really notice any changes to this sub-version. It freezes out of debug mode, but in debug mode there is no halt.

My network currently consists of a windows XP computer running an ORB uPnP server, a Windows Media uPnP server, a BeyondTV uPnP server/http server- A laptop running windows Vista with a Windows Media uPnP server and it is wireless-G to my Linksys WRT320N router. The xbox and desktop are 4pr/CAT-5e/RJ45 connected LAN @ 100mbps. I am also running a wireless-G iPhone as a non-server client to the network. All settings on the router have been verified. No servers are showing up from the desktop on XBMC. The Vista laptop shows all servers from the desktop.

Is it possible that the current setup only allows for one uPnP instance per IP/Name? or that references to different servers on the same port on the same machine will cause it to handle unexpectedly?

I've opened up a ticket for a related issue in TRAC. Ref: 7320. http://trac.xbmc.org/ticket/7320, My beyondTV server has never connected to xbmc, but WMP servers do. I thought there were opened work orders on this issue until I got on there and found there was none for BTV. There wasn't even one for the uPnP issues that I could find.


Messages In This Thread
[No subject] - by Geeba - 2009-09-28, 09:15
[No subject] - by Numus - 2009-09-28, 15:19
[No subject] - by whitney - 2009-09-28, 17:50
[No subject] - by whitney - 2009-09-28, 18:17
[No subject] - by CrashX - 2009-09-28, 18:41
[No subject] - by whitney - 2009-09-28, 18:49
[No subject] - by whitney - 2009-09-28, 19:17
[No subject] - by Numus - 2009-09-28, 19:42
[No subject] - by whitney - 2009-10-01, 07:16
[No subject] - by c0diq - 2009-10-01, 10:19
[No subject] - by c0diq - 2009-10-01, 10:27
[No subject] - by Geeba - 2009-10-01, 11:16
[No subject] - by whitney - 2009-10-01, 14:09
[No subject] - by whitney - 2009-10-01, 14:38
[No subject] - by outleradam - 2009-10-07, 04:35
[No subject] - by Geeba - 2009-10-07, 09:29
[No subject] - by whitney - 2009-10-07, 15:56
[No subject] - by Geeba - 2009-10-07, 16:10
[No subject] - by outleradam - 2009-10-09, 21:14
Platinum update - by c0diq - 2009-10-10, 21:21
[No subject] - by outleradam - 2009-10-11, 10:41
[No subject] - by outleradam - 2009-10-11, 11:43
[No subject] - by outleradam - 2009-10-13, 02:28
[No subject] - by whitney - 2009-10-13, 06:58
[No subject] - by Geeba - 2009-10-13, 11:29
[No subject] - by Numus - 2009-10-13, 14:26
[No subject] - by whitney - 2009-10-13, 14:45
[No subject] - by elupus - 2009-10-13, 16:13
[No subject] - by whitney - 2009-10-13, 17:25
[No subject] - by Geeba - 2009-10-13, 23:53
[No subject] - by outleradam - 2009-10-14, 05:39
[No subject] - by outleradam - 2009-10-14, 06:01
[No subject] - by whitney - 2009-10-14, 07:04
[No subject] - by outleradam - 2009-10-14, 20:49
[No subject] - by whitney - 2009-10-28, 05:03
[No subject] - by whitney - 2009-10-29, 06:33
[No subject] - by arnova - 2009-10-29, 14:39
[No subject] - by whitney - 2009-11-06, 23:23
[No subject] - by arnova - 2009-11-07, 01:27
[No subject] - by c0diq - 2009-12-03, 00:16
[No subject] - by whitney - 2009-12-03, 02:02
[No subject] - by sion28 - 2009-12-05, 00:20
[No subject] - by kemik - 2009-12-08, 14:00
[No subject] - by sion28 - 2009-12-10, 21:37
[No subject] - by Stevie69 - 2010-03-17, 23:58
[No subject] - by n8mack33 - 2010-03-18, 01:55
[No subject] - by spdabbs - 2010-03-26, 10:19
[No subject] - by malsbury - 2010-03-28, 04:20
[No subject] - by arnova - 2010-03-29, 08:36
[No subject] - by nchall - 2010-03-30, 07:19
[No subject] - by spdabbs - 2010-04-01, 22:05
[No subject] - by Geeba - 2010-04-03, 10:29
[No subject] - by arnova - 2010-04-03, 10:43
[No subject] - by Geeba - 2010-04-03, 10:58
[No subject] - by joshuaali - 2010-04-03, 13:35
[No subject] - by arnova - 2010-04-03, 13:36
[No subject] - by johnscrub - 2010-04-03, 13:48
[No subject] - by Geeba - 2010-04-05, 11:47
[No subject] - by joshuaali - 2010-04-06, 14:29
[No subject] - by joshuaali - 2010-04-06, 14:30
[No subject] - by joshuaali - 2010-04-06, 15:46
[No subject] - by Geeba - 2010-04-06, 16:39
[No subject] - by arnova - 2010-04-08, 07:33
[No subject] - by joshuaali - 2010-04-08, 08:25
[No subject] - by willers.nail - 2010-04-08, 11:16
[No subject] - by Bomb Bloke - 2010-04-09, 04:36
[No subject] - by joshuaali - 2010-04-09, 11:42
[No subject] - by Bad Joker - 2010-04-10, 16:10
[No subject] - by joshuaali - 2010-04-10, 17:07
[No subject] - by Bad Joker - 2010-04-11, 00:26
[No subject] - by joshuaali - 2010-04-11, 01:47
[No subject] - by teresa - 2010-04-11, 04:58
[No subject] - by arnova - 2010-04-11, 12:11
[No subject] - by Bad Joker - 2010-04-11, 20:29
[No subject] - by arnova - 2010-04-12, 08:31
[No subject] - by Bomb Bloke - 2010-04-12, 15:02
[No subject] - by Bad Joker - 2010-04-12, 23:26
[No subject] - by Scott R - 2010-04-16, 22:50
[No subject] - by sethjvm - 2010-04-29, 01:18
[No subject] - by spdabbs - 2010-05-01, 08:07
[No subject] - by teresa - 2010-05-08, 19:43
same problem - by maraxion - 2010-05-13, 01:14
[No subject] - by maraxion - 2010-05-14, 01:56
UPNP Still Freezes - by rower - 2010-06-04, 20:28
[No subject] - by joshuaali - 2010-06-05, 01:36
[No subject] - by arnova - 2010-06-06, 15:31
[No subject] - by joshuaali - 2010-06-06, 18:38
[No subject] - by Bomb Bloke - 2010-06-07, 01:06
[No subject] - by arnova - 2010-06-07, 08:07


Logout Mark Read Team Forum Stats Members Help
uPNP problems sometime after rev211420
This forum uses Lukasz Tkacz MyBB addons.