Transparency! slow on ATV
#1
ronie Wrote:uhhh...don't misinterpret my reply. you didn't step on my toes.
i was just trying to answer you question.... ;-)

Smile

The main reason I wanted to try and do something like this is to try and speed up the ATV and Transparency!. I still find it a bit slow.

I do like the Fanart and its very nice but scrolling through all the TV shows or movies seems a bit slow. It is loading the fanart for every movie that it goes through. Is there any way to delay loading of the fanart?

I thought if the main background is static, changing the image on the theatre screen might be faster.

Zeljko
Reply
#2
Amet Wrote:Smile

The main reason I wanted to try and do something like this is to try and speed up the ATV and Transparency!. I still find it a bit slow.

I do like the Fanart and its very nice but scrolling through all the TV shows or movies seems a bit slow. It is loading the fanart for every movie that it goes through. Is there any way to delay loading of the fanart?

I thought if the main background is static, changing the image on the theatre screen might be faster.

Zeljko

i don't think it would matter. the skin will still have to load the entire fanart image, even if you display it at a smaller size.
in fact the fanart is loaded in the background, so it should not influence scrolling through the library at all.

it might be the loading of the dvd covers that's slowing things down...
what view are you using? are all of them equally slow?
try the 'thumbnail' and 'icon' views, i'm using background loading for the dvd covers in those views, so let me know if scrolling is faster in those views.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
ronie Wrote:i don't think it would matter. the skin will still have to load the entire fanart image, even if you display it at a smaller size.
in fact the fanart is loaded in the background, so it should not influence scrolling through the library at all.

it might be the loading of the dvd covers that's slowing things down...
what view are you using? are all of them equally slow?
try the 'thumbnail' and 'icon' views, i'm using background loading for the dvd covers in those views, so let me know if scrolling is faster in those views.

When I am scrolling through tv shows in Fanart view there is no DVD cover. What I have noticed is that it takes about 2-3 seconds to load the fanart, but if I go back to the previous one it is almost instantaneous. I hope you understand what I mean.

The cpu usage is quite high, about 78% just idling on the Fanart view, and it drops to 40-48% when I go back to home screen.

Zeljko
Reply
#4
Amet Wrote:When I am scrolling through tv shows in Fanart view there is no DVD cover. What I have noticed is that it takes about 2-3 seconds to load the fanart, but if I go back to the previous one it is almost instantaneous. I hope you understand what I mean.

ok, so it's not the dvd cover...it just takes a long time to load the fanart.
one thing you could try is disable media flagging in Skin Settings.
if that doesn't help.....Debug Log? ;-)

Amet Wrote:The cpu usage is quite high about 78% just idling on the Fanart view, and it drops to 40-48% when I go back to home screen.

how does it compare to PM3.HD? could you give me the cpu values in the same views in PM3.HD?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#5
ronie Wrote:ok, so it's not the dvd cover...it just takes a long time to load the fanart.
one thing you could try is disable media flagging in Skin Settings.
if that doesn't help.....Debug Log? ;-)
Here is the debug log. If you need more info just let me know

ronie Wrote:how does it compare to PM3.HD? could you give me the cpu values in the same views in PM3.HD?

cpu values on PM3.HD are 26-29% on Home screen and 46-50% on Tvshows screen in Fanart view with the same tv show selected(tried to make it consistent)

Hope it helps

Thanks
Zeljko
Reply
#6
i don't see anything out of the ordinary in the Debug Log.
on my pc Transparency! idles at 15% in fanart view and PM3.HD at 12%.

i've moved this discussion to a separate thread, so maybe other ATV users can share their experiences.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#7
Just my observations, not so much a critique/demand/request/etc.

I recently bought an appletv and got xbmc on it, so I only have a couple weeks experience with it.

I've tried the latest transparency (2.01 as I recall), and observed some of the same behavior mentioned in the 1st post of topic.

In particular, I was trying to use the movie slide mode, but the horizontal scrolling was pretty slow and even still alot of times (the dvd cover) images would not be loaded as they scroll past. I realize that the fanart normally pops in the background when you pause on a movie, but the same thing happened with the dvd covers, typically only showing up when you stop.

I don't know if its a cache/memory issue or cpu processing, but I have ~650 movies listed when no filtering and it only takes a dozen or movies worth of scrolling for it to get behind.

Also as a side note, in slide mode when you move to the scrollbar under the movie slide, it still only moves 1 movie at a time instead of the expected page at a time. And the plot window did not seem sized right (xbmc and atv set for 720p full screen).

I was going to, and still intend to, try the xbox version, I just haven't taken the time.

Great skin tho, I really like it.
Reply
#8
ronie Wrote:i don't see anything out of the ordinary in the Debug Log.
on my pc Transparency! idles at 15% in fanart view and PM3.HD at 12%.

i've moved this discussion to a separate thread, so maybe other ATV users can share their experiences.

Transparency! 2.01 on my MacBook Pro also uses fair amount of CPU.

Transparency! on MacBook Pro Core 2 Duo 2.2 Ghz:
31% on home and 46% in Videos(dont have the same DB to test with the same TVshow)

PM3.HD on MacBook Pro Core 2 Duo 2.2 Ghz:
20% on home and 30% in Videos with the same movie Fanart.

I suspect it has to do with the OSX/ATV build.

Regards
Zeljko
Reply
#9
TeknoJnky Wrote:Just my observations, not so much a critique/demand/request/etc.

I recently bought an appletv and got xbmc on it, so I only have a couple weeks experience with it.

I've tried the latest transparency (2.01 as I recall), and observed some of the same behavior mentioned in the 1st post of topic.

In particular, I was trying to use the movie slide mode, but the horizontal scrolling was pretty slow and even still alot of times (the dvd cover) images would not be loaded as they scroll past. I realize that the fanart normally pops in the background when you pause on a movie, but the same thing happened with the dvd covers, typically only showing up when you stop.

true, in slide view i'm also loading the covers in the background. the benefit of this is that you can quickly scroll through the list, without having to wait for the cover to load first.
i'm not sure why scrolling is slow on the atv though.

TeknoJnky Wrote:I don't know if its a cache/memory issue or cpu processing, but I have ~650 movies listed when no filtering and it only takes a dozen or movies worth of scrolling for it to get behind.

Also as a side note, in slide mode when you move to the scrollbar under the movie slide, it still only moves 1 movie at a time instead of the expected page at a time.

yup, the scrollbar in slideview is broken. i'm aware of it, but haven't been able to find a fix for it yet.

TeknoJnky Wrote:And the plot window did not seem sized right (xbmc and atv set for 720p full screen).

this was an issue in xbmc and is fixed in r23204
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply



Logout Mark Read Team Forum Stats Members Help
Transparency! slow on ATV0
This forum uses Lukasz Tkacz MyBB addons.