•   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)
USB drive not appearing
#91
@topfs2

Thanks for the heads up. I wasn't aware that Jaunty didn't support it. Just my luck too. Wink Amazing what you pickup switching from Windows to Linux.

Thanks
Reply
#92
kizer Wrote:@topfs2

Thanks for the heads up. I wasn't aware that Jaunty didn't support it. Just my luck too. Wink Amazing what you pickup switching from Windows to Linux.

Thanks

Just to be clear Smile, jaunty supports async just fine. XBMC Mounting in jaunty won't since I can't test it (no build enviornment).

Cheers,
Tobias
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#93
Oh that makes a difference. Thanks for the heads up.
Reply
#94
topfs2 Wrote:No way to do it via config, and jaunty builds won't have async. only karmic and beyond.

Unfortunately, karmic also automount in synchronous mode.

Today I made a fresh install of karmic minimal and xbmc 9.11beta2. The 1st thing I've tested was the USB. Here is the result of /proc/mount to an USB device mounted by XBMC 9.11 beta2:

Code:
[email protected]:~$ cat /proc/mounts | grep JEJE
/dev/sde1 /media/JEJE-16GB vfat rw,sync,nosuid,nodev,relatime,uid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,errors=remount-ro 0 0

As can see, the flag sync is there... It's really slow! Slower then with 9.04! While transferring a large file with same USB stick, in 9.04, XBMC show from 950kb/s to 1050kb/s. In karmic with 9.11beta2 the speed in sync mode downs to 800kb/s.

After this, I switch to async by 'sudo mount -o remount,async /media/JEJE-16GB'. The result of /proc/mount is quiet interesting:
Code:
[email protected]:~$ cat /proc/mounts | grep JEJE
/dev/sde1 /media/JEJE-16GB vfat rw,nosuid,nodev,relatime,uid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,errors=remount-ro 0 0

When mounted in asynchronous mode, there is no async or sync flag! So, I can only conclude one thing: async should be the default mode for USB devices, but, for some reason, XBMC insist in automount it with sync flag.

Cheers,
FireMan.
Reply
#95
FireMan Wrote:When mounted in asynchronous mode, there is no async or sync flag! So, I can only conclude one thing: async should be the default mode for USB devices, but, for some reason, XBMC insist in automount it with sync flag.

Cheers,
FireMan.

yes and I've changed it if you read my post more thoroughly Wink

Did not know karmic had sync as default, accoring to mount man async should be default. However I'm still stunned that there is a difference, there really shouldn't be any.
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#96
Hi Tobias,

Sorry if I didn't fully understand your message. This is probably because of my bad English.
Anyway, what I understand is: the async mode was add in R25470. Is that right? But I'm running Ubuntu Karmic minimal install and XBMC 9.11-beta2 r25484 (Compiled: Dec 9 2009) and all USB devices still being mounted in sync mode and still with about 1/10 of the speed (to save) in Windows or when remounted in async.

Cheers,
FireMan.
Reply
#97
FireMan Wrote:Hi Tobias,

Sorry if I didn't fully understand your message. This is probably because of my bad English.
Anyway, what I understand is: the async mode was add in R25470. Is that right? But I'm running Ubuntu Karmic minimal install and XBMC 9.11-beta2 r25484 (Compiled: Dec 9 2009) and all USB devices still being mounted in sync mode and still with about 1/10 of the speed (to save) in Windows or when remounted in async.

Cheers,
FireMan.

I'm getting the same results as your previous post on: XBMC 9.11-beta2 r25484 (Compiled: Dec 9 2009) installed with the live-cd.
Reply
#98
Be sure to start xbmc with --standalone, the code is in place.

It won't mount with sync, there is no async option as previously stated so it will just not mount sync.

So it shouldn't be mounting it sync now unless something is up in your enviornment, i.e. defaults are wrong or something, I have no clue tbh.

Cheers,
Tobias
If you have problems please read this before posting

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Image

"Well Im gonna download the code and look at it a bit but I'm certainly not a really good C/C++ programer but I'd help as much as I can, I mostly write in C#."
Reply
#99
Hi Tobias,

to autostart xbmc with X, I have created an .xsessionrc on xbmc user home dir. This faile contains:

Code:
exec xbmc --standalone

And automount still mounting USB in sync mode, like this:

Code:
/dev/sde1 /media/CORSAIR vfat rw,sync,nosuid,nodev,relatime,uid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,errors=remount-ro 0 0

Also, I believe XBMC Live, when install to fixed HDD, will start XBMC with --standalone option. But hellsing is reporting his installation is mounting in sync to.

What can be wrong, since it is mounting in sync mode even with --standalone @ ubuntu karmic and latest binaries?

If I quit XBMC and manual mount the same device, withou any parameters, it will correctly mount in async mode.

Cheers,
FireMan.
Reply
I'm sad Sad

The final 9.11 is out and still mounting USB device in sync mode (karmic):

Code:
[email protected]:~$ cat /proc/mounts | grep media
/dev/sdc1 /media/JEJE-16GB vfat rw,sync,nosuid,nodev,relatime,uid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,errors=remount-ro 0 0

Regards.
Reply
Is there an unmount/save remote option implemented? I haven't found it searching and browsing the menus.
Reply
the only I've found is eject for CD, nothing about USB drive. Moreover - detaching usb drive a window appears that it is Unsafe .... or something like that...
Reply
When browsing files (highlight 'settings' then press the right key), right click on you USB device name (hit 'C' if u using a keyboard).
Then chose eject.

Regards.
Reply
Is it recommended to unmount USB devices before I detach it? What can happen if I don't unmount the device? In Windows I never unmount it.
Reply
sorry to bump a dead thread...

after tinkering with the GRUB initialisation file and removing autodiskmount, i managed to get my 1TB external drive showing up in xbmc. everything was going swimmingly.

however lately i have been noticing that it randomly unmounts itself, and only reappears after a reboot. this is really annoying especially since i am downloading torrents to this drive (and of course all my media is on it).

it disappears from the /media/sdb1/ path and the torrents pop up with a 'no such path exists'-kinda error. then of course i can't play any of the videos/music from my library until i restart. i can't tell if it's the transmission daemon causing this problem or XBMC itself.

also i suck at linux so i don't know how to try to remount from the console (or any other kind of debugging).

the drive is NTFS (i know, i know) and i'm using LIVE SVN dated march 1st, acer revo r3610.
Reply
  •   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)



Logout Mark Read Team Forum Stats Members Help
USB drive not appearing0
This forum uses Lukasz Tkacz MyBB addons.