XBMC freezes randomly
#1
Hi,

I have an annoying problem since working with XBMC.

This is what happens:

I start xbmc, do some things and after a while (sometimes 1min, 5min, 10min) the while system freezes.

When I'm logged in via ssh, I can do commands like ps ax, but these aren't completed, even a sudo reboot doesn't do anything. The only solution is the reset button Sad

revision:
XBMC 9.04.1 r20654

os:
Linux oskar 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux (ubunto 9.04 Jaunty)

installed via apt-get install xbmc

In my log I can't see something special...
http://pastebin.com/m56c04121

Many thx

if you need more information or logs I'll give them!
Reply
#2
Please pastbin a full debug log.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#3
Full log : http://pastebin.com/d218436dc
Reply
#4
Try disabling the startup library scan and see if it fixes it .
The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
Reply
#5
When I disable it and I do a manual scan... the problem remains...
Reply
#6
Update. That rev is too old to bother debugging.
Reply
#7
I use these sources:

deb http://ppa.launchpad.net/team-xbmc/jaunty-ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/team-xbmc/jaunty-ppa/ubuntu jaunty main
Reply
#8
To get a more recent build you have to use the svn ppa packages:

https://edge.launchpad.net/~team-xbmc-svn/+archive/ppa
Reply
#9
http://pastebin.com/d2c415c75


Built on Oct 3 2009 (SVN:23321)
Reply
#10
jverdeyen Wrote:When I disable it and I do a manual scan... the problem remains...

If you don't do any scan does it hang ?
The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
Reply
#11
No only when I do a manual or automatic at boot scan.. the system hangs.
I can still login with ssh, but when I execute a command, it doesn't seems to execute the whole command. Even a reboot command doesn't work.

I have to do a hard reset + It seems that sometimes after this reset the usplash bootscreen is messed up... rather strange...

Edit:

if it can help, dmesg:
http://pastebin.com/d1037d82a
Reply
#12
Same issue reported here .. http://forum.xbmc.org/showthread.php?tid=46718
The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC freezes randomly0
This forum uses Lukasz Tkacz MyBB addons.