Remote works then stops...
#1
This is driving me mad and I can't figure out why this is happening.

Ubuntu 9.04
SVN PPAs of XBMC (although this happened with most recent stable as well and I am not sure it is an XBMC issue anyway...)

After booting, my MCE remote (Hauppauge) always works fine - then stops altogether. Sometimes it works for a minute or two, sometimes it works for only a few button presses. Exiting XMBC and restarting lirc then going back into XBMC does not solve the issue. Only thing that does is a full reboot. I can tell the receiver is getting signal from the remote because the LED on the IR receiver lights with each button press. irw doesn't display any button presses in this state either (which is why I don't suspect XBMC). Normally I would suspect hardware conflicts, but this is a dedicated media PC with no other USB or serial devices...

Anyone else experience thisHuh Thanks in advance!!!

(XBMC is killer.. thanks to all!)
Reply
#2
I experienced exactly the same. My default remote receiver that came with my case did the same thing.

But in the consol I got the message “can't enumerate device on port …..” The device works on other motherboards but not on my m3n asus. Only getting a few key presses. Sometimes it helps to set “legacy support” in the bios usb menu. I ended up buying a Microsoft MCE remote that works very well.
Reply
#3
Exact same scenario... same MOBO and same experience. I tried the legacy USB setting in the BIOS, but it seems to be the same. Which MCE remote did you buy, specifically? Just curious...

Thanks!!!
Reply
#4
have you guys tried the blacklist option ?
Something about a certain xpad tha can cause this behaviour.

There is a post in this forum how to check if this is the case with you.
Sorry for dont supplying the forum link. a search should find it. "xpad" "blacklist"
PointOfView Nvidia ION Atom 330 - TRANSCEND 2GB DDR2 DIMM 800MHz - G.SKILL 64GB SSD 2.5
Open Elec Beta4 1.95.4
XBMC Online Manual - HOW-TO post about a problem in a useful manner - Create/View Bug Report
Setup/Fix correct resolution on XBMC/Ubuntu - Usefull linux terminal commands
Reply
#5
Thanks for the replies!!!

I purchased a new MCE remote and receiver - a slightly newer model is all the local shop had, and still the same occurs. I have removed, purged, and reinstalled LIRC countless times with no success. I looked into the xpad blacklist, but I don't have an xpad module and from what I can tell, this is for the Xbox only.

Still digging.. anyone else have this issue?

Thanks!
Reply
#6
When bringing up the machine and not starting XBMC, the remote will work (longer) and display output from irw, but eventually still locks up and no longer works. The difference is about 80 clicks (random) without XBMC, vs. stopping working after about 5 clicks (random) in XBMC. No logs, no errors reported, etc. Still digging. Ubuntu forums didn't have anything that as done the trick either.

Thanks!
Reply
#7
I have this same issue, and the thing is I have seen it also on minimyth, so I think the issue is related to lirc. Really just a guess, but I have no idea how to find out more info. Ideas? Please where do we turn?
Reply
#8
I don't know if this is related or not, but I also get the same working then frozen behavior from my mouse and keyboard as well. Yesterday when I got the 'keyboard frozen' effect, it was in the middle of typing something, and the symptom looked like a stuck key, even though there was no stuck key.
Reply
#9
Jed, what motherboard are you using?
Reply
#10
Mobo: Asus M3N78-VM

I have pulled out all my hair on this one... current workaround that seems to be OK so far with both of my MCE remotes: $20 PCI USB card. I still have the onboard USB ports enabled - mainly because I haven't hooked up a keyboard to disable them. Still going to to dig into this one, but at least I can navigate the menus now...
Reply
#11
I solved this problem for me anyway

The whole thing turned out to be a bad ground in my house wiring. Test your ground to make sure it is actually connected to 'the ground'. Make sure you have a 3 wire connection to the wall and that the wall's ground has conductivity with your house plumbing or ground bar.
Reply
#12
deleteme
Reply



Logout Mark Read Team Forum Stats Members Help
Remote works then stops...0
This forum uses Lukasz Tkacz MyBB addons.