Receiver audio "wake up"
#1
My receiver seems to take a second or so to "wake up" to the fact that audio is incoming over HDMI (or coax/optical). This normally means missing the 1st second or so of audio on an MP3, which can be annoying at times.

I'm sure other folks are in the same boat.

What are you doing to deal?

Thanks!
Reply
#2
Set up spdif as default output in .asoundrc and sdl should continuously send silent audio.

If that fails "aplay -c2 -r48000 -fS16_LE < /dev/zero" should do the job.
Reply
#3
bobo1on1 Wrote:Set up spdif as default output in .asoundrc and sdl should continuously send silent audio.

If that fails "aplay -c2 -r48000 -fS16_LE < /dev/zero" should do the job.

Would I type that in via the cl?
So long and thanks for all the fish.
Reply
#4
Yes.

You can put it in /etc/rc.local with a & behind it to start it at boot.
Reply
#5
Is this command different since I'm using HDMI?
Reply
#6
No, but you might want to use the -D flag if you can't play audio with the default alsa device.
Reply
#7
Tarantulas Wrote:My receiver seems to take a second or so to "wake up" to the fact that audio is incoming over HDMI (or coax/optical). This normally means missing the 1st second or so of audio on an MP3, which can be annoying at times.

I'm sure other folks are in the same boat.

What are you doing to deal?

Thanks!

I'm in the same boat as you, but this .asoundrc seems to work pretty well with Asrock 330 Ion and Denon AVR-1610.

Adjust pcm "hw:0,3" accordingly.

Code:
pcm.dmixer {
   type dmix
   ipc_key 1024
   ipc_key_add_uid false
   ipc_perm 0660
   slave {
      pcm "hw:0,3"
      rate 48000
      channels 2
      format S32_LE
      period_time 0
      period_size 1024
      buffer_time 0
      buffer_size 4096
   }
}

pcm.!default {
   type plug
   slave.pcm "dmixer"
}

Then set your audio output device to default in XBMC. I'm pretty sure this only works with 2-channel stereo pcm, dunno if there's anything to do for passthrough audio.
I have no idea if this causes problems elsewhere, since configuring alsa seems like rocket science to me. :mad:
Reply
#8
Hi Toiva !

Note that your .asoundrc file makes alsa up/downmix ALL pcm sound to 48khz.
This makes a horrible quality loss in case of CD material as it is with 44.1khz.
So don't use plug dmix if you want good quality audio.

I have an other issue with hdmi. It is that whenever i play a passthrough dts,ac3 content AND i press pause for 2 secs i hear a click from the amp changin g sound mode. After that returning back to main screen i loose navigation sounds. Restarting xbmc i get back navsounds.

My setup are hdmi, hdmi for both pcm and passthrough device and i have a "default" device defined is .asoundrc as a plug to hw:0,3.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#9
Then resample to 192 kHz, alsa has plugins that use the libsamplerate resamplers.
Reply
#10
bobo1on1 Wrote:Then resample to 192 kHz, alsa has plugins that use the libsamplerate resamplers.

Thanks for the tip, but still when i listen to music i want to have the sound passed to the amp without any change. Still 192000 can not be divided with 44100 so there is still some loss. Maybe it is marginal...
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#11
using a decent upsampler (with dealiasing) you won't be able to tell the difference. oh, and upsampling happens in frequency space taken from a windowed time domain so them being divisible doesn't matter as such.
Reply
#12
So the sacrifice in audio quality is marginal?

Will it effect more than just MP3s? Like will I have video/audio sync problems are run my CPU at 100% in an effort to resync everything?
Reply
#13
bobo1on1 Wrote:Then resample to 192 kHz, alsa has plugins that use the libsamplerate resamplers.

@bobo1on1

How great it would be to have an option in advanvedsettings.xml that tells xbmc to up sample everything to a certain bit rate and sample format. Combining this with the smoothvideo function's libsamplerate converter would be awesome. This way we could avoid that the sound is up/down sampled two times.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#14
Resampling to a higher rate is possible, but changing the sample format would mean a pretty major code change so don't expect that any time soon.
Reply
#15
bobo1on1 Wrote:Resampling to a higher rate is possible, but changing the sample format would mean a pretty major code change so don't expect that any time soon.

OK. Thanks for the info.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Receiver audio "wake up"00