update to r23422: DVD ifo no longer works
#1
I have just updated to r23422 from the may stable build. I have some movies in DVD folder structure, but clicking on video_ts.ifo no longer plays them. Nothing happens. I cant move the remote for a few seconds, and after that I am still in file view. DVD folders like this played from library have the same problem.

Asrock 330
XBMC PRE-9.10 R23422
Ubuntu 2.6.28.15-generic #52
http://www.pastebin.ca/1595914
Reply
#2
I tried avi and mkv and they play fine. Tried multiple video_ts files and none of them worked. if I keep trying the same file over and over eventually I'll get an error (too many consecutive items - didnt write the exact error down). Can anyone see anything in my debug log? Can't find other problems like this either.
Reply
#3
seems it fails opening the input stream. i have seen one other report so there is a bug lurking.
Reply
#4
I can confirm I have issues with DVD playback - I just posted a thread before you. I can browse and play the individual vobs, but not just simply "Play Disk". So certainly something is not right!
I'm on svn 23446
Matt
Reply
#5
Thanks. Can someone please point me to a guide to downgrade properly? I have tried many things yet (installed with a script, reran it but it gives errors because installed build is newer).
Reply
#6
I can also confirm I have the same issues when running IFO files. Looks like the stream is not properly demuxed anymore. Not sure what the trac record was, but I added a comment to the following item: http://trac.xbmc.org/ticket/7278#comment:2
Reply
#7
I also added this thread to that ticket.
Reply
#8
I was hoping that the commit with updated ffmpeg and libswscale (r23484) fixed the problem. Unfortunately, it does not, but now crashes XBMC (segmentation fault). Capture the pastebin in http://pastebin.com/m78a0ce29

I'm on r23517 from a pristine checkout of svn.
Reply
#9
Issue is resolved, tested in r23534.

Apparantly the fix from r23521, mentioning that ffmpeg changed get_buffer(), solved the problem. Did not test on ISO's, but IFO's are working ok.

Thanks davilla for solving this!
Reply



Logout Mark Read Team Forum Stats Members Help
update to r23422: DVD ifo no longer works0
This forum uses Lukasz Tkacz MyBB addons.