• 1
  • 2(current)
  • 3
  • 4
  • 5
  • 10
ASUS Eee Box EB1501 (+ alternative 1501 models EB1501U and EB1501P) discussion thread
@succo I see you run ubuntu on it. did you also have a problem with the ethernet connector? i installed karmic but this port is not working :S

edit: Thx god. just found out that this problem was caused by my KVM switch. seems the asus really can't work properly when this one is connected. plugged in mouse and keyboard directly to the asus and now everything works like a charm and sooooooooooo silent Big Grin

the asrock was also a good device but I think i'll get rid of it and definitly get another one of those asus babies for my office. I am really impressed of this box. only thing i miss is 801.22N 5Ghz support but I usually stream via cable anyway so I can live with that Big Grin
succo Wrote:ok, i seem to have solved it by setting lirc to use devinput and setting the right things in Lircmap.xml, but some buttons do not seem to send any signal, namely the 'color' ones, teletext, eee, images, videos and music while * and # seem to send a combination of presses
did anyone have the same troubles?

I seem to have the same IR and I'm fairly new to IR in general.

Cab you please explain what changed you make to get this IR working ?


ok, this is a simple howto for making the MCE USB IR Receiver- Spinel plusf0r ASUS (0471:206c) work with xbmc on linux
first let's see where is our remote located, so
cat /proc/bus/input/devices
we will have a lot of output including what we are interested in, something like
I: Bus=0003 Vendor=0471 Product=206c Version=0100
N: Name="PHILIPS MCE USB IR Receiver- Spinel plusf0r ASUS"
P: Phys=usb-0000:00:04.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:04.0/usb3/3-1/3-1:1.0/input/input3
U: Uniq=
H: Handlers=kbd mouse1 event3
B: EV=120017
B: KEY=c0000 400 0 0 70000 0 58000 8001f8 4000c004 e0beffdf 1cfffff ffffffff fffffffe
B: REL=103
B: MSC=10
B: LED=1f
so we know the remote is located at event3, in my case, but it can change if we move the remote controller to another usb port, so now we want to make an udev rule to link the event device which has the vendor-id and product id of our remote to /dev/input/irremote, so we already know that the vendor id is 0471 and device id is 0206c, so we can do
sudo nano /etc/udev/rules.d/10-local.rules
and put in the file
now we can make
sudo service udev restart
detach and attach the remote again and we'll find a symlink in /dev/input/irremote pointing to our device
now we can proceed to install lirc
sudo apt-get install lirc lirc-dev
the lirc configuration will ask us what kind of remote we have, so we can say we have custom and make it point to /dev/input/irremote
now we have to edit /etc/lirc/hardware.conf so that it loads the correct remote template
sudo nano /etc/lirc/hardware.conf
and we make the REMOTE_LIRCD_CONF line look like
if we do
sudo /etc/init.d/lirc restart
and try irw we should have some output, now
so we go and make it work with xbmc, so
nano ~/.xbmc/userdata/Lircmap.xml
and put in there
        <remote device="devinput">
where i commented the lines with the not working keys
we save it and restart xbmc and we should have a working remote, except the keys i previously said
that's all Smile
Really really great! Everything worx out of the box an this thing is really more silent then the asrock! The only problem i got is, with xbmc live installed to hdd. I can not turn the eb1501 off. Pressing the power button on the remote (that was delivered with the eb1501!) does not do anything. But shut down over the menu it works - resume with the power button works too! Any idea?
did you set wake by usb in the bios menu?
it works perfectly here
Wakeup works perfect! But not Shutdown with the same Button. I always have to go through the menu and select shut down
if you use my lircmap.xml and set xbmc to shutdown on exit, pressing the button will shutdown the computer... it doesn't work outside xbmc, it could if you set irexec to shutdown the pc on keypress, i guess...
Doemer Wrote:@succo I see you run ubuntu on it. did you also have a problem with the ethernet connector? i installed karmic but this port is not working :S

EB1501 seems have bug for lancard detection
"The Realtek Network Controller was not found",

Fix : remove everything connect to EB1501
( power cord, USB device, Lan.....)
wait for few minutes,
plug-in everything
the OS system will detect lan card and install the driver.
I was thinking about getting one of these, Anyone noticed any slow downs from the cpu, output 1080p? Anything you don't like about it?
I tried 720p and 1080p (MKVs) with the latest Live Version 190.53 driver). I can't get it run without lags Sad Has somebody it up and running fine?
Yes Zubbeli, I'm running the 9.11 Rc1 on an eee box 1501, both 720p and 1080p without any lagging.

If you're running Live 9.11 Rc1 I think your problem is that there is a problem with that release making the hardware acceleration (VDPAU) not to work.

First check that you have choosen VDPAU as renderer in playback settings

If it still don't work, try to use what's described in this link:


Hope you get it to work.

Thank you MrStarhouse. Good to hear that somebody has it running fine.
I updated the NVIDIA driver as discribed. One test with 190.53 and also the latest 195.22. VDPAU is activated. The CPU runs with abaou 50% with 1080p and 720p with around 40%. But still laggings. What I have to say is that I'm streaming the files from my network. But I'm pretty sure it should not be the problem, shouldn't be?

When I try to use Windows 7 (without XBMC) the result are much worser.

I'm appreciate any help or suggestions.
I could solve my problems by downgrading to the beta 2 (190.42 driver icluded). I think in the rc1 must be more than updating to the 190.53 driver only to get better results. I wonder that nobody else seems to have "my" problems also Wink No I love my 1501 :-)
Call me stupid but i still have the same problem. Tryed everything but xbmc does not react in any way onto the powerbutton onside xbmc. I can turn on but. Not turn off the eb1501. Everything else Works. Maybe there are different remotes delivered with the eb? Mine got none Windows Media Button, but on some Foto i saw one with this green Win Button. I tryed with a logitech 555 Remote but same. Rest of this Box is fantasic! BTW i am using latest live installed in hd.
did you use the lircmap i submitted before?
did you set xbmc to shutdown on exit?

if both answers are 'yes' try to run irw on a console and see what's written on screen when you push the power button
if it's something like 'KEY_SLEEP' then you lied when you answered yes to the questions before... if it's nothing at all maybe you've got a different remote
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 10
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
ASUS Eee Box EB1501 (+ alternative 1501 models EB1501U and EB1501P) discussion thread00