[Asrock] Resume suspend mode, is it possible with IR?
#31
I think you may have a command in your sleep script which resumes the computer. If you can, undo all of your changes to the sleep scripts and use the guide to construct a new one.

Also, try running IRW from a terminal when you shut down the computer to see if any random commands are being sent through lirc.
Reply
#32
Tried your method and I have the same problem. One thing I noticed when running irw though is that every keypress is repeated 4 times but the last one has a suffix of _UP
Code:
[email protected]:~$ irw
00000000000000a8 00 RIGHT XboxDVDDongle
00000000000000a8 01 RIGHT XboxDVDDongle
00000000000000a8 02 RIGHT XboxDVDDongle
00000000000000a8 00 RIGHT_UP XboxDVDDongle
00000000000000a9 00 LEFT XboxDVDDongle
00000000000000a9 01 LEFT XboxDVDDongle
00000000000000a9 02 LEFT XboxDVDDongle
00000000000000a9 00 LEFT_UP XboxDVDDongle
00000000000000a7 00 DOWN XboxDVDDongle
00000000000000a7 01 DOWN XboxDVDDongle
00000000000000a7 02 DOWN XboxDVDDongle
00000000000000a7 00 DOWN_UP XboxDVDDongle
00000000000000a6 00 UP XboxDVDDongle
00000000000000a6 01 UP XboxDVDDongle
00000000000000a6 02 UP XboxDVDDongle
00000000000000a6 00 UP_UP XboxDVDDongle
00000000000000ce 00 1 XboxDVDDongle
00000000000000ce 01 1 XboxDVDDongle
00000000000000ce 02 1 XboxDVDDongle
00000000000000ce 00 1_UP XboxDVDDongle
00000000000000cd 00 2 XboxDVDDongle
00000000000000cd 01 2 XboxDVDDongle
00000000000000cd 02 2 XboxDVDDongle
00000000000000cd 00 2_UP XboxDVDDongle
00000000000000cc 00 3 XboxDVDDongle
00000000000000cc 01 3 XboxDVDDongle
00000000000000cc 02 3 XboxDVDDongle
00000000000000cc 00 3_UP XboxDVDDongle

it kicks in after a very brief pause, for example it will display that the number 3 is pressed 3 times very quickly and then a slight pause before it does 3_UP. I don't know if that has anything to do with it though.

I read somewhere on the forums, that nvidia 190 drivers have the immediate resume problem with them so I downgraded to 185 and am having the same problem. Nothing else displays when I have irw running while suspending.
Reply
#33
are you suspending from the remote?
Reply
#34
Try disabling the remote as a part of the sleep command.
Code:
case "$1" in
    hibernate|suspend)
        sudo curl "http://127.0.0.1:8080/xbmcCmds/xbmcHttp?command=ExecBuiltIn&parameter=LIRC.Stop"
        sudo /etc/init.d/lirc stop
    ;;
esac

.... then put the rest of your sleep script here ....
Reply
#35
double post my bad.
Reply
#36
outleradam Wrote:Try disabling the remote as a part of the sleep command.
Code:
case "$1" in
    hibernate|suspend)
        sudo curl "http://127.0.0.1:8080/xbmcCmds/xbmcHttp?command=ExecBuiltIn&parameter=LIRC.Stop"
        sudo /etc/init.d/lirc stop
    ;;
esac

.... then put the rest of your sleep script here ....

pardon my ignorance, which sleep script? the 99lirc_resume one we made or some other script? the only other thing in my sleep.d folder is a shortcut to one called action_wpa
Reply
#37
it should work in 99lirc-resume.sh

add in a debug line and check it when you resume to see if it executed.....

Code:
echo "sleep portion of the script completed" >>/tmp/script.log

I can't remember if it's supposed to be > or >> for add to the log, one clears the log and adds to it, the other just adds to the log. Try both ways
Reply
#38
I think we are making progress. This time (after adding that code to the script), it appeared to go into sleep mode except it left a blinking cursor in the top left corner of the screen, it seemed to resume fine but if I try to suspend again xbmc just freezes for 10-15 seconds and the seems to restart (only say that because it updates the library again). I neglected to mention that it was doing the same thing before I added that extra bit to the script. It seems to only try to suspend the first time, after that I have to reboot.

edit: so it wasn't me that resumed it, I rebooted and suspended again but just left it at the blinking cursor and waited, sure enough, it just seemed come back to xbmc after about 10 seconds.
Reply
#39
put this line echo "sleep portion of the script completed" >>/tmp/script.log right after the lirc stop command. and remove the last echo command that says script complete.

restart the computer
suspend,
resume
check your log in /tmp/script.log and see if it says 'sleep portion of the script completed' Make sure it is executing that portion of the code.

Have you tried suspending by using the keyboard? I should have asked that first. that last script was to remove all extra commands from your remote.
Reply
#40
yes, that portion of the script is logged as being executed and it is with that portion that my screen goes black with the blinking cursor, when I remove that part, the asrock appears to sleep but only for a second before the activity light blinks and it resumes.

I tried the sleep button on my keyboard but it didnt do anything, I also used my keyboard to navigate to shutdown > suspend but it reacted just as if I was using the remote, which I expected.

I really appreciate your help troubleshooting this and I feel some progress is being made. Not sure where the trouble lies as nobody else seems to be having the same issue with the asrock.

Is there anything else I can provide to be more helpful?
Reply
#41
Ok, the resume script did nothing at all. It simply makes your computer take more time to shut down.


Here's what I'm going to need to take this any further.

Restore all bios settings to factory from inside the sytem bios

and one of the following:


What troubleshooting steps have you taken, which are not posted in this thread?

Post up any devices you have attatched to the computer

Post up any services you have installed on the computer

Can you post copies of the the files which you have modified?


or

do a clean re-install from a XBMC-Live cd.
Reply
#42
Same behaviour here the ion330 just wakes up right away. and i have to unplug the receiver and plug it back in to get the remote working again.
it's driving me insane.
Reply
#43
^^I wrote two wiki articles today.

Here is the answer to your problem of resuming.
http://wiki.xbmc.org/?title=Enable_Wake-On-Device
Here is the answer to your remote not working after resume
http://wiki.xbmc.org/?title=Automatic_li...ume_script
Reply
#44
Just wondering if anyone experiencing the immediate wake on suspend issue with the ASRock 330 has found a working solution yet?

When I was running Alpha 1 my system would suspend and stay suspended and I had to enable the proper USB port to wake the system back up.

However since updating to Karmic and Alpha 2 my system will not stay suspended. It doesn't matter if I use the keyboard to navigate to the suspend command in XBMC or use the remote. The system powers down and no more then a second or two later fires right back up again.
Reply
#45
ingeo Wrote:Just wondering if anyone experiencing the immediate wake on suspend issue with the ASRock 330 has found a working solution yet?

When I was running Alpha 1 my system would suspend and stay suspended and I had to enable the proper USB port to wake the system back up.

However since updating to Karmic and Alpha 2 my system will not stay suspended. It doesn't matter if I use the keyboard to navigate to the suspend command in XBMC or use the remote. The system powers down and no more then a second or two later fires right back up again.

I have the exactly the same problem...
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[Asrock] Resume suspend mode, is it possible with IR?00
This forum uses Lukasz Tkacz MyBB addons.