Apple Remote, Candelair, OS X 10.6.2
#1
Can we please have some official word from XBMC devs about what to do about the Apple Remote situation?

You probably know about Plex 0.83 working fine with the help of the drivers written by the RemoteBuddy dev. Here's a news story:

http://elan.plexapp.com/2009/10/23/snow-...dy-author/

And here's the new preference pane called "Candelair":

http://www.iospirit.com/labs/candelair/

So what should we do? Wait for XBMC to be updated in the SVN? Wait for OS X 10.6.2? Install Candelair now?

Thanks.
Reply
#2
It's all taken care of as far as I know. When I installed candelair the remote worked fine with the latest builds without starting frontrow etc.
Reply
#3
great, glad to know it works. however there is still some confusion. what happens when os x 10.6.2 comes out with a supposed fix? then will there be a conflict? and plex 0.83 builds in the candelair code without needing to install the candelair, as far as I understand it. so i imagine xbmc would too eventually. then again, what about conflicts?
Reply
#4
ctawn Wrote:great, glad to know it works. however there is still some confusion. what happens when os x 10.6.2 comes out with a supposed fix? then will there be a conflict? and plex 0.83 builds in the candelair code without needing to install the candelair, as far as I understand it. so i imagine xbmc would too eventually. then again, what about conflicts?

I don't know if 10.6.2 contains a 'fix' (do apple recognize it as a problem?) but if it did create a conflict then just remove candelair before updating I imagine.
Reply
#5
http://xbmc.org/davilla/2009/10/23/ir-re...w-leopard/
Reply
#6
spiff, thanks for the link. still doesn't answer the question though, if the HID class is part of XBMCHelper in the SVN builds now, does Candelair need to be installed (the pref pane) and if not does having it installed also cause conflicts? And although you can't answer this second question definitively -- assuming apple is going to fix something in 10.6.2, can we expect any problems or conflicts then? thx.
Reply
#7
Candelair can co-exist with the 10.6.2 update. When the 10.6.2 update gets pushed public, then you have the option to keep running Candelair.

Candelair is the driver side, XBMCHelper is the client. The HID Class that XBMCHelper uses will work with or without Candelair.

Candelair just restores what 10.6 broke, 10.6.2 update will restore that too.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#8
how come it works in plex without Candelair installed
tried xbmc r24107 and no working remote am I doing something wrong?

I don´t want to install Candelair.
Image
Reply
#9
CosyCat Wrote:how come it works in plex without Candelair installed

How come you think Plex works without Candelair installed? They may have included it in their package/installer.
10.6.{0,1} need to have Candelair installed. If it's not installed, you won't get proper remote control behaviour.

Quote:[...]

I don´t want to install Candelair.
Sorry, but then you'll have to wait for 10.6.2 and see if the bug is fixed.

cheers,
mdd

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules. If you don't have the time to read them, please don't take the time to post in this forum!
For troubleshooting and bug reporting please make sure you read this first.
Reply
#10
ok .. couldn't wait so I installed Candelair and I´m happy again..... it works great

THX
Image
Reply
#11
davilla Wrote:Candelair can co-exist with the 10.6.2 update. When the 10.6.2 update gets pushed public, then you have the option to keep running Candelair.

Candelair is the driver side, XBMCHelper is the client. The HID Class that XBMCHelper uses will work with or without Candelair.

Candelair just restores what 10.6 broke, 10.6.2 update will restore that too.

Thanks very much. I've updated the main post on the Harmony Remote post to reflect this information.
Reply
#12
I had never heard of Candelair or the problems with the IR remote under snow leopard until last night when I installed 10.6.2 on my Mac Mini and suddenly lost the ability to use my IR remote with FrontRow. After searching around, I discovered Candelair and installed it and then my remote worked just fine. Whatever Apple did to "fix" the IR remote code is definitely not fixed.
Reply
#13
hi,

i'm a italian new user (my english is terrible, sorry), today update my mac mini to 10.6.2.

Before upgrade 10.6.2, my apple remote work in xbmc with candelair driver, but after upgrade apple remote don't work.

I tried to refresh install candelair, but don't work.

There is a know bug about my problemHuh

There is a solution?

thanks.
Reply
#14
Hi,
I was using XBMC 9.04.1 on my macbook with Candelair 1.7.2 and my standard apple remote worked great. I updated OSX to 10.6.2 and the remote fails to work with XBMC. Is there anything I can do to get it back working again?
Thanks
Reply
#15
hey58 Wrote:Hi,
I was using XBMC 9.04.1 on my macbook with Candelair 1.7.2 and my standard apple remote worked great. I updated OSX to 10.6.2 and the remote fails to work with XBMC. Is there anything I can do to get it back working again?
Thanks

Did you reinstall Candelair ?
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Apple Remote, Candelair, OS X 10.6.200