XBMCLive (Error 2: Share not available)
#1
Hi. I've installed XBMC Live onto a USB to run on a little ION system I've built. All works fine apart from when I try to access files on the network. When I browse for a new share and click "Windows Network (SMB)", it throws up this error:

ERROR 2: SHARE NOT AVAILABLE

Any ideas why this is? As an aside, where abouts is the USB drive mounted in the filesystem by default? I can't seem to find it.

EDIT

I'm connected to the network fine by the way. I can SSH in and the weather updates ok too.
Reply
#2
are you trying to connect to a windows 7 machine?
Reply
#3
I have this problem too- and yes my main PC is using windows 7, latest beta XBMC live on my asrock330HT... Any suggestions?
Reply
#4
Very weird- if I plug an ethernet cable in I can access the files no problem, but over wifi I get the error 2 report every single time! Have checked all setting- workgroup is OK, password sharing off, folders shared, can access them from my eee using ubuntu. Its just XBMC which seems to have this problem!
Reply
#5
this happens to me too sometimes, but my files are on a freebsd box running samba....restarting xbmc a few times usually fixes it. This only occured after updating to karmic from jaunty....jaunty never had this problem.
Board: Zotac ION-A-U Case: M350 Mini ITX Memory: 4GB Patriot PC6400 OS: XBMC on OpenELEC.tv build 6936 on a Corsair 32GB SSD Media Storage: W2K8 running on 14TB RAID 5 on an Asrock board w/ AMD Athlon X2 250 and PERC 6/I controller w/ 8 Samsung HD204UI Green drives Time to interface from power switch: 22.4 seconds.
Reply
#6
No on mine it just won't recognise the network. I have installed the youtube plugin and that works, Ive been through and checked all the windows 7 settings and it should connect fine. Group name is fine, firewall is basic windows so shouldnt interfere (doesnt have a problem with my ubuntu eee netbook). It just will not let me access the files over wifi. Ive lugged it all into my office and am copying everything over the ethernet now, but I dont want to have to do that for my whole media library!!!
Reply
#7
Tried turning the windows firewall off and that didnt work either. I installed XBMC on my workstation and I could see the files using UPNP if I had XBMC running- but it would not play anything as I just got a Network not connected message...
Reply
#8
I also get the exact same error, just installed the latest XBMC Live today.

When browsing for a new share i click smb and it says "error 2 share not available"

Is this a bug or just something we are all doing wrong? dont want to waste peoples time and file a bug about something that doesn't exist.
Reply
#9
Ive got this error as well.
At random it will not connect to smb shares, and there seems to be some kind of delay causing an "Operation not permitted" error message. if i click the same share again it will work or get the "Error 2" message or just display an empty folder (without the ".." directory even)
This seems totally random at best.
The network is solid and ive never had any issues on other machines or other protocols, only SMB shares via latest Live installed on an ION machine.
Reply
#10
After browsing around the forums, i came across this thread
http://forum.xbmc.org/showthread.php?tid=65886

Though the solution there did nothing for me, it might be worth mentioning
Reply
#11
Having a similar problem.... Imac has the music folder shared which is on the actual machine, and 2 hard external Hard drives with TV/movies. When I go to browse for the new share the music folder works fine, the external hard drives are getting error 2. Everything is shared over a wired network. Any suggestions?
Reply
#12
As far as i can tell, this must be an smb/authentication issue.

One of my shares never fails to connect, and after ive connected to this, i can connect to any other shares on the same server. After a while, Samba times out, and the connection errors occurs again.

ive tried changing the advancedsettings.xml <samba><clienttimeout>, but i cant say that have made any difference either..

Debug level 3 log here.
I cant read anything special out of the log.. some of my shares seem to send user:pass, while others do not, although i cant see that it makes any difference either way.
Reply
#13
Bump. I am having the exact same issue. Fresh install. Anyone making progress on this? Much appreciated!
Reply
#14
Did anyone besides me export/import the library from an earlier version of xbmc?
Reply
#15
I was booting xbmc live with a usb stick for over a week and my shares always worked. I used the same stick to install to a hard drive and now I constantly get the error 2 message when trying to get a SMB share. It never has has connected. I've tried switching ethernet cards on the motherboard with no luck.

I can get weather and my playon upnp working.

The computer is using windows xp pro. Its been using earlier versions of xbmc just fine with about 3 or 4 xboxes for a long time.

EDIT (again): It actually works now. The only thing I needed to do was set the proper workgroup and have it "properly" ask me to reboot the computer. For some reason just changing it and then manually restarting didn't seem to work. Perhaps I wasn't giving it enough time.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMCLive (Error 2: Share not available)00