[LINUX] Problems switching from Analog to Digital over SPDIF?
#1
I've read all the relevant threads here but couldn't find a working solution.

version: 9.11 alpha 2, ubuntu 9.10

This is the situation:
  • I'm using optical spdif to output all audio to a DTS capable receiver.
  • I can get both analog and digital audio to play correctly on the receiver
  • When I switch from an analog stream to a digital one (which uses passthrough) I get an error "failed to initialize audio settings".
  • However, when i set the audio output device to iec958 and load DTS content it works, but after switching to an analog stream and then switching back to DTS I get the error again. The menu sounds don't work at all in iec958 output mode
  • All of this switching works without a problem using VLC

Here is the log where i successfully played DTS content(Eastern.Promises), then successfully switched to analog audio content(Happiness) and failed to switch back to the same DTS content(Eastern.Promises).

http://pastebin.com/pastebin.php?dl=m767fda9c

this is where it goes wrong (seems it doesn't even try to switch to passthrough here):

Code:
02:37:49 T:2928397168 M:1889439744   DEBUG: CDVDPlayerAudio - CDVDMsg::GENERAL_RESYNC(484414693.877551, 0)
02:37:49 T:2928397168 M:1889439744  NOTICE: Creating audio device with codec id: 86017, channels: 2, sample rate: 44100, no pass-through
02:37:49 T:2928397168 M:1889439744   DEBUG: PulseAudio: Opening Channels: 2 - SampleRate: 44100 - SampleBit: 16 - Resample false - Codec PCM - IsMusic false - IsPassthrough false - device: [email protected]efault
02:37:49 T:2928397168 M:1889439744   DEBUG: PulseAudio: Context failed
02:37:49 T:2928397168 M:1889439744   ERROR: PulseAudio: Waited for the Context but it failed
02:37:49 T:2928397168 M:1889439744   ERROR: PulseAudio: Failed to create context
02:37:49 T:2928397168 M:1889312768    INFO: AudioRendererFactory: [email protected]efault not a explicit device, trying to autodetect.
02:37:49 T:2928397168 M:1889312768   DEBUG: PulseAudio: Opening Channels: 2 - SampleRate: 44100 - SampleBit: 16 - Resample false - Codec PCM - IsMusic false - IsPassthrough false - device: pulse:[email protected]efault
02:37:49 T:2928397168 M:1889312768   DEBUG: PulseAudio: Context failed
02:37:49 T:2928397168 M:1889312768   ERROR: PulseAudio: Waited for the Context but it failed
02:37:49 T:2928397168 M:1889312768   ERROR: PulseAudio: Failed to create context
02:37:49 T:2928397168 M:1889312768   DEBUG: CALSADirectSound::CALSADirectSound - Channels: 2 - SampleRate: 44100 - SampleBit: 16 - Resample false - Codec PCM - IsMusic false - IsPassthrough false - audioDevice: pulse:[email protected]efault
02:37:49 T:2928397168 M:1889312768   DEBUG: Initialize - using alsa device pulse:[email protected]efault
02:37:49 T:2928397168 M:1889312768   ERROR: Initialize - pcm_open_lconf, alsa error: -2 - No such file or directory
02:37:49 T:2928397168 M:1889312768   ERROR: Creating a Null Audio Renderer, Check your audio settings as this should not happen
02:37:49 T:2928397168 M:1889312768   DEBUG: CDVDPlayerAudio:: synctype set to 0: clock feedback
02:37:49 T:2928397168 M:1889312768   DEBUG: CDVDPlayerAudio:: Discontinuty - was:484436040.884942, should be:484440838.059010, error:4797.174068

All help appreciated!
Reply


Messages In This Thread
[LINUX] Problems switching from Analog to Digital over SPDIF? - by miseryshining - 2009-11-22, 04:04
[No subject] - by F3d0r - 2009-11-22, 09:32
[No subject] - by F3d0r - 2009-11-22, 09:59
[No subject] - by miseryshining - 2009-11-22, 16:42
[No subject] - by F3d0r - 2009-11-23, 19:48
[No subject] - by razo - 2009-11-23, 21:40
[No subject] - by F3d0r - 2009-11-23, 22:32
[No subject] - by miseryshining - 2009-11-24, 01:26
[No subject] - by F3d0r - 2009-11-24, 10:06
[No subject] - by dongioia - 2009-11-24, 10:41
[No subject] - by F3d0r - 2009-11-24, 10:51
[No subject] - by dongioia - 2009-11-24, 10:56
[No subject] - by dongioia - 2009-11-24, 20:23
[No subject] - by lloydsmart - 2009-11-28, 00:18
[No subject] - by remb0 - 2009-11-28, 01:22
[No subject] - by F3d0r - 2009-11-28, 10:07
[No subject] - by miseryshining - 2009-11-28, 12:07
[No subject] - by lloydsmart - 2009-11-29, 01:32
[No subject] - by bradford108 - 2009-11-30, 02:18
Excellent - by jonnybignote - 2010-01-07, 07:59
[No subject] - by Asswipe44 - 2010-01-07, 11:39
[No subject] - by erhnam - 2010-02-02, 12:20
[No subject] - by F3d0r - 2010-02-02, 15:36
[No subject] - by fidoboy - 2010-02-03, 03:08
[No subject] - by erhnam - 2010-02-07, 16:27
[No subject] - by fidoboy - 2010-02-07, 16:39
[No subject] - by josbeir - 2010-02-09, 02:20
[No subject] - by finite3 - 2010-02-09, 10:09
[No subject] - by josbeir - 2010-02-09, 10:32
[No subject] - by erhnam - 2010-02-09, 17:00


Logout Mark Read Team Forum Stats Members Help
[LINUX] Problems switching from Analog to Digital over SPDIF?1
This forum uses Lukasz Tkacz MyBB addons.