[LINUX] Problems switching from Analog to Digital over SPDIF?
#26
josbeir Wrote:This will get spdif + hdmi audio working with dmix thus allowing crossfading in xbmc!! :-)

Works like a charm on Asrock ION 330HT system and is probably a starting point for non-ion systems.

save to /etc/asound.conf or .asoundrc

Hope this helped.

The good thing is that my hick-ups and pop-ups are gone when switching from one song to another (using spdif). The bad thing is that I that no my hdmi crackles. I also have issues when swithing from one song to another that I have to press play one more time. Also the screen is quite smaller when I finish watching a movie using hdmi. When I look at my xbmc.log and find these errors:

Code:
15:23:40 T:3079460752 M:1383768064   ERROR: PulseAudio: Waited for the Context but it failed
15:23:40 T:3079460752 M:1383768064   ERROR: PulseAudio: Failed to create context
15:23:40 T:3079460752 M:1383514112   ERROR: PulseAudio: Waited for the Context but it failed
15:23:40 T:3079460752 M:1383514112   ERROR: PulseAudio: Failed to create context
15:23:46 T:3079460752 M:1384239104   ERROR: PulseAudio: Waited for the Context but it failed
15:23:46 T:3079460752 M:1384239104   ERROR: PulseAudio: Failed to create context
15:23:46 T:3079460752 M:1384239104   ERROR: PulseAudio: Waited for the Context but it failed
15:23:46 T:3079460752 M:1384239104   ERROR: PulseAudio: Failed to create context
15:23:58 T:3079460752 M:1384189952   ERROR: PulseAudio: Waited for the Context but it failed
15:23:58 T:3079460752 M:1384189952   ERROR: PulseAudio: Failed to create context
15:23:58 T:3079460752 M:1384054784   ERROR: PulseAudio: Waited for the Context but it failed
15:23:58 T:3079460752 M:1384054784   ERROR: PulseAudio: Failed to create context
15:24:32 T:3079460752 M:1367171072   ERROR: PulseAudio: Waited for the Context but it failed
15:24:32 T:3079460752 M:1367171072   ERROR: PulseAudio: Failed to create context
15:37:19 T:3078018960 M:1373483008 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush instead

This config seems to work much better! At least it doesn't give me hdmi problems.

Code:
pcm.!default {
    type plug
    slave {
        pcm "both"
    }
}
pcm.both {
    type route
    slave {
        pcm multi
        channels 4
    }
    ttable.0.0 1.0
    ttable.1.1 1.0
    ttable.0.2 1.0
    ttable.1.3 1.0
}
pcm.multi {
    type multi
    slaves.a {
        pcm "tv"
        channels 2
    }
    slaves.b {
        pcm "dmixrec"
        channels 2
    }
    bindings.0.slave a
    bindings.0.channel 0
    bindings.1.slave a
    bindings.1.channel 1
    bindings.2.slave b
    bindings.2.channel 0
    bindings.3.slave b
    bindings.3.channel 1
}
pcm.dmixrec {
    type dmix
    ipc_key 1024
    slave {
        pcm "receiver"
        period_time 0
        period_size 1024
        buffer_size 8192
        rate 48000
     }
     bindings {
        0 0
        1 1
     }
}
pcm.tv {
    type hw
    card 0
    device 3
    channels 2
}
pcm.receiver {
    type hw
    card 0
    device 1
    channels 2
}
Reply


Messages In This Thread
[No subject] - by F3d0r - 2009-11-22, 09:32
[No subject] - by F3d0r - 2009-11-22, 09:59
[No subject] - by miseryshining - 2009-11-22, 16:42
[No subject] - by F3d0r - 2009-11-23, 19:48
[No subject] - by razo - 2009-11-23, 21:40
[No subject] - by F3d0r - 2009-11-23, 22:32
[No subject] - by miseryshining - 2009-11-24, 01:26
[No subject] - by F3d0r - 2009-11-24, 10:06
[No subject] - by dongioia - 2009-11-24, 10:41
[No subject] - by F3d0r - 2009-11-24, 10:51
[No subject] - by dongioia - 2009-11-24, 10:56
[No subject] - by dongioia - 2009-11-24, 20:23
[No subject] - by lloydsmart - 2009-11-28, 00:18
[No subject] - by remb0 - 2009-11-28, 01:22
[No subject] - by F3d0r - 2009-11-28, 10:07
[No subject] - by miseryshining - 2009-11-28, 12:07
[No subject] - by lloydsmart - 2009-11-29, 01:32
[No subject] - by bradford108 - 2009-11-30, 02:18
Excellent - by jonnybignote - 2010-01-07, 07:59
[No subject] - by Asswipe44 - 2010-01-07, 11:39
[No subject] - by erhnam - 2010-02-02, 12:20
[No subject] - by F3d0r - 2010-02-02, 15:36
[No subject] - by fidoboy - 2010-02-03, 03:08
[No subject] - by erhnam - 2010-02-07, 16:27
[No subject] - by fidoboy - 2010-02-07, 16:39
[No subject] - by josbeir - 2010-02-09, 02:20
[No subject] - by finite3 - 2010-02-09, 10:09
[No subject] - by josbeir - 2010-02-09, 10:32
[No subject] - by erhnam - 2010-02-09, 17:00


Logout Mark Read Team Forum Stats Members Help
[LINUX] Problems switching from Analog to Digital over SPDIF?1
This forum uses Lukasz Tkacz MyBB addons.