[LINUX] Problems switching from Analog to Digital over SPDIF?
#32
Long story short, uninstall Pulse. I loosely followed this guide.

If you're interested in the whole store, read on.

I worked at getting audio working smoothly under Ubuntu 10.04 Lucid Lynx for about three to four hours this morning. I started at the wiki here, but that simply did not work for me (I only have two audio devices, the analog and the digital, and neither worked).

I then browsed through a few of these threads and found a few recommendations for disabling Digital Audio under Pulse I did that and I had pretty much flawless playback of streaming digital audio, but the analog was a no go.

I tried working through it, but kept getting stuck with either analog and no streaming digital or streaming digital but no analog.

I was at the same time testing audio under Gnome Mplayer which was more forgiving. I kept coming the the conclusion that Pulse was what was getting in my way, as anytime I could get a program to get around pulse I was golden.

I don't hate pulse, so I was hesitant to revamp the audio setup from the standard, but after hitting my head against all other paths (all that was left was installing OSSv4) I decided to purge Pulse and install the xfce4 mixer (since the gnome mixer is no longer in the main repositories).

I rebooted, used the mixer to make sure all the necessary settings were right then set XBMC to use iec958 (both standard audio and pass-through), tested and both analog and streaming digital was working.

I'm not sure about menu sounds, but that's a non issue for me. I also imagine this might be done a bit more elegantly (by installing Esound maybe) but this system is really only going to be running XBMC so this is where I'm currently leaving it. Though I may test OSSv4 if I feel like risking it.

I hope this saves someone four hours of their life! Smile
Reply


Messages In This Thread
[No subject] - by F3d0r - 2009-11-22, 09:32
[No subject] - by F3d0r - 2009-11-22, 09:59
[No subject] - by miseryshining - 2009-11-22, 16:42
[No subject] - by F3d0r - 2009-11-23, 19:48
[No subject] - by razo - 2009-11-23, 21:40
[No subject] - by F3d0r - 2009-11-23, 22:32
[No subject] - by miseryshining - 2009-11-24, 01:26
[No subject] - by F3d0r - 2009-11-24, 10:06
[No subject] - by dongioia - 2009-11-24, 10:41
[No subject] - by F3d0r - 2009-11-24, 10:51
[No subject] - by dongioia - 2009-11-24, 10:56
[No subject] - by dongioia - 2009-11-24, 20:23
[No subject] - by lloydsmart - 2009-11-28, 00:18
[No subject] - by remb0 - 2009-11-28, 01:22
[No subject] - by F3d0r - 2009-11-28, 10:07
[No subject] - by miseryshining - 2009-11-28, 12:07
[No subject] - by lloydsmart - 2009-11-29, 01:32
[No subject] - by bradford108 - 2009-11-30, 02:18
Excellent - by jonnybignote - 2010-01-07, 07:59
[No subject] - by Asswipe44 - 2010-01-07, 11:39
[No subject] - by erhnam - 2010-02-02, 12:20
[No subject] - by F3d0r - 2010-02-02, 15:36
[No subject] - by fidoboy - 2010-02-03, 03:08
[No subject] - by erhnam - 2010-02-07, 16:27
[No subject] - by fidoboy - 2010-02-07, 16:39
[No subject] - by josbeir - 2010-02-09, 02:20
[No subject] - by finite3 - 2010-02-09, 10:09
[No subject] - by josbeir - 2010-02-09, 10:32
[No subject] - by erhnam - 2010-02-09, 17:00
If you're still stuck here's a solution! - by Ainer - 2010-05-15, 02:58


Logout Mark Read Team Forum Stats Members Help
[LINUX] Problems switching from Analog to Digital over SPDIF?1
This forum uses Lukasz Tkacz MyBB addons.