Thread Rating:
  • 0 Vote(s) - 0 Average
Weird slanted font bug
#1
Question 
I've made a switch from Windows 7 to Ubuntu. There's a bug in XBMC font rendering. Here's a screenshot:

Image

Some of the letters are slanted to the left “anti-italic” style. I've tried switching the skins, fonts and resolutions, but the bug still persists.
An interesting fact: while popping up this menu looks nice, but the letters become slanted as soon as the transition ends.

ASRock Ion 330 via HDMI to LG 37LC51 TV
Ubuntu 9.04 (fully up-to-date)
NVidia drivers 190.42
XBMC 9.11 beta 1 (SVN PPA)
Aeon Auriga (GIT)

Can this be solved?
Reply
#2
There was a shameless bump. I'm sorry.
Reply
#3
Bump within 4.5 hours? FFS give people some time to answer - this is an international forum.

It's not a bug per-se. What's happening is it's being rendered at an odd pixel location and so some things are being rounded down and some are rounded up.

What resolution are you running? One presumes it only happens on whatever version of Aeon you're using?

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#4
I have this same issue, running alaska on beta 1 jaunty. I was going to post a topic on it, but it doesn't really bug me THAT much. It's been like this for the last month or so that i can recall. I'm running 1920x1080 @ 24 hz.
Board: Zotac ION-A-U Case: M350 Mini ITX Memory: 4GB Patriot PC6400 OS: XBMC on OpenELEC.tv build 6936 on a Corsair 32GB SSD Media Storage: W2K8 running on 14TB RAID 5 on an Asrock board w/ AMD Athlon X2 250 and PERC 6/I controller w/ 8 Samsung HD204UI Green drives Time to interface from power switch: 22.4 seconds.
Reply
#5
I'm running 1360x768@60hz. As I've said this has nothing to do with resolutions or skins — I've tried switching them.
Reply
#6
Anyone? A couple of versions later the bug is still there.
Reply
#7
I've noticed the same thing with my Live Camelot install using the default skin at 720p. At first I thought it was due to the square setting in the video calibration setup, but after getting a ruler and making sure that thing was dead on square it still happens!

Doesn't bother me too much though. I just assumed it would be fixed somewhere down the line.
Reply
#8
i only have this issue if i mess with the calibration
when i reset it, the fonts look fine, so from now on i just have it at default
kinda annoying considering on the main screen the time is a bit cut off but whatever, the fonts just really bothered me, especially on the main screen menu
Reply



Weird slanted font bug00