[Linux] how to get digital audio output through hdmi and spdif simulaneously
#16
eggzenbeanz Wrote:hi,
Would it work for TOSLINK & HDMI into the same amp? I have an AVR amp and want my music to go through TOSLINK, but movie DTS, AC3 etc to go through HDMI using the same amp?
thanks

sure, why not? just plug your hdmi in e.g. dvd and toslink in e.g. cd.
Reply
#17
this works a treat, thanks so much.

I could never play music via hdmi through my avr then change the tv channel to play a game. It would always flip out. Now i can switch the avr to a toslink input and change the tv to play games.

top work, thanks

eggz
Reply
#18
einhänder Wrote:this is just a blind shot. but i'd try to set hdmi as the default audio device (connected to tv) while defining spdif/toslink as your passthrough device (connected to avr). the downmix option would be disabled in that case, since hdmi puts out all stereo signals anyway.

nevertheless you would have to use the posted asound.conf in case you want to output stereo signals via the passthrough device (spdif in your case) as well. if you wouldn't need stereo over your passthrough device it should work out of the box just by defining the devices in a correct way (e.g. like mentioned above).

Thanks for the reply.
Here are the set-up's i have tried :

Audio Output : "alsa: plug:iec958"
Passthrough output : "iec958"


SPDIF : AC3/DTS is passed through, Anything else is sent as stereo
HDMI : No Sound for all source material types

I understand why I am not getting output from the HDMI in this case.

Using your posted asound.conf file in place of mine and setting to below.
Audio Output : "default"
Passthrough Output : "default"


SPDIF : AC3/DTS is passed through, Anything else with a matching sample rate is outputed as stereo, Anything with a non-matching sample rate caused a "failed to init audio device error" in xbmc
HDMI : AC3/DTS NOT heard, Anything with a matching sample rate is outputed. Anything with a non-matching sample rate caused the "failed to init audio device error" in xbmc.

Almost there! Damn it Nod

So somehow i need to insert the "plug" command into the section that plays 2-ch pcm to ensure that the sample rate problems is taken care of. But I still need to find a method of also down-mixing the AC3/DTS for the HDMI channel.

Any advice would be much appreciated.

Thanks,
Anand
Reply
#19
Hi Anand

I don't know if you have found a solution to your problem. But here is what I've found.

I've used einhänder's setting for asound and xbmc's audio settings are:

Audio output: Digital
- Dolby digital (AC3) capable receiver: True
- DTS capable receiver: True
Audio output device: default
Passthrough output device: iec958
Downmix multichannel audio to stereo: true

My setup are:
ASRock 330 HT
XBMC 9.11

HTPC ---> HDMI ---> TV (stereo)
HTPC ---> Toslink / optical ---> HIFI (surround)


nigma2k Wrote:Thanks for the reply.
Here are the set-up's i have tried :

Audio Output : "alsa: plug:iec958"
Passthrough output : "iec958"


SPDIF : AC3/DTS is passed through, Anything else is sent as stereo
HDMI : No Sound for all source material types

I understand why I am not getting output from the HDMI in this case.

Using your posted asound.conf file in place of mine and setting to below.
Audio Output : "default"
Passthrough Output : "default"


SPDIF : AC3/DTS is passed through, Anything else with a matching sample rate is outputed as stereo, Anything with a non-matching sample rate caused a "failed to init audio device error" in xbmc
HDMI : AC3/DTS NOT heard, Anything with a matching sample rate is outputed. Anything with a non-matching sample rate caused the "failed to init audio device error" in xbmc.

Almost there! Damn it Nod

So somehow i need to insert the "plug" command into the section that plays 2-ch pcm to ensure that the sample rate problems is taken care of. But I still need to find a method of also down-mixing the AC3/DTS for the HDMI channel.

Any advice would be much appreciated.

Thanks,
Anand
Reply
#20
This is a great thread. Now I have my sound working exactly how I like it.

I can play audio to my tv when the receiver is off or I can tun the tv volume down and have audio going through the receiver when I want. No need to change settings in the audio menu to switch back and forth because I get simultaneousness audio out of both devices. I'm also getting great 5.1 audio through the receiver.

I also have normal xbmc menu sounds and it didn't break the sound for my emulators.

Here is my setup just in case anyone else wants to know.

*For my HTPC hardware you can see my signature. I'm using onboard HDMI and Optical Out
*I'm using HDMI for video/sound to the tv
*Optical out is connected to my receiver.


results from aplay -l:
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I used the exact asound.conf located in this thread.

XBMC Audio Settings:
Audio output = analog
speaker configuration = 5.1
Boost volume level on downmix = off (not really sure what this does)
Audio Output Device = Simultaneous output to RS880 Audio Device [Radeon HD 4200]
How to use Git
| AMD Athlon II X3 Triple Core Processor 2.9 GHz |GIGABYTE GA-MA785GM-US2H Mobo 2GB DDR2 Ram | MSI N430GT |
| Logitec Harmony Smart Control Remote| 52" Sharp Aquos LED TV | Denon AVR-X1000 |
| Freenas Server with 18TB ASRock Intel Avoton C2750 |
Reply



Logout Mark Read Team Forum Stats Members Help
[Linux] how to get digital audio output through hdmi and spdif simulaneously1
This forum uses Lukasz Tkacz MyBB addons.