[LIVE] Audio becomes garbled after a while
#1
Since I have updated my XBMC Live-distribution to beta2 I notice that every now and then the audio becomes garbled when playing music. This happens with both mp3-files and Shoutcast-stations and can be fixed by pressing pause and play again. Interesting detail: the garbled audio is actually visible on the visualizer as jittery spikes.

I have connected my Point of View ION-MB330-1 to my receiver using digital optical. XBMC Live has the default audio settings, I think it's 'default' and 'iec958' -- can't check atm. These settings have always worked fine.

Does someone have a clue?
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#2
I have the same problem if I set the screensaver to 'dim', when I set it to 'blank screen' it doesn't happen...
Reply
#3
THDN Wrote:I have the same problem if I set the screensaver to 'dim', when I set it to 'blank screen' it doesn't happen...

That's weird. I'll try disabling the screensaver, see what that does. Thanks for pointing me in this direction!
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#4
Seen a similar problem, with 9.11rc2 Live on an acer revo. After 15 minutes or so, the audio starts to get garbled (normal sound plus a distorted echo, the distortion seems very "digital"). A pause and a unpause seems to fix it.
Reply
#5
I have the exactly same, using optical out on nettop ion 330.
In my case screensaver has nothing to do with it.
Reply
#6
Sounds like an ION-related bug... has anyone looked at their log-files to see if there's any indication what is going on?
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#7
Sad 
x5nder Wrote:Since I have updated my XBMC Live-distribution to beta2 I notice that every now and then the audio becomes garbled when playing music. This happens with both mp3-files and Shoutcast-stations and can be fixed by pressing pause and play again. Interesting detail: the garbled audio is actually visible on the visualizer as jittery spikes.

I have connected my Point of View ION-MB330-1 to my receiver using digital optical. XBMC Live has the default audio settings, I think it's 'default' and 'iec958' -- can't check atm. These settings have always worked fine.

Does someone have a clue?

I'm using a Zotac IONITX (Atom 230) and experiencing the same issues. Interesting, no problem when playing videos with Dolby or DTS (both passthrough) with the same optical cable and receiver. It looks something with the MP3 decoder. Does anybody know how can I switch to another for testing?
Reply
#8
Same here...
Reply
#9
+1 for me, Asrock 330.
Reply
#10
I have the Asrock ION 330HT and the same issue, as described here.

I updated the ALSA drivers to 1.0.22 according to this link:
http://monespaceperso.org/blog-en/2009/1...oala-9-10/

Don't forget to do a
Quote:sudo apt-get update

Because without it I lost some things like wget.

Unfortunately this doesn't solve the problem. The symptoms are slightly changed, it looks like it take longer for the error to occur and the distortion seems to be less harsh.
Reply
#11
The garbled audio doesn't occur when I disable both the screensaver and visualization. Another thing I noticed: sometimes, instead of garbling the audio, XBMC just plain crashes. This happens mostly on Shoutcast-streams, never on smaller mp3-albums.

WEIRD.
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#12
I just upgraded to Camelot from the RC1 version. This doesn't solve the problem. The only fix is disabling the screensaver.

Mary X-mas, Joep
Reply
#13
This is what my log shows:

Quote:13:01:48 T:3077797776 M:1451110400 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush instead
13:04:29 T:3077797776 M:1450864640 ERROR: Unable to find host: DISKSTATION
13:08:03 T:3077797776 M:1451008000 ERROR: Unable to find host: DISKSTATION
13:10:08 T:3077797776 M:1451040768 WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush instead
13:11:39 T:3077797776 M:1450921984 ERROR: Unable to find host: DISKSTATION
13:15:14 T:3077797776 M:1450905600 ERROR: Unable to find host: DISKSTATION

DISKSTATION is the Synology Diskstation that contains my MP3 collection (SMB)
Reply
#14
Hmm. Updating to Camelot made it worse and disabling the screensaver doesn't help at all anymore. Will try to produce log-file tomorrow :-S
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#15
Camelot shows this for me as well. Screensaver and visualizations disabled doesn't seem to help. Seems to particularly happen on shoutcast streams. Every 10 minutes or so it starts to get garbled. Sometimes it will more or less correct itself after a few minutes, but generally needs a pause/play to fix it.

Using the analog audio out, vdpau enabled for video, vis off, screensaver off.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LIVE] Audio becomes garbled after a while00
This forum uses Lukasz Tkacz MyBB addons.