[LIVE] Audio becomes garbled after a while
#46
Mine seems to be working fine so far with optical out and iec938 as the output. Will test some more later though.
Reply
#47
I switched to HDMI out and iec938, and the problem seems to have gone away for me as well.
I am currently playing song number 6 in a row without any issues...Big Grin
Reply
#48
Got the same issue on Zotac Ion A XBMC live 9.11 and spdi/f over coax...
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
#49
Another test tonight and I'm on track 24 with no problems Big Grin

Seems like the change to iec938 for output device has fixed the problem for me.
Reply
#50
thomash72 Wrote:I tried switching to iec958 but doing this I don't hear any sound. I am using analog out, do I need to get HDMI or SPDIF working in order to use iec938 ? I have not tried this yet since I hear a lot of people are having trouble with this...

Likewise using analog out and iec958. Failed to initialize sound settings or something like that. Thats weird because nothing else could be handling audio, right? I'm not using my HDMI port for anything at the moment
Reply
#51
I have updated my kernel from 2.6.31-16 to 2.6.31-17, will check tonight if this fixes the problem too.
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#52
x5nder Wrote:I have updated my kernel from 2.6.31-16 to 2.6.31-17, will check tonight if this fixes the problem too.

Do you have good news for us?
Hardware:
1) PointOfView Intel Atom 330 Mainboard
2) Scenic-PC (2.9 GHz) with onboard Intel-Graphic 915g
Reply
#53
I installed yesterday morning XBMC 9.11 live to the HD and can confirm the audio probs with Shoutcast streams.Sad

BUT yesterday evening it worked for some hours continous without errors on "Shoutcast - Disco - LEMIXX 160kbps" stream.:confused2:

Using the same settings under Win7 (without VDPAU of course) with XBMC 9.11 works fine! But i dont like to run such an "overblown" os as a backend for a HTPC mediacenter only! Big Grin
So currently i am trying to switch to the linux version...

If i remember right i had the same probs with all other XBMC live versions since 9.04 i tested from CDROM - that includes all RC of 9.11 and the beta too.

(will check this later again...)


- now starting playback MP3s from the NAS ... -


______

XBMC Live 9.11 installed to test partitions
(XBMC 9.11 on Win 7 - on first partition)
System: Point of View ION-MB330-1 with 2 GB DDR2
Audio digital optical out -> Yamaha RX-V740 RDS Amp
HDMI video out -> Philips 42 PFL 3312

XBMC settings for audio:
Playback: playback next song automaticly (on), queue songs (off), playgain volume adjust (album level), crossfade (11 sec), crossfade same songs album (on), visualization (off)
Hardware: Digital, AC3 (on), DTS (on), default, IEC958, downmix (off)

XBMC settings for video:
Playback: render method VDPAU, adjust display refresh rate (off), sync playback (off), allowed error (off), VDPAU studio color (off)
Hardware: resolution [email protected] full screen, LCD/VCD (off)

XBMC settings screensaver: time 3 min, dim, use visualization (off), use dim (off), dim level 20%
--------------------------
NAS WinXP Fileserver for Media and TV with DVB S2 Sat-DVB Viewer Pro running as Server, using XBMC UDPNP playback the TV streams
--------------------------
Reply
#54
now after around an hour playing without errors the garbarge starts while playing back MP3s from the NAS Sad
sounds like an echo or so.
when fading into the next song it plays fine and clear again.
will now try to check the mp3 meta infos...

_edit 1_
both MP3s are 128kbps Shoutcast recordings - nothing special - hmmm...
_edit 1_

...now starting playback Shoutcast Stream...

_edit 2_
playing now about 3 hours - without errors
_edit 2_
Reply
#55
Jarny Wrote:Do you have good news for us?

With 2.6.31-17 my Shoutcast-stream keeps crashing XBMC within ten minutes. I have just reverted to 2.6.31-16, but now nmbd is giving me a PID error. Will look into it later today, but 2.6.31-17 seems to be a no-go for now...
Kodi v17 "Krypton" Beta 6 running on Amazon Fire TV (2014) with FLIRC receiver.
Reply
#56
my system info:
Linux 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8...
Uptime: 21 hours, 41 minutes
opengl vendor: NVidia
opengl version: 3.2.0 NVIDIA 190.53
Reply
#57
After some tests with Shoutcast i still get the errors sooner or later.
Pressing "pause" twice makes the music sound good again.
Reply
#58
I am getting the exact same thing on shoutcast. Using a Zotac ION mb, 1Gig ram, booting LIVE from a usb drive analog audio. Pressing pause then un-pause will correct the garbled audio. Sometimes it will crash and go to the command prompt.
Reply
#59
I have the problem since 9.11 update. So for about 1.5 months - I've been away for a month so havent been so active in trying to solve the issue. It only happens on music, not on films even if the soundtrack is mp3 encoded. This shows the issue could easily be power save related but all LCD powersaving features are off on my install.

I even tried changing the sound card three times. Originally I use an Edirol UA1-EX, I changed it to my Texas PCM2702 DAC and then tried the onboard analog output on my Acer revo.

The problem persists. I am using Arch using the latest 2.6.32 kernel, although the issue was still there with kernel 2.6.32.

The problem happened about every 3 track, seems like a little less with the PCM2702 DAC - which uses the same alsa driver as the UA1-EX.
Reply
#60
I am on Acer Aspire Revo R3610. I am seeing this problem as well.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LIVE] Audio becomes garbled after a while00