Problems with "External Player" (XBMC CPU Usage or error returning to XBMC)
#16
tiben20 Wrote:From your explorer with tortoise svn you right click on your xbmc folder and you select tortoise svn and then you will see create patch
and then you login on trac and go there http://trac.xbmc.org/newticket

Done: http://trac.xbmc.org/ticket/8362
Reply
#17
it's great to see that a Ticket has been submitted for this.

I hope it filters through to Tiben's build soon. Because his player is awesome, but coming back to XBMC from a blu-ray is a pain.
Reply
#18
I have exactly the same problem, and tried your patched executable, but it does *not* solve the problem. XBMC is still choppy and sluggish has to be restarted to reinstate performance after returning from using an external player for a long period of time (the problem doesn't occur if I only use the external player for a couple of minutes; but it does if I watch a whole movie - I haven't fooled around with it long enough to determine exactly what the threshold time is, but, still, this doesn't work for me.

Any other ideas or solutions?

Cheers
The REAL Joe
Reply
#19
Anyone get this figured out? I was able to use the modified .exe on my Atom PC and it worked, but not my Xeon.
Reply
#20
Mochilote Wrote:Finally i solved it. I download and compile camelot source code and get a solution for the returning to xbmc problem when hidexbmc=true.

In ExternalPlayer.cpp about line 330, i have added 2 lines:

....
m_bIsPlaying = false;
CLog::Log(LOGNOTICE, "%s: Stop", __FUNCTION__);

#if defined(_WIN32)
if (m_hidexbmc)
g_Windowing.Minimize();

g_Windowing.Restore();

if (currentStyle & WS_EX_TOPMOST)
....

Maibe it's not the best solution, but it works :-)

Here is the link to download Camelot + this patch (only xbmc.exe): http://www.megaupload.com/?d=RH873844


bye.


Top banana Mate./ I have been having this problem for a while but your script worked a treat.. Solved the problem for me.

Thanks
Reply
#21
johnbhoy Wrote:Top banana Mate./ I have been having this problem for a while but your script worked a treat.. Solved the problem for me.

Thanks

Having the same problem with new 10.0 BETA.. can it be fixed?
Enjoy OpenSource! :nod:
MY SETUP: XBMC 12 Frodo RC3, Multiple Asus EB1501's throughout the Home for XBMC based STB's
Reply
#22
It was fixed. Last week in trunk and yesterday in Dharma.
I didn't get feedback on the fix in the ticket so I'd appreciate confirmation by someone reading this thread (esp. for XP).
Always read the XBMC online-manual, FAQ, Wiki and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#23
Out of interest is there any way to get access to these latest SVN/Nightly builds of Dharma right now, or do you mean wait until Dharma is released/next beta and test then?

I'll admit Im thinking of testing different things rather than this issue, but I dont see anything newer than Dharma Beta 2 from the 14th Sept in either the public release or nightly download areas. Seemed worth an ask as if we have to wait til next release rolls round you might have a bit of a wait for fix confirmation Crystal Smile
Reply
#24
alexrose1uk Wrote:Out of interest is there any way to get access to these latest SVN/Nightly builds of Dharma right now, or do you mean wait until Dharma is released/next beta and test then?

I'll admit Im thinking of testing different things rather than this issue, but I dont see anything newer than Dharma Beta 2 from the 14th Sept in either the public release or nightly download areas. Seemed worth an ask as if we have to wait til next release rolls round you might have a bit of a wait for fix confirmation Crystal Smile
Alex - here is a link to unofficial builds of xbmc - though I wouldn't go identifying faults with them as they are 'unofficial' http://sshcs.com/xbmc/.

CrystalP - running great, Dharma SVN, but with Win7.
Reply
#25
Thanks
Reply
#26
Thanks for the confirmation.
Always read the XBMC online-manual, FAQ, Wiki and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply



Logout Mark Read Team Forum Stats Members Help
Problems with "External Player" (XBMC CPU Usage or error returning to XBMC)0
This forum uses Lukasz Tkacz MyBB addons.