ExternalPlayer -vo mpegpes via FF DVB-S Card
#1
Hi,

I still have to use my old Tube-TV, so my best picture is to send all video streams to the card which gets me a fine RGB signal to the good old tube. Using a new installed mplayer, works almost perfect on the cmd-line.

Now I want to start this as ExternalPlayer through XBMC. The video starts, but I cannot control the mplayer anymore. Is this normal or did I made something wrong?

Also, is there maybe a way of configuring the internal default video player to use the DVB Card as output when I compile by myself? So that every played video goes to the card?

This I would use then until I can buy a Flat TV Nod

My Setup:
POV 330-1 ION
Technotrend WinTV DVB-S rev1.5
XBMC 9.11(live): Camelot through a RC1 upgrade
Code:
<playercorefactory>
  <players>
    <!-- These are compiled-in as re-ordering them would break scripts
    The following aliases may also be used:
      audiodefaultplayer, videodefaultplayer, videodefaultdvdplayer
    <player name="DVDPlayer" audio="true" video="true"/>
</player>
    <player name="DVDPlayer" /> placeholder for MPlayer
    <player name="PAPlayer" audio="true" />
    -->

    <player name="mplayer2" type="ExternalPlayer" audio="true" video="true">
    <filename>/usr/bin/mplayer</filename>
        <args>"{0}" -vo mpegpes  -ao mpegpes</args>
        <hidexbmc>false</hidexbmc>
    
        <hideconsole>false</hideconsole>
        <warpcursor>none</warpcursor>
    </player>


  </players>

  <rules name="system rules">
    <rule name="rtv" protocols="rtv" player="DVDPlayer" />
    <rule name="hdhomerun/myth/rtmp/mms/udp" protocols="hdhomerun|myth|cmyth|rtmp|mms|mmsh|udp" player="DVDPlayer" />
    <rule name="lastfm/shout" protocols="lastfm|shout" player="PAPlayer" />

    <!-- dvdplayer can play standard rtsp streams -->
    <rule name="rtsp" protocols="rtsp" filetypes="!(rm|ra)"  player="PAPlayer" />

    <!-- Internet streams -->
    <rule name="streams" internetstream="true">
      <rule name="flv/aacp/sdp" mimetypes="video/x-flv|video-flv|audio/aacp|application/sdp" player="DVDPlayer" />
      <rule name="mp2" mimetypes="application/octet-stream" filetypes="mp2" player="PAPlayer" />
    </rule>

    <!-- DVDs -->

    <rule name="dvd" dvd="true" player="mplayer2" />
    <rule name="dvdfile" dvdfile="true" player="mplayer2" />
    <rule name="dvdimage" dvdimage="true" player="mplayer2" />
<!--
    <rule name="dvd" dvd="true" player="videodefaultdvdplayer" />
    <rule name="dvdfile" dvdfile="true" player="videodefaultdvdplayer" />
    <rule name="dvdimage" dvdimage="true" player="videodefaultdvdplayer" />
-->
    <!-- Only dvdplayer can handle these normally -->
    <rule name="sdp/asf" filetypes="sdp|asf" player="DVDPlayer" />

    <!-- Pass these to dvdplayer as we do not know if they are audio or video -->
    <rule name="nsv" filetypes="nsv" player="DVDPlayer" />
  </rules>
</playercorefactory>


Any hints would be fine, or even the light @ the end of the tunnel.

Thanks

JCB
Reply
#2
If your using a remote control with lirc then you will need to add key assignments to your .lircrc in your home directory for mplayer to work. There are quite a few posts in the forum that should help you out.
Reply
#3
Hi daledude,

thanks for that. I just thought, there is another way, cause many others have used external players, but never mentioned that. So I hoped xbmc routes the commands to the client it just started.

Thanks for Your help. I will try that.

JCB
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
ExternalPlayer -vo mpegpes via FF DVB-S Card00