Cannot shutdown from within XBMC
#16
Has anyone actually posted a bug on the trac for this yet?
Reply
#17
Yep. I just created one here: http://trac.xbmc.org/ticket/8406
Reply
#18
I have attached my log file and the log file Drumaster12 posted (hope you dont mind) to the trac as I know the xbmc dev's like there log files.
Reply
#19
I fixed the Suspend, Shutdown, Reboot commands with this info from this post.


http://forum.xbmc.org/showpost.php?p=448...stcount=54

I have not removed firefox so all is good.

If you already have:
policykit-1
devicekit-power

Just force reinstall on them IF after creating that file you still have problems...
Reply
#20
essence25 Wrote:I fixed the Suspend, Shutdown, Reboot commands with this info from this post.


http://forum.xbmc.org/showpost.php?p=448...stcount=54

I have not removed firefox so all is good.

If you already have:
policykit-1
devicekit-power

Just force reinstall on them IF after creating that file you still have problems...

This worked for me as well by doing the following.

PHP Code:
[Actions for xbmc user]
Identity=unix-user:xbmc
Action
=org.freedesktop.devicekit.power.*;org.freedesktop.consolekit.system.*
ResultActive=yes
ResultAny
=auth_admin
ResultInactive
=yes 
Paste the above text into
sudo nano /var/lib/polkit-1/localauthority/50-local.d/custom-actions.pkla

then I
sudo apt-get remove policykit-1
sudo apt-get remove devicekit-power

Note: May only need to type "sudo apt-get -f install devicekit-power"

then reboot.

The question though is why we have had to do this?
Reply
#21
Drumaster12 Wrote:The shutdown functions I see available are: ?0? and ?-1?. I don't know what these mean, but I've tried both of them and I get the same result.

What language is your system running at ? You should have "Quit", "Shutdown", "Suspend"
The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
Reply
#22
Thank you all for your help. That fix worked for me too after removing the device packages.
Reply
#23
I am running in English, apparently when the code got jacked up it made the shutdown options display ?0? and ?-1?. now that I applied the fix, everything's back to normal (and plain English)
Reply
#24
Now that we have this fixed, perhaps some devs can clarify why this has happened in the first place....

Also under those shutdown options do you see "Suspend" & "Hibernate" correct?
Nothing else right?
Reply
#25
essence25 Wrote:Now that we have this fixed, perhaps some devs can clarify why this has happened in the first place....

Also under those shutdown options do you see "Suspend" & "Hibernate" correct?
Nothing else right?

No you should also see shutdown and restart. I had the same and found that in the original post there was an erroneous space in /var/lib/polkit-1/localauthority/50-local.d/custom-actions.pkla
e.g. (second freedesktop)
PHP Code:
Action=org.freedesktop.devicekit.power.*;org.freed esktop.consolekit.system.* 
should be
PHP Code:
Action=org.freedesktop.devicekit.power.*;org.freedesktop.consolekit.system.* 
Reply
#26
Yes, I was aware of that space and corrected it. But thats not the options I'm refering to. These are the two options under setup "power action" etc...
I think these are the only options there...
Reply
#27
Yea, I understood that.
As I stated, in that option you should see shutdown, restart, suspend and hibernate.
Reply
#28
As a side not for those folks that want a browser.

I grabbed Chromium from the nightly dev PPA. It grabs minimal depends and works great. Very fast.

I wonder if it (or another browser) could be used as a built-in browser for XBMC? Something that comes up on the home menu with Video/Music/Settings/whatnot...
Reply
#29
HELP!!! I've run:

sudo apt-get remove policykit-1
sudo apt-get remove devicekit-power

Now my XBMC LIVE won't boot! it dumps me at the login prompt! Damn this FireFOX!!!
Reply
#30
On a minimal Ubuntu 10.10 (Maverick) install (from the XBMCbuntu guide) the solution was to install the upower package. That package has replaced devicekit-power on newer Ubuntus.

Code:
sudo apt-get install upower
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Cannot shutdown from within XBMC00