XBMC Live and Antec Micro Fusion 350
Hi all,

I've replaced my old xbox with xbmc for a proper Atom Ion based htpc several months back. I've tried to get the remote and display running on xbmc 9.04 and the new 9.11 but some how I can't get it done.

Where to start? What's the right way? And who managed to get it up and running?

Thanks in advance!

I have the same problem here with the live version. I have a Compro K300 MCE compatible remote which works with XBMC live on a different system but the range of that remote is very, very pour.
The same Live version (9.11) does not "see" the Antec Fusion remote nor the vfd.
I will make an hdd install and look further into it. But if someone has sorted this out, please let us know.

Is help still required for the antec micro fusion 350. I have this setup working perfectly with the LCD working. If you are still looking for a solution post back and i'll upload a how-to, don't want to waste time, but am willing to help.

My setup;
Antec micro fusion 350 with the built in (imon) lcd and ir with the rm100 remote (mini pad). The remote can also be replaced using an mce remote aswell.

My lCD in action:
My remote:
Having similar issues, so i'm interested atleast ;-)
This is for those out there that are having problems with installing the imon RM100 remote and LCD that comes with the Antec Micro Fusion 350.

I know there are a few tutorials here on the forums detailing how to install the imon LCD/VFD, however people seem to be using some other sort of remote such as MCE and other have had problems like me.

The instructions below have proven to work on my setup of XBMC Live 9.11 Repack (Dec 2009), with Antec micro Fusion 350.

Here is a pic of the remote in question:



From terminal (on HTPC Ctrl + Alt + F1, or SSH eg. google: Putty) type the following.

sudo apt-get install lirc

sudo dpkg-reconfigure lirc

Then select "Soundgraph imon ir/lcd"
Then select "none"

The following should be displayed:

* Loading LIRC modules [ OK ]

* Starting remote control daemon(s) : LIRC [ OK ]


nano /etc/modprobe.d/lirc.conf

Then copy the following into the new document:

options lirc_imon debug=0 nomouse=1 display_type=2 ir_protocol=0 pad_thresh=5

Hit "Ctrl + x", then "y" then "enter"

Type the following:

nano /etc/lirc/lircd.conf

Copy and paste the following:

# this config file was hand-generated
# using lirc-0.8.5-CVS (imon) on Wed Jan 14 2009
# contributed by Michel Quercia <michel.quercia|prepas.org>
# brand:                       Antec Veris
# model no. of remote control: RM100 (Rebadged iMon PAD)
# devices being controlled by this remote:
#     -Antec Veris Fusion 350
# nb: most codes appear to come in with an initial keypress value, as well as
# a "this key is no longer being pressed" value, which is "key | 0x00004000"

begin remote

  name   Antec_Veris_RM100
  bits                  64
  eps                   30
  aeps                 100

  one              0     0
  zero             0     0
  gap               139998
  ignore_mask 0x0000000000000301
  min_repeat             1
  toggle_bit             0

      begin codes
          KEY_EXIT                 0x288195b700000101 # AppExit
          KEY_POWER                0x289115b700000101 # Power
          KEY_BACKSPACE            0x0200002a00000000 # Backspace
          KEY_UP                   0x2aa515b700000101 # Pad Up
          RightMenu                0x0200006500000000 # Right Menu
          KEY_LEFT                 0x29a515b700000101 # Pad Left
          KEY_ENTER                0x0200002800000000 # ENTER
          KEY_RIGHT                0x2ba515b700000101 # Pad Right
          KEY_VOLUMEUP             0x28a395b700000101 # VOL +
          KEY_DOWN                 0x289515b700000101 # Pad Down
          KEY_CHANNELUP            0x289395b700000101 # CH +
          KEY_VOLUMEDOWN           0x28a595b700000101 # VOL -
          KEY_MUTE                 0x2b9595b700000101 # Mute
          KEY_CHANNELDOWN          0x288795b700000101 # CH -
          KEY_REWIND               0x298315b700000101 # Rewind
          KEY_PLAY                 0x2a8315b700000101 # Play
          KEY_FASTFORWARD          0x2b8315b700000101 # Fast Forward
          Go                       0x2ab195b700000101 # Go
      end codes

end remote

Hit "Ctrl + x" then "y" then "return".
(this lirc.conf was downloaded from here: http://lirc.sourceforge.net/remotes/, so you can see here if your remote is different)

Now type:

nano /etc/lirc/hardware.conf

Copy and paste the following:

# /etc/lirc/hardware.conf

#Chosen Remote Control

REMOTE="Soundgraph iMON IR/LCD"

REMOTE_MODULES="lirc_dev lirc_imon"





#Chosen IR Transmitter







#Enable lircd

#Don't start lircmd even if there seems to be a good config file


#Try to load appropriate kernel modules

#Default configuration files for your hardware if any

#Forcing noninteractive reconfiguration

#If lirc is to be reconfigured by an external application

#that doesn't have a debconf frontend available, the noninteractive

#frontend can be invoked and set to parse REMOTE and TRANSMITTER

#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure

#to leave this set to "false"






sudo /etc/init.d/lirc restart

sudo irw

Now in the terminal you should see some output when you push the buttons on the remote.

If not then you can try the following, if you do skip to step 2.


sudo irrecord /etc/lirc/remote1.conf -d /dev/lirc0 --disable-namespace

Following the instructions using the enter button on your remote. NOTE: Follows the steps asked for each button and finish by pressing return for the final time. After recording try the restart and irw commands again as above and all should be outputting codes to your terminal.
Now nano /etc/lirc/lirc.conf again and overwrite with the code above otherwise your (Enter button will be 'pressed' after releasing some of the other buttons [RM100 only]).


Now it is time to map those button to XBMC.

nano /usr/share/xbmc/system/Lircmap.xml

Copy and paste:

<remote device="Antec_Veris_RM100">

















Hit "Ctrl + x" then "y" then "Return" (note if you are keeping your recorded lirc.conf you must use <xbmclable>WHAT_YOUNAMED_THE_BUTTON</xbmclable>)
NOTE: Notice that the name of the remote in the lirc.conf must be the same in the device in the Lirckey.xml

Reboot your HTPC and you should have a fully working RM100 Veris Remote
In my setup I emitted the /home/{USER}/.xbmc/keymaps/remote.xml so that <power> actually suspended the system. To do this use this code <power>XBMC.Suspend()</power> to replace the existing <power> entry in the global tree.


The LCD is next.


sudo apt-get update

sudo apt-get install lcdproc

nano /etc/LCDd.conf

Change the LCDd.conf as below:



* delete #'s infront of ServerScreen and OnExit
Hit "Ctrl + w" the type "0038" then hit "return", change:



Hit "Ctrl + x" then "y" then "Return"


sudo /etc/init.d/LCDd restart

Now enable lcd/vfd in xbmc settings=>System=>Video Output
and reboot

Your LCD should now work, it should also turn its backlight off when you suspend xbmc.

Now type:

nano /home/{USER}/.xbmc/userdata/advancedsettings.xml

Copy and paste the following (this will slow down the scroll and look better, choose a number between 1-10). The Rows and Columns are as required 2x16.)

  <rows>2</rows>                        <!-- Number of rows to use for the LCD. -->
  <columns>16</columns>                 <!-- Number of columns to use for the LCD. -->
  <scrolldelay>8</scrolldelay>          <!-- Delay of the scroller widget. Defaults to 1. -->

Hit "Ctrl + x" then "y" then "Return"

Now edit your LCD.xml as you would like it too show. Found at /home/{USER}/.xbmc/userdata/LCD.xml
Remember the LCD only shows two rows, however you can have a third as a backup if say <line>2</line> doesn't display. See the XBMC wiki LCD.xml for more info on what you can display.

Reboot and enjoy your new setup

My lCD in action:

The following guids were used

See here for lirc.conf 's:

See here for XBMC LCD INFO labels:

Hope this helps
excellent, had most of the remoteconfig solved already but got some questionmarks cleared and the lcd is up and running perfectly, thanks m8! =)
No problem, I'm glad to help. Hope this helps others too, just post a question if you have any and I'll do my best to answer.
@NebulaOdyssey, awesome! I tried XBMCLive on this a few months ago and couldn't get my remote/LCD working. Switched to Windows 7.... now it looks like I am going to switch back. I can't wait to get a free day to try this out.
synapseattack Wrote:@NebulaOdyssey, awesome! I tried XBMCLive on this a few months ago and couldn't get my remote/LCD working. Switched to Windows 7.... now it looks like I am going to switch back. I can't wait to get a free day to try this out.

If you need any help when you do get chance just post back and I'll attempt to help.

perhaps a mod can put this in HOW-TO?
any1 got the lcd to shutdown properly? seems like something probes the usb during the final stages of shutdown (ubuntu 9.10)
I have never managed to get it to turn off. In the lcdd.conf i've selected to display the time on shut-down, which it seems to do on the odd occasion randomly when it wants too. If i select to keep the 'good-bye' message it keeps this on the display every time, it seems buggy?

However i always hibernate my system (mapped my remote power to hibernate), and this turns off the LCD. Hope this is good enough for you? If not then i don't know of anyone managing to get it to stay off when actually shutting down.
Great Nebula, i'm ok until

sudo irw

and it show things like

2aa515b700000101 00 KEY_UP Antec_Veris_RM100
2aa515b700000101 00 KEY_UP Antec_Veris_RM100
289515b700000101 00 KEY_DOWN Antec_Veris_RM100

copied your map file but nothing happen on xbmc interface.. why ?

Thank you
microchip1974 Wrote:sudo irw

and it show things like

2aa515b700000101 00 KEY_UP Antec_Veris_RM100
2aa515b700000101 00 KEY_UP Antec_Veris_RM100
289515b700000101 00 KEY_DOWN Antec_Veris_RM100
Ok this bit is perfectly right and indicated the remote is working and the machine is picking up the signals. The problem must be with the lircmap.xml or the location of it.

Quote:copied your map file but nothing happen on xbmc interface.. why ?

Put the Lircmap.xml in the local location instead, as this has higher priority.

I think the location is:
Where username is your user, you probably made the user "xbmc".

So just nano the location above copy my lircmap.xml into it, press Ctrl+x then 'Y' then Enter.

Now reboot xbmc and see if this works? Get back to me of not, i'll be in a better position to help Monday evening as i'll be back with my HTPC so can give you a better indication of paths; though I think this is right.
What can i say ? Just thank you. it works perfect.

Another question Nebula. I have also a MCE remote from my sony Vaio VCG-LA2 (i think it is a standard MCE Remote ) i f i would like to use it instead of the Veris Remote for using more buttons, do you have a guide for me or maybe some step to try ?
Great job anyway.
the remote code maybe can help. is RM-MCE20E
i've found this but i don't know if can help.

Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
XBMC Live and Antec Micro Fusion 35000