•   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  •   
[AppleTV] Broadcom Crystal HD Decoder Apple TV step-by-step installation guide
oezkan12 Wrote:I'm still onyl see the XBMC Version 9.11 in the Launcher 3.2.2.

defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array http://www.sshcs.com/xbmc/Info.asp

did not helped anyway.

Could it be that this is temporarly offline? seems that the nighty builds are not available at this moment ..

Can someone help?

try the official mirrors (see above comment for what you need to do) and reboot your atv...
Reply
Thought I would post here since it's on topic regarding the CrystalHD chip.

So following the guide on Here I am having the issue of my rc.local file adding in periods on the front and back of the kext. The rc.local reads:

./sbin/turbo_atv_enabler.bin.
./sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext.

I had tried this several times before finding out the problem. Finally i took the text in step 7 and paste it to wordpad. Edited out the " used in the syntax, and got it to write successfully on the next attempt. But because of that, my rc.local now reads:

/sbin/turbo_atv_enabler.bin
./sbin/turbo_atv_enabler.bin.
./sbin/turbo_atv_enabler.bin.
./sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext.
./sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext.
/sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext


I am using WinSCP to log onto the ATV to run the commands. There is an "Edit" option when right clicking the file on the ATV, but it doesn't allow me to edit it giving me a "permission denied" error. I also tried copying rc.local to my local drive, editing it locally, then copying it back to /etc but again, it gives me permission errors. Oddly enough though I can copy it to other folders like /tmp and Front_Row.

Following the guide, it seems that using " in the step 7 cut and paste is what seems to give people issues, i just can't seem to correct the file. I don't know if this in turn doesn't allow me to download the nightly builds as the option doesn't show under my downloads; as well it doesn't show me the CrystalHD option as a renderer.

Any suggestions?

-Z
Reply
zcast Wrote:Thought I would post here since it's on topic regarding the CrystalHD chip.

So following the guide on Here I am having the issue of my rc.local file adding in periods on the front and back of the kext. The rc.local reads:

./sbin/turbo_atv_enabler.bin.
./sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext.

I had tried this several times before finding out the problem. Finally i took the text in step 7 and paste it to wordpad. Edited out the " used in the syntax, and got it to write successfully on the next attempt. But because of that, my rc.local now reads:

/sbin/turbo_atv_enabler.bin
./sbin/turbo_atv_enabler.bin.
./sbin/turbo_atv_enabler.bin.
./sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext.
./sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext.
/sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext


I am using WinSCP to log onto the ATV to run the commands. There is an "Edit" option when right clicking the file on the ATV, but it doesn't allow me to edit it giving me a "permission denied" error. I also tried copying rc.local to my local drive, editing it locally, then copying it back to /etc but again, it gives me permission errors. Oddly enough though I can copy it to other folders like /tmp and Front_Row.

Following the guide, it seems that using " in the step 7 cut and paste is what seems to give people issues, i just can't seem to correct the file. I don't know if this in turn doesn't allow me to download the nightly builds as the option doesn't show under my downloads; as well it doesn't show me the CrystalHD option as a renderer.

Any suggestions?

-Z

You don't need the period in front when the path is from root of the filesystem Smile Also the period at the end is also wrong. Remove them.

/sbin/turbo_atv_enabler.bin


WinSCP does not have permission to edit something in "/etc". That directory is owned by "root" and you can't login as "root".
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
FYI, another log with slowdown: http://pastebin.com/m581a0312
Reply
davilla Wrote:You don't need the period in front when the path is from root of the filesystem Smile Also the period at the end is also wrong. Remove them.

/sbin/turbo_atv_enabler.bin


WinSCP does not have permission to edit something in "/etc". That directory is owned by "root" and you can't login as "root".

Can you give some ideas on how to edit the file and insert it back into /etc ?

-Z
Reply
zcast Wrote:Can you give some ideas on how to edit the file and insert it back into /etc ?

-Z
ssh in

sudo nano /etc/rc.local


add your bits

control-x writes the file and quits.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
oezkan12 Wrote:I'm still onyl see the XBMC Version 9.11 in the Launcher 3.2.2.

defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array http://www.sshcs.com/xbmc/Info.asp

did not helped anyway.

Could it be that this is temporarly offline? seems that the nighty builds are not available at this moment ..

Can someone help?

Make sure you are not superuser when you do it.
(no sudo or sudo -s etc)
Reply
oezkan12 Wrote:I'm still onyl see the XBMC Version 9.11 in the Launcher 3.2.2.

defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array http://www.sshcs.com/xbmc/Info.asp

did not helped anyway.

Could it be that this is temporarly offline? seems that the nighty builds are not available at this moment ..

Can someone help?

Last night I had the same problem. I've done a lot of :

defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array http://www.sshcs.com/xbmc/Info.asp

but I couldn't see any new XBMC additional download.
So I was not able to finish the installation my new Broadcom card (arrived just yesterday).

Could it be offline ?
Someone can give us instruction for manually installation ?

Thank you a lot in advance !
Reply
raf63 Wrote:Last night I had the same problem. I've done a lot of :

defaults write com.teamxbmc.xbmclauncher XBMCAdditionalDownloadPlistURLs -array http://www.sshcs.com/xbmc/Info.asp

but I couldn't see any new XBMC additional download.
So I was not able to finish the installation my new Broadcom card (arrived just yesterday).

Could it be offline ?
Someone can give us instruction for manually installation ?

Thank you a lot in advance !

reboot after changing com.teamxbmc.xbmclauncher.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
I use the late 2009 mac mini - I think that's not possible to use the crystal hd. Isn't it?

Best

Wikus
Reply
Wikus Wrote:I use the late 2009 mac mini - I think that's not possible to use the crystal hd. Isn't it?

Best

Wikus

If the MacMini has the nvidia chipset, no crystalhd for you. Boot to linux and enjoy full hw based decode under VDPAU.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
purplechris Wrote:[...]
http://www.blogythefox.co.uk/2010/01/09/...tallation/ [...]

Hi there,

Bandwith ist exceeded Sad Is there any known mirror?

If installed the hardware and updated to Launchpad 3.2.2 and the current nightlie build... but can't finde the render Option for CrystalHD...

i thought this guide would help me Sad

Greets Zuph
Reply
Smile 
Zuphael Wrote:Hi there,

Bandwith ist exceeded Sad Is there any known mirror?

If installed the hardware and updated to Launchpad 3.2.2 and the current nightlie build... but can't finde the render Option for CrystalHD...

i thought this guide would help me Sad

Greets Zuph

Hello,

look there and have fun Smile

http://todayguesswhat.blogspot.com/2010/...le-tv.html

Check under "Settings -> Video -> Playback -> Render method", there is an option Auto-Detect, which could be changed to "Broadcom Crystal HD"

Greets
Guido
Reply
wow thats great Smile

the image works and the render could be selected... now image and sound are out of synch... tried each sync-way no change...?!

Is there a need to reboot the atv after changing? any tips for that particular problem? Couldn't find anything in the thread or forum (for atv/osx), or i'm blind Wink
Reply
I'll guess I'll wait till May when the next stable release comes with built-in support for the Crystal HD. I don't want to mess everything up.
Reply
  •   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[AppleTV] Broadcom Crystal HD Decoder Apple TV step-by-step installation guide51