XBMC and Mac Firewall Popup
Hi, I've been using XBMC under Leopard on a Mini for a while, switched to Plex last year but decided to give Camelot a go and I love it.

Only problem is every time I start XBMC now, I get a pop up that says:

Do you want the application "XBMC.app" to accept incoming network connections?

With buttons for Allow / Deny underneath.

It doesn't matter what I click, the next time I start XBMC I get the pop up again.

My firewall is set to "Set access for specific services". I've gone into the firewall settings, removed the entry and added it manually, repaired permissions, nothing works.

The only way I can get it to stop coming up is to choose either "Allow all incoming connections" or "Allow only essential services", neither of which are ideal.

Any ideas?
Looks like this is a code signing issue, I think it's been mentioned before on the forums.

From looking at this ticket, it doesn't look like it's going to be sorted.
Not going to pursue this, Digital signed code and FLOSS just does not mix and the benefits are not worth the effort. Users can easily add XBMC to the 10.5/10.6 firewall exceptions should they need it.

I do have it added to the firewall exceptions and I'm still having the problem. If not everybody is getting the issue, it looks like it's something on my computer...

Hmm. Sucks.
Did anyone fix this problem?

I am having the same problem.

I also have had similar problems with a few other programs.

I was told for people that are having the problem with iTunes that you can disable Bonjour to fix this.

Curious if anyone had any luck fixing this.
I just started using XBMC and I have this same issue. Everytime I start XBMC, I get the popup "Do you want the application "XBMC.app" to accept incoming network connections?"

I also have XBMC added to my firewall settings "Allow incoming connections"

Has anyone found a solution?

I think it may be an apple bug as when I have it on, it doesn't remember any applications - not even apple apps like itunes.

I got frustrated and turned it off.

Flirc now has a forum: forum.flirc.tv
Same issue here!

iMac , OS X 10.9.5, Time Capsule 2TB
AppleTV1 & 3, iPhone 6, iPad mini
XBMC Remote App
XBMC ATV1 Chrystalbuntu
Kodi OSX
egoldy Wrote:Did anyone fix this problem?.

Ran into this problem after installing a couple of add-ons. The problem is that the signature of the file was somehow corrupted. Rather than reinstall you can create a self-signed certificate and resign the xbmc.app:

1. Verify the signature of xbmc.app:

From TERMINAL type the following:
'codesign -vvv /Path/To/xbmc.app'
if the result includes the message 'a sealed resource is missing or invalid' then move on to step 2.
2. Create a Self Signed Certificate

- Open Applications > Utilities > Keychain Access.
- From the Keychain Access menu, choose Certificate Assistant > Create a Certificate.
- Fill in a name for the certificate. This name appears in the Keychain Access utility as the name of the certificate. This is also the name you will use when referencing this certificate.
- Choose Self Signed Root from the Type popup menu.
- Check the Let me override defaults checkbox.
- Choose Code Signing from the Certificate Type menu.
Click Continue.
Specify a serial number for the certificate. Any number will do as long as you have no other certificate with the same name and serial number.
- Fill in the information for the certificate.
- Accept the defaults for the rest of the dialogs.

3. Re-sign xbmc.app:

From TERMINAL type the following:

'codesign -s "NAME OF CERTIFICATE" -f /Path/To/xbmc.app'

4. Verify the signature of xbmc.app:

From TERMINAL type the following:
'codesign -vvv /Path/To/xbmc.app'
if the result includes the message 'satisfies its Designated Requirement' you are good - move on to step 5.

5. Delete and re-add xbmc.app to firewall exceptions (System Preferences)

You should no longer be prompted to allow incoming connections!Big Grin

By the way, this same procedure will work for all your other apps including iTunes etc. Clearly not an XBMX issue.
If it works for you please add to my rep!!
To add since XBMC is already signed you may need to add a -f to replace the existing code signature in step 3

codesign -f -s "NAME OF CERTIFICATE" -f /Path/To/xbmc.app

Thanks for the post codisgod, saved me a lot of time.
sparcxl Wrote:Thanks for the post codisgod, saved me a lot of time.

Glad it helped!! I've spent hours sorting out these minor issues and hoped it would be useful to someone else.
I have recently turned off the MacOSX 10.7 Application Filtering firewall (The simple one found under System Preferences > Security) and have activated Packet Filtering (PF) firewall. I did so as I needed more control over the firewall so I could, for example, work directly with ports.

Anyways turning off the Application Filtering Firewall seems to have stopped the 'Accept Incoming Network Connections' issue with XBMC.

BTW configuring PF by hand / through config files is not something I wanted to do. I found http://www.openbsd.org/faq/pf/example1.html which would have helped but instead I found IceFloor app for MacOSX 10.7 that is a gui front end and simplified the task significantly.


Brooke Nod
(2012-01-20, 07:48)sparcxl Wrote: To add since XBMC is already signed you may need to add a -f to replace the existing code signature in step 3

codesign -f -s "NAME OF CERTIFICATE" -f /Path/To/xbmc.app

Thanks for the post codisgod, saved me a lot of time.


I too am encountering the same issue. However, when I tried your solution, I rceived an error as follow:

object file format unrecognized, invalid, or unsuitable

Is there something that I have to have installed prior to performing your steps?

This thread helped me an awful lot but only by reading that you have to install (I did) XCode form the App Store and within XCode turn on the Command Line Tools. You will find them in the Preferences of XCode.

After that this line:

codesign -f -s "MySelfMadeCertificate" -f /Volumes/HardDisk/Applications/XBMC.app

went smooth and came back with the (after checking with this line):

codesign -vvv /Volumes/HardDisk/Applications/xbmc.app

that "it satisfied its Designated Requirement". I then removed and re-added XBMC to the firewall. Problem solved.

Thanks to all in the thread that putted me on the right track.
wlgspotter: had the same problem under mointain lion. What worked:
Before the codesign -fs ... step, enter the following commands.

export CODESIGN_ALLOCATE="/Applications/Xcode.app/Contents/Developer/usr/bin/codesign_allocate"

Then do the codesign step. Don't ask me why exactly this works, got this from a post on stackoverflow.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Logout Mark Read Team Forum Stats Members Help
XBMC and Mac Firewall Popup1
This forum uses Lukasz Tkacz MyBB addons.